aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/haproxy-devel/Makefile3
-rw-r--r--net/haproxy-devel/files/patch-Makefile11
-rw-r--r--net/haproxy/Makefile2
-rw-r--r--net/haproxy/files/patch-Makefile11
4 files changed, 3 insertions, 24 deletions
diff --git a/net/haproxy-devel/Makefile b/net/haproxy-devel/Makefile
index 45d44f7fa992..99b75b5e01fd 100644
--- a/net/haproxy-devel/Makefile
+++ b/net/haproxy-devel/Makefile
@@ -24,7 +24,8 @@ DEVICEATLAS_DISTFILE= deviceatlas-enterprise-c-${DEVICEATLAS_VERSION}
DEVICEATLAS_REGISTRATION_URL= https://deviceatlas.com/deviceatlas-haproxy-module
MAKE_ARGS= TARGET=freebsd DEFINE=-DFREEBSD_PORTS USE_GETADDRINFO=1 \
- USE_ZLIB=1 USE_CPU_AFFINITY=1 CC="${CC}" DEBUG_CFLAGS="" OPTIONS_CFLAGS="${CFLAGS}"
+ USE_ZLIB=1 USE_CPU_AFFINITY=1 CC="${CC}" CFLAGS="${CFLAGS} -fno-
+strict-aliasing -fwrapv"
OPTIONS_DEFINE= DOCS EXAMPLES LUA OPENSSL DEVICEATLAS
OPTIONS_RADIO= PCRE
diff --git a/net/haproxy-devel/files/patch-Makefile b/net/haproxy-devel/files/patch-Makefile
deleted file mode 100644
index 3c74b35769c9..000000000000
--- a/net/haproxy-devel/files/patch-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig 2017-04-19 13:18:14.404480000 +0300
-+++ Makefile 2017-04-19 13:18:26.684393000 +0300
-@@ -128,7 +128,7 @@ DEBUG_CFLAGS = -g
- #### Compiler-specific flags that may be used to disable some negative over-
- # optimization or to silence some warnings. -fno-strict-aliasing is needed with
- # gcc >= 4.4.
--SPEC_CFLAGS = -fno-strict-aliasing -Wdeclaration-after-statement
-+SPEC_CFLAGS = -fno-strict-aliasing -Wdeclaration-after-statement -fwrapv
-
- #### Memory usage tuning
- # If small memory footprint is required, you can reduce the buffer size. There
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index 45e535d8fef4..1e3771e1e005 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -23,7 +23,7 @@ DEVICEATLAS_DISTFILE= deviceatlas-enterprise-c-${DEVICEATLAS_VERSION}
DEVICEATLAS_REGISTRATION_URL= https://deviceatlas.com/deviceatlas-haproxy-module
MAKE_ARGS= TARGET=freebsd DEFINE=-DFREEBSD_PORTS USE_GETADDRINFO=1 \
- USE_ZLIB=1 USE_CPU_AFFINITY=1 CC="${CC}" DEBUG_CFLAGS="" OPTIONS_CFLAGS="${CFLAGS}"
+ USE_ZLIB=1 USE_CPU_AFFINITY=1 CC="${CC}" CFLAGS="${CFLAGS} -fno-strict-aliasing -fwrapv"
OPTIONS_DEFINE= DOCS EXAMPLES LUA OPENSSL DEVICEATLAS
OPTIONS_RADIO= PCRE
diff --git a/net/haproxy/files/patch-Makefile b/net/haproxy/files/patch-Makefile
deleted file mode 100644
index 3c74b35769c9..000000000000
--- a/net/haproxy/files/patch-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig 2017-04-19 13:18:14.404480000 +0300
-+++ Makefile 2017-04-19 13:18:26.684393000 +0300
-@@ -128,7 +128,7 @@ DEBUG_CFLAGS = -g
- #### Compiler-specific flags that may be used to disable some negative over-
- # optimization or to silence some warnings. -fno-strict-aliasing is needed with
- # gcc >= 4.4.
--SPEC_CFLAGS = -fno-strict-aliasing -Wdeclaration-after-statement
-+SPEC_CFLAGS = -fno-strict-aliasing -Wdeclaration-after-statement -fwrapv
-
- #### Memory usage tuning
- # If small memory footprint is required, you can reduce the buffer size. There