aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/zita-convolver/Makefile3
-rw-r--r--biology/phyml/Makefile3
-rw-r--r--databases/percona56-server/Makefile2
-rw-r--r--databases/pg_citus/Makefile3
-rw-r--r--databases/soci/Makefile3
-rw-r--r--devel/arpc/Makefile3
-rw-r--r--devel/critcl/Makefile3
-rw-r--r--devel/cxxtools/Makefile2
-rw-r--r--devel/libffcall/Makefile3
-rw-r--r--devel/ppl/Makefile3
-rw-r--r--devel/subversion-static/Makefile3
-rw-r--r--dns/bundy/Makefile2
-rw-r--r--games/crafty/Makefile3
-rw-r--r--graphics/a2png/Makefile3
-rw-r--r--japanese/man/Makefile3
-rw-r--r--lang/go14/Makefile6
-rw-r--r--lang/mono/Makefile6
-rw-r--r--lang/racket-minimal/Makefile2
-rw-r--r--mail/mairix/Makefile3
-rw-r--r--sysutils/py-psutil121/Makefile3
-rw-r--r--x11-toolkits/mygui/Makefile6
21 files changed, 62 insertions, 6 deletions
diff --git a/audio/zita-convolver/Makefile b/audio/zita-convolver/Makefile
index 9c4d84de4523..cc0ec867e1c4 100644
--- a/audio/zita-convolver/Makefile
+++ b/audio/zita-convolver/Makefile
@@ -16,6 +16,9 @@ LICENSE_FILE= ${WRKSRC}/../COPYING
BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:math/fftw3
LIB_DEPENDS= libfftw3f.so:math/fftw3-float
+BROKEN_armv6= fails to compile: c++: the clang compiler does not support '-march=native'
+BROKEN_armv7= fails to compile: c++: the clang compiler does not support '-march=native'
+
USES= compiler:c++11-lib gmake localbase:ldflags tar:bz2
USE_LDCONFIG= yes
WRKSRC_SUBDIR= libs
diff --git a/biology/phyml/Makefile b/biology/phyml/Makefile
index 14aca86b45b7..775a5ac161c4 100644
--- a/biology/phyml/Makefile
+++ b/biology/phyml/Makefile
@@ -13,6 +13,9 @@ COMMENT= Simple, fast, and accurate algorithm to estimate large phylogenies
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_armv6= fails to compile: c++: the clang compiler does not support '-march=native'
+BROKEN_armv7= fails to compile: c++: the clang compiler does not support '-march=native'
+
USE_GITHUB= yes
GH_ACCOUNT= stephaneguindon
diff --git a/databases/percona56-server/Makefile b/databases/percona56-server/Makefile
index 1719d526a2ce..f7c36fb6d3e7 100644
--- a/databases/percona56-server/Makefile
+++ b/databases/percona56-server/Makefile
@@ -12,6 +12,8 @@ DISTNAME= percona-server-${DISTVERSION}
MAINTAINER= flo@FreeBSD.org
COMMENT?= Multithreaded SQL database (server)
+BROKEN_armv6= fails to compile: sql/mysqld.cc:198:19: error: cannot combine with previous 'type-name' declaration specifier
+BROKEN_armv7= fails to compile: sql/mysqld.cc:198:19: error: cannot combine with previous 'type-name' declaration specifier
NOT_FOR_ARCHS= powerpc64
NOT_FOR_ARCHS_REASON= unsupported platform
diff --git a/databases/pg_citus/Makefile b/databases/pg_citus/Makefile
index 75f56167eadc..56a77de8d6c2 100644
--- a/databases/pg_citus/Makefile
+++ b/databases/pg_citus/Makefile
@@ -12,6 +12,9 @@ COMMENT= Horizontally scale Postgresql using sharding and replication
LICENSE= AGPLv3
+BROKEN_armv6= fails to compile: transaction/backend_data.c:53:2: error: unknown type name 'pg_atomic_uint64'; did you mean 'pg_atomic_uint32'?
+BROKEN_armv7= fails to compile: transaction/backend_data.c:53:2: error: unknown type name 'pg_atomic_uint64'; did you mean 'pg_atomic_uint32'?
+
USES= gmake pgsql:9.6+ autoreconf readline
WANT_PGSQL= lib server
GNU_CONFIGURE= yes
diff --git a/databases/soci/Makefile b/databases/soci/Makefile
index 36ed4a6ab658..d3cf8d4a39b8 100644
--- a/databases/soci/Makefile
+++ b/databases/soci/Makefile
@@ -13,6 +13,9 @@ COMMENT= The C++ Database Access Library
LICENSE= BSL
LICENSE_FILE= ${WRKSRC}/LICENSE_1_0.txt
+BROKEN_armv6= fails to compile: backends/mysql/session.cpp:202:22: error: ordered comparison between pointer and zero ('int *' and 'int')
+BROKEN_armv7= fails to compile: backends/mysql/session.cpp:202:22: error: ordered comparison between pointer and zero ('int *' and 'int')
+
USES= cmake zip
CMAKE_ARGS+= -DWITH_ORACLE:BOOL=OFF
USE_LDCONFIG= yes
diff --git a/devel/arpc/Makefile b/devel/arpc/Makefile
index 1943fa23d6c6..f8d19f696e1f 100644
--- a/devel/arpc/Makefile
+++ b/devel/arpc/Makefile
@@ -19,6 +19,9 @@ LIB_DEPENDS= libargdata.so:devel/argdata
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyPEG2>=2.15.2:textproc/py-pyPEG2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}toposort>=1.5:devel/py-toposort@${PY_FLAVOR}
+BROKEN_armv6= fails to build: *** Signal 11
+BROKEN_armv7= fails to build: *** Signal 11
+
USES= cmake localbase:ldflags python:3.4+ shebangfix tar:xz
python_OLD_CMD= "/usr/bin/env python3"
SHEBANG_FILES= scripts/aprotoc.py
diff --git a/devel/critcl/Makefile b/devel/critcl/Makefile
index 30fbf9296b80..71bbb07152c1 100644
--- a/devel/critcl/Makefile
+++ b/devel/critcl/Makefile
@@ -17,6 +17,9 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
RUN_DEPENDS= ${LOCALBASE}/lib/Trf/pkgIndex.tcl:devel/tcl-trf \
${LOCALBASE}/lib/tcllib/cmdline/pkgIndex.tcl:devel/tcllib
+BROKEN_armv6= fails to package: pkg-static: Unable to access file lib/critcl_md5c0.12/freebsd-armv6/md5c.so:No such file or directory
+BROKEN_armv7= fails to package: pkg-static: Unable to access file lib/critcl_md5c0.12/freebsd-armv7/md5c.so:No such file or directory
+
USES+= tcl:85+
USE_GITHUB= yes
GH_ACCOUNT= andreas-kupries
diff --git a/devel/cxxtools/Makefile b/devel/cxxtools/Makefile
index 55e8b227f7ea..3f020f6b4f0f 100644
--- a/devel/cxxtools/Makefile
+++ b/devel/cxxtools/Makefile
@@ -14,6 +14,8 @@ LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_aarch64= does not configure: error: check for atomictype failed
+BROKEN_armv6= does not compile: string_view:204:5: error: static_assert failed "Character type of basic_string_view must be a POD"
+BROKEN_armv7= does not compile: string_view:204:5: error: static_assert failed "Character type of basic_string_view must be a POD"
BROKEN_mips= does not configure: in section .data.rel.ro of csvdeserializer-test.o: defined in discarded section
BROKEN_mips64= does not configure: in section .data.rel.ro of csvdeserializer-test.o: defined in discarded section
BROKEN_sparc64= does not configure
diff --git a/devel/libffcall/Makefile b/devel/libffcall/Makefile
index 11895d7b398a..c2f192fbd87b 100644
--- a/devel/libffcall/Makefile
+++ b/devel/libffcall/Makefile
@@ -11,6 +11,9 @@ COMMENT= Foreign function call libraries
LICENSE= GPLv2+
+BROKEN_armv6= fails to build: avcall-armhf.s:46:2: error: '.syntax divided' arm assembly not supported
+BROKEN_armv7= fails to build: avcall-armhf.s:46:2: error: '.syntax divided' arm assembly not supported
+
GNU_CONFIGURE= yes
USES= gmake libtool
USE_LDCONFIG= yes
diff --git a/devel/ppl/Makefile b/devel/ppl/Makefile
index 23d924a4ed29..9bf74ccc408d 100644
--- a/devel/ppl/Makefile
+++ b/devel/ppl/Makefile
@@ -17,6 +17,9 @@ BUILD_DEPENDS= gm4:devel/m4
LIB_DEPENDS= libglpk.so:math/glpk \
libgmp.so:math/gmp
+BROKEN_armv6= fails to compile: ./OR_Matrix_inlines.hh:100:8: error: missing 'typename' prior to dependent type template name 'OR_Matrix<T>::Pseudo_Row'
+BROKEN_armv7= fails to compile: ./OR_Matrix_inlines.hh:100:8: error: missing 'typename' prior to dependent type template name 'OR_Matrix<T>::Pseudo_Row'
+
USES= gmake perl5 tar:xz libtool
USE_PERL5= build
GNU_CONFIGURE= yes
diff --git a/devel/subversion-static/Makefile b/devel/subversion-static/Makefile
index 891b799cbea1..d1734050f4e8 100644
--- a/devel/subversion-static/Makefile
+++ b/devel/subversion-static/Makefile
@@ -7,6 +7,9 @@ CONFLICTS_INSTALL= ${PORTNAME}-[0-9]*
OPTIONS_EXCLUDE= ${OPTIONS_DEFINE}
OPTIONS_SLAVE= FREEBSD_TEMPLATE P4_STYLE_MARKERS SERF STATIC
+BROKEN_armv6 = fails to link: (.text+0x1124e8): undefined reference to 'log' 20171201
+BROKEN_armv7 = fails to link: (.text+0x118018): undefined reference to 'log' 20171126
+
MASTERDIR= ${.CURDIR}/../subversion
PKGMESSAGE= ${.CURDIR}/pkg-message
diff --git a/dns/bundy/Makefile b/dns/bundy/Makefile
index ecdeaca73aba..0e41b5257914 100644
--- a/dns/bundy/Makefile
+++ b/dns/bundy/Makefile
@@ -26,6 +26,8 @@ LIB_DEPENDS= libbotan-1.10.so:security/botan110 \
libsqlite3.so:databases/sqlite3
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
+BROKEN_armv6 = fails to build: Child process terminated abnormally: Segmentation fault
+BROKEN_armv7 = fails to build: Child process terminated abnormally: Segmentation fault
BROKEN_powerpc64= fails to configure: checking for botan/botan.h... no
USE_GITHUB= yes
diff --git a/games/crafty/Makefile b/games/crafty/Makefile
index 16605dfab9fa..aed36c9cafbd 100644
--- a/games/crafty/Makefile
+++ b/games/crafty/Makefile
@@ -18,6 +18,9 @@ EXTRACT_ONLY= crafty-${PORTVERSION}.zip
MAINTAINER= johans@FreeBSD.org
COMMENT= Chess program for playing and analyzing games
+BROKEN_armv6 = fails to build: Could not read profile default.profdata: No such file or directory
+BROKEN_armv7 = fails to build: Could not read profile default.profdata: No such file or directory
+
WRKSRC= ${WRKDIR}
USES= gmake zip
diff --git a/graphics/a2png/Makefile b/graphics/a2png/Makefile
index 29357a887b1a..96275795749a 100644
--- a/graphics/a2png/Makefile
+++ b/graphics/a2png/Makefile
@@ -15,6 +15,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libgd.so:graphics/gd
+BROKEN_armv6 = fails to build: parse.c:(.text+0x174): undefined reference to 'fgettok'
+BROKEN_armv7 = fails to build: parse.c:(.text+0x174): undefined reference to 'fgettok'
+
USES= tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-gd
diff --git a/japanese/man/Makefile b/japanese/man/Makefile
index 7026682fb8b2..5806673ab412 100644
--- a/japanese/man/Makefile
+++ b/japanese/man/Makefile
@@ -21,6 +21,9 @@ LICENSE= GPLv2
RUN_DEPENDS= ${LOCALBASE}/bin/groff:japanese/groff \
jless:japanese/less
+BROKEN_armv6 = fails to compile: man.c:37:10: fatal error: 'config.h' file not found
+BROKEN_armv7 = fails to compile: man.c:37:10: fatal error: 'config.h' file not found
+
MAKE_ENV= GZCAT=${GZCAT} GZIP_CMD="${GZIP_CMD}"
USES= shebangfix
SHEBANG_FILES= catman/catman.perl makewhatis/makewhatis.perl
diff --git a/lang/go14/Makefile b/lang/go14/Makefile
index efc500184a62..5ab04622404b 100644
--- a/lang/go14/Makefile
+++ b/lang/go14/Makefile
@@ -12,6 +12,10 @@ COMMENT= Go programming language
LICENSE= BSD3CLAUSE
+BROKEN_armv6 = fails to build: go build runtime: go/pkg/tool/freebsd_arm/5g: wait: interrupted system call
+BROKEN_armv7 = fails to build: go build runtime: go/pkg/tool/freebsd_arm/5g: wait: interrupted system call
+ONLY_FOR_ARCHS= amd64 armv6 armv7 i386
+
USES= compiler shebangfix
SHEBANG_LANG= sh perl
SHEBANG_FILES= src/*.bash \
@@ -29,8 +33,6 @@ sh_CMD= ${SH}
WRKSRC= ${WRKDIR}/go
-ONLY_FOR_ARCHS= amd64 armv6 armv7 i386
-
.include <bsd.port.pre.mk>
# If cc is clang, change it to clang to help Go identify the compiler
diff --git a/lang/mono/Makefile b/lang/mono/Makefile
index 90876b4d937c..293066e336ef 100644
--- a/lang/mono/Makefile
+++ b/lang/mono/Makefile
@@ -18,6 +18,10 @@ BUILD_DEPENDS= p5-XML-Parser>=0:textproc/p5-XML-Parser \
LIB_DEPENDS= libinotify.so:devel/libinotify
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow
+BROKEN_armv6= fails to compile: mono/arch/arm/arm-codegen.h:947:10: fatal error: 'mono/arch/arm/arm_dpimacros.h' file not found
+BROKEN_armv7= fails to compile: mono/arch/arm/arm-codegen.h:947:10: fatal error: 'mono/arch/arm/arm_dpimacros.h' file not found
+ONLY_FOR_ARCHS= amd64 armv6 armv7 i386 powerpc
+
OPTIONS_DEFINE= ACCEPTANCE_TESTS MONOLITE
OPTIONS_DEFAULT= MONOLITE
ACCEPTANCE_TESTS_DESC= Download and run the .Net acceptance tests
@@ -65,8 +69,6 @@ MAKE_ENV= MONO_SHARED_DIR="${WRKDIR}" \
TEST_TARGET= check
TEST_WRKSRC= ${WRKSRC}/mono/tests
-ONLY_FOR_ARCHS= amd64 armv6 armv7 i386 powerpc
-
PORTSCOUT= limit:^\d+\.\d+\.[1-9]\d*
LOCALBASE?= /usr/local
diff --git a/lang/racket-minimal/Makefile b/lang/racket-minimal/Makefile
index a22b550c4cca..a5019434bece 100644
--- a/lang/racket-minimal/Makefile
+++ b/lang/racket-minimal/Makefile
@@ -21,6 +21,8 @@ LICENSE= LGPL3
LIB_DEPENDS= libffi.so:devel/libffi
+BROKEN_armv6= fails to compile: ./lightning/lightning.h:81:2: error: GNU lightning does not support the current target
+BROKEN_armv7= fails to compile: ./lightning/lightning.h:81:2: error: GNU lightning does not support the current target
BROKEN_i386= fails to build: Seg fault (internal error) at 0x606060a
BROKEN_powerpc64= fails to build: jit.c: 'JIT_LOCAL4' undeclared (first use in this function)
NOT_FOR_ARCHS= aarch64 aarch64 sparc64
diff --git a/mail/mairix/Makefile b/mail/mairix/Makefile
index 6850c90b8406..3207bb458f10 100644
--- a/mail/mairix/Makefile
+++ b/mail/mairix/Makefile
@@ -11,6 +11,9 @@ COMMENT= Indexing and searching in Maildir, MH, or mbox folders
LICENSE= GPLv2
+BROKEN_armv6= fails to build under emulation: qemu: uncaught target signal 11 (Segmentation fault) - core dumped
+BROKEN_armv7= fails to build under emulation: qemu: uncaught target signal 11 (Segmentation fault) - core dumped
+
USES= bison gmake
HAS_CONFIGURE= yes
diff --git a/sysutils/py-psutil121/Makefile b/sysutils/py-psutil121/Makefile
index 87396d0d0be8..3e92b9eb35aa 100644
--- a/sysutils/py-psutil121/Makefile
+++ b/sysutils/py-psutil121/Makefile
@@ -14,6 +14,9 @@ COMMENT= Process utilities module for Python
LICENSE= BSD3CLAUSE
+BROKEN_armv6= fails to compile: psutil/_psutil_bsd.c:957:23: error: no member named 'kf_sa_local' in 'struct kinfo_file'
+BROKEN_armv7= fails to compile: psutil/_psutil_bsd.c:957:23: error: no member named 'kf_sa_local' in 'struct kinfo_file'
+
PORTSCOUT= limit:^1\.2\.
USES= python
diff --git a/x11-toolkits/mygui/Makefile b/x11-toolkits/mygui/Makefile
index 74c8324860bd..40b94884fd93 100644
--- a/x11-toolkits/mygui/Makefile
+++ b/x11-toolkits/mygui/Makefile
@@ -13,8 +13,6 @@ COMMENT?= Fast, simple and flexible GUI system for games and 3D applications
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING.MIT
-BROKEN_powerpc64= Does not build
-
.if !defined(MASTERDIR)
LIB_DEPENDS= libfreetype.so:print/freetype2 \
libOIS.so:devel/ois
@@ -25,6 +23,10 @@ BUILD_WRKSRC= ${WRKSRC}/${MYGUI_SUBDIR}
INSTALL_WRKSRC= ${WRKSRC}/${MYGUI_SUBDIR}
.endif
+BROKEN_armv6= fails to compile: memory:2050:9: error: cannot initialize a member subobject of type 'std::__1::basic_string<char> *' with an rvalue of type 'int'
+BROKEN_armv7= fails to compile: memory:2050:9: error: cannot initialize a member subobject of type 'std::__1::basic_string<char> *' with an rvalue of type 'int'
+BROKEN_powerpc64= fails to build
+
USE_GITHUB= yes
GH_ACCOUNT= MyGUI