aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--ports-mgmt/portupgrade-devel/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/ports-mgmt/portupgrade-devel/Makefile b/ports-mgmt/portupgrade-devel/Makefile
index cf2116c21452..86cc77b31330 100644
--- a/ports-mgmt/portupgrade-devel/Makefile
+++ b/ports-mgmt/portupgrade-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= portupgrade
PORTVERSION= 20130303
+PORTREVISION= 1
PORTEPOCH= 3
CATEGORIES= ports-mgmt
MASTER_SITES= GH \
@@ -56,6 +57,11 @@ INSTALL_TARGET= install
INSTALL_TARGET+= install-doc
.endif
+# parsedate is needed for date globbing
+.if ${RUBY_VER} == 1.9
+RUN_DEPENDS+= ${RUBY_SITELIBDIR}/parsedate.rb:${PORTSDIR}/devel/ruby-date2
+.endif
+
# Need to install working script(1)
.if ${OSVERSION} < 801000
PLIST_SUB+= SCRIPT=""