aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-orz/Makefile31
-rw-r--r--devel/p5-orz/distinfo3
-rw-r--r--devel/p5-orz/pkg-descr4
-rw-r--r--devel/p5-orz/pkg-plist4
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 69cb4a68fcc5..340fb181c4e9 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1352,6 +1352,7 @@
SUBDIR += p5-enum
SUBDIR += p5-iCal-Parser
SUBDIR += p5-mixin
+ SUBDIR += p5-orz
SUBDIR += p5-prefork
SUBDIR += p5-version
SUBDIR += p65
diff --git a/devel/p5-orz/Makefile b/devel/p5-orz/Makefile
new file mode 100644
index 000000000000..9d04d8eaab9a
--- /dev/null
+++ b/devel/p5-orz/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-orz
+# Date created: 2006-06-08
+# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= orz
+PORTVERSION= 0.11
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= CPAN/INGY
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= snowfly@yuntech.edu.tw
+COMMENT= A method of annotation as /* */ in perl
+
+BUILD_DEPENDS= ${SITE_PERL}/Module/Compile.pm:${PORTSDIR}/devel/p5-Module-Compile
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= orz.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.1 or above
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-orz/distinfo b/devel/p5-orz/distinfo
new file mode 100644
index 000000000000..24a3c0c27fad
--- /dev/null
+++ b/devel/p5-orz/distinfo
@@ -0,0 +1,3 @@
+MD5 (orz-0.11.tar.gz) = 355b09cc0ff0ca3cab95d57372e913fe
+SHA256 (orz-0.11.tar.gz) = dbf034c0c992ee480e1cbeb01ecfae539d794c3656c1067207c2a893923a8646
+SIZE (orz-0.11.tar.gz) = 30393
diff --git a/devel/p5-orz/pkg-descr b/devel/p5-orz/pkg-descr
new file mode 100644
index 000000000000..e0197e66e00d
--- /dev/null
+++ b/devel/p5-orz/pkg-descr
@@ -0,0 +1,4 @@
+When you just can't get your code to work, admit you are a total failure.
+
+Author: Ingy <ingy@cpan.org>
+WWW: http://search.cpan.org/dist/orz/
diff --git a/devel/p5-orz/pkg-plist b/devel/p5-orz/pkg-plist
new file mode 100644
index 000000000000..e384b9ecde47
--- /dev/null
+++ b/devel/p5-orz/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/orz.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/orz/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/orz