aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/libg++/Makefile8
-rw-r--r--devel/prcs/Makefile4
-rw-r--r--net-im/kmess-kde4/Makefile5
-rw-r--r--net-im/kmess/Makefile5
-rw-r--r--net/kmess/Makefile5
-rw-r--r--security/hashish/Makefile8
6 files changed, 33 insertions, 2 deletions
diff --git a/devel/libg++/Makefile b/devel/libg++/Makefile
index 0a98209697c9..07b83bfc2a11 100644
--- a/devel/libg++/Makefile
+++ b/devel/libg++/Makefile
@@ -23,10 +23,16 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= ports@FreeBSD.org
COMMENT= A libg++ container classes for EGCS and later versions of GCC
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
PLIST_SUB= GCC28SUBDIR=${GCC28DIR}
pre-configure:
@${CP} -p ${FILESDIR}/Makefile.libg++ ${WRKSRC}/Makefile
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/prcs/Makefile b/devel/prcs/Makefile
index 334ec1a25fc4..91b615bc1448 100644
--- a/devel/prcs/Makefile
+++ b/devel/prcs/Makefile
@@ -22,6 +22,10 @@ MAN1= prcs.1
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
.if exists(${LOCALBASE}/bin/emacs)
PLIST_SUB+= EMACS=''
.else
diff --git a/net-im/kmess-kde4/Makefile b/net-im/kmess-kde4/Makefile
index b90465160f3b..7a6b272e5ba4 100644
--- a/net-im/kmess-kde4/Makefile
+++ b/net-im/kmess-kde4/Makefile
@@ -20,6 +20,11 @@ USE_REINPLACE= yes
USE_GMAKE= yes
.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
pre-patch:
${REINPLACE_CMD} -e '23s/^.*$$/#include <unistd.h>/' \
${WRKSRC}/kmess/kmessview.cpp
diff --git a/net-im/kmess/Makefile b/net-im/kmess/Makefile
index b90465160f3b..7a6b272e5ba4 100644
--- a/net-im/kmess/Makefile
+++ b/net-im/kmess/Makefile
@@ -20,6 +20,11 @@ USE_REINPLACE= yes
USE_GMAKE= yes
.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
pre-patch:
${REINPLACE_CMD} -e '23s/^.*$$/#include <unistd.h>/' \
${WRKSRC}/kmess/kmessview.cpp
diff --git a/net/kmess/Makefile b/net/kmess/Makefile
index b90465160f3b..7a6b272e5ba4 100644
--- a/net/kmess/Makefile
+++ b/net/kmess/Makefile
@@ -20,6 +20,11 @@ USE_REINPLACE= yes
USE_GMAKE= yes
.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
pre-patch:
${REINPLACE_CMD} -e '23s/^.*$$/#include <unistd.h>/' \
${WRKSRC}/kmess/kmessview.cpp
diff --git a/security/hashish/Makefile b/security/hashish/Makefile
index 8be8f7f28403..f135156ebff8 100644
--- a/security/hashish/Makefile
+++ b/security/hashish/Makefile
@@ -20,6 +20,12 @@ COMMENT= A file and string hashing utility
BUILD_DEPENDS= ${LOCALBASE}/lib/libcryptopp.a:${PORTSDIR}/security/cryptopp
LIB_DEPENDS= wx_gtk:${PORTSDIR}/x11-toolkits/wxgtk-devel
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/Hashish
CFLAGS+= -I${LOCALBASE}/include
@@ -34,4 +40,4 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/hashish ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>