aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/libshout/Makefile2
-rw-r--r--audio/raop_play/Makefile4
-rw-r--r--audio/umurmur/Makefile1
3 files changed, 6 insertions, 1 deletions
diff --git a/audio/libshout/Makefile b/audio/libshout/Makefile
index e2e4ee0bc111..cd5ba3d3f394 100644
--- a/audio/libshout/Makefile
+++ b/audio/libshout/Makefile
@@ -13,6 +13,8 @@ COMMENT= Connect and transmit data to an Icecast media streaming server
LICENSE= LGPL20
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_SSL= openssl-devel
+
LIB_DEPENDS= libogg.so:audio/libogg \
libvorbis.so:audio/libvorbis
diff --git a/audio/raop_play/Makefile b/audio/raop_play/Makefile
index 18be65d28f9e..d775f4a99f93 100644
--- a/audio/raop_play/Makefile
+++ b/audio/raop_play/Makefile
@@ -13,6 +13,8 @@ COMMENT= Music file player for Apple Airport Express
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_SSL= openssl-devel
+
LIB_DEPENDS= libsamplerate.so:audio/libsamplerate \
libfltk.so:x11-toolkits/fltk \
libid3tag.so:audio/libid3tag
@@ -24,7 +26,7 @@ RUN_DEPENDS= mpg321:audio/mpg321 \
GNU_CONFIGURE= yes
CFLAGS+= -D_WITH_GETLINE
LDFLAGS+= `fltk-config --ldflags`
-USES= gmake
+USES= gmake ssl
USE_GNOME= glib20
post-patch:
diff --git a/audio/umurmur/Makefile b/audio/umurmur/Makefile
index 7d289e57fb20..bf5be5e0107c 100644
--- a/audio/umurmur/Makefile
+++ b/audio/umurmur/Makefile
@@ -16,6 +16,7 @@ LIB_DEPENDS= libconfig.so:devel/libconfig \
BROKEN_aarch64= fails to compile: fatal error: byteswap.h file not found
BROKEN_armv6= fails to compile: fatal error: byteswap.h file not found
+BROKEN_SSL= openssl-devel
USE_GITHUB= yes