aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/rubygem-aes_key_wrap/Makefile18
-rw-r--r--security/rubygem-aes_key_wrap/distinfo3
-rw-r--r--security/rubygem-aes_key_wrap/pkg-descr4
4 files changed, 26 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 53398653efd3..1f316ad4e5e1 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1060,6 +1060,7 @@
SUBDIR += rkhunter
SUBDIR += rndpassw
SUBDIR += ruby-camellia
+ SUBDIR += rubygem-aes_key_wrap
SUBDIR += rubygem-airbrussh
SUBDIR += rubygem-attr_encrypted
SUBDIR += rubygem-attr_encrypted30
diff --git a/security/rubygem-aes_key_wrap/Makefile b/security/rubygem-aes_key_wrap/Makefile
new file mode 100644
index 000000000000..a8b30c713914
--- /dev/null
+++ b/security/rubygem-aes_key_wrap/Makefile
@@ -0,0 +1,18 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= aes_key_wrap
+PORTVERSION= 1.0.1
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Ruby implementation of AES Key Wrap
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-aes_key_wrap/distinfo b/security/rubygem-aes_key_wrap/distinfo
new file mode 100644
index 000000000000..d57dc1a11c23
--- /dev/null
+++ b/security/rubygem-aes_key_wrap/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1519733612
+SHA256 (rubygem/aes_key_wrap-1.0.1.gem) = 0770dc79001aa46e03b25772ffbc4de0fefd2cde4eac7bf39f5204f4c0342852
+SIZE (rubygem/aes_key_wrap-1.0.1.gem) = 7680
diff --git a/security/rubygem-aes_key_wrap/pkg-descr b/security/rubygem-aes_key_wrap/pkg-descr
new file mode 100644
index 000000000000..e3fb3bff8a1a
--- /dev/null
+++ b/security/rubygem-aes_key_wrap/pkg-descr
@@ -0,0 +1,4 @@
+AESKeyWrap is a Ruby implementation of AES Key Wrap (RFC 3394, a.k.a. NIST Key
+Wrap).
+
+WWW: https://github.com/tomdalling/aes_key_wrap