aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/quazip-qt5/Makefile9
-rw-r--r--archivers/quazip/Makefile10
-rw-r--r--astro/marble-kde4/Makefile4
-rw-r--r--astro/merkaartor/Makefile4
-rw-r--r--astro/qmapshack/Makefile3
-rw-r--r--cad/qcad/Makefile3
-rw-r--r--editors/texstudio/Makefile6
-rw-r--r--emulators/mupen64plus-qt/Makefile3
-rw-r--r--graphics/tulip/Makefile4
11 files changed, 23 insertions, 25 deletions
diff --git a/MOVED b/MOVED
index 01c1b81cf0f0..54083d9d142d 100644
--- a/MOVED
+++ b/MOVED
@@ -10196,3 +10196,4 @@ www/phpmp||2018-03-08|Has expired: Unmaintained, all www files wrongly belongs t
www/lionwiki||2018-03-08|Has expired: Unmaintained, all www files wrongly belongs to www user
databases/php-memcached|databases/pecl-memcached|2018-03-10|Remove duplicate port, use databases/pecl-memcached instead
emulators/i386-wine-staging|emulators/i386-wine-devel|2018-03-10|Broken for months, abandoned upstream
+archivers/quazip-qt5|archivers/quazip@qt5|2018-03-11|Moved to a flavoured version
diff --git a/archivers/Makefile b/archivers/Makefile
index b1c48ed323d8..bb7ec1a4e95c 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -196,7 +196,6 @@
SUBDIR += py-zstd
SUBDIR += qpress
SUBDIR += quazip
- SUBDIR += quazip-qt5
SUBDIR += rar
SUBDIR += rox-archive
SUBDIR += rpm2cpio
diff --git a/archivers/quazip-qt5/Makefile b/archivers/quazip-qt5/Makefile
deleted file mode 100644
index 7a1db989024a..000000000000
--- a/archivers/quazip-qt5/Makefile
+++ /dev/null
@@ -1,9 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= quazip
-PORTREVISION= 0
-PKGNAMESUFFIX= -qt5
-
-MASTERDIR= ${.CURDIR:H}/quazip
-
-.include "${MASTERDIR}/Makefile"
diff --git a/archivers/quazip/Makefile b/archivers/quazip/Makefile
index 80639d14a6e1..e104a74238ba 100644
--- a/archivers/quazip/Makefile
+++ b/archivers/quazip/Makefile
@@ -2,20 +2,24 @@
# $FreeBSD$
PORTNAME= quazip
-PORTVERSION= 0.7.3
-PORTREVISION?= 0
+DISTVERSION= 0.7.3
+PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= SF
+PKGNAMESUFFIX= -${FLAVOR}
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt/C++ wrapper for ZIP/UNZIP package
LICENSE= LGPL21
+FLAVORS= qt4 qt5
+FLAVOR?= ${FLAVORS:[1]}
+
USES= cmake:outsource
USE_LDCONFIG= yes
-. if empty(PKGNAMESUFFIX)
+. if ${FLAVOR} == qt4
USE_QT4= corelib moc_build network_build qmake_build rcc_build uic_build
CMAKE_ARGS= -DBUILD_WITH_QT4:BOOL=TRUE
. else
diff --git a/astro/marble-kde4/Makefile b/astro/marble-kde4/Makefile
index 60eb4b67314d..941c740b1086 100644
--- a/astro/marble-kde4/Makefile
+++ b/astro/marble-kde4/Makefile
@@ -2,13 +2,13 @@
PORTNAME= marble
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= astro kde kde-kde4
MAINTAINER= kde@FreeBSD.org
COMMENT= Virtual globe and world atlas for KDE
-LIB_DEPENDS= libquazip.so:archivers/quazip
+LIB_DEPENDS= libquazip.so:archivers/quazip@qt4
USES= cmake:outsource kde:4 shared-mime-info tar:xz
USE_KDE= kdelibs automoc4
diff --git a/astro/merkaartor/Makefile b/astro/merkaartor/Makefile
index d4a8fd6e4848..6dad59f02456 100644
--- a/astro/merkaartor/Makefile
+++ b/astro/merkaartor/Makefile
@@ -3,7 +3,7 @@
PORTNAME= merkaartor
PORTVERSION= 0.18.2
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= astro
MAINTAINER= dev2@heesakkers.info
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libgdal.so:graphics/gdal \
libproj.so:graphics/proj \
- libquazip5.so:archivers/quazip-qt5
+ libquazip5.so:archivers/quazip@qt5
USE_GITHUB= yes
GH_ACCOUNT= openstreetmap
diff --git a/astro/qmapshack/Makefile b/astro/qmapshack/Makefile
index ba928ac64ccb..dc646a609dfb 100644
--- a/astro/qmapshack/Makefile
+++ b/astro/qmapshack/Makefile
@@ -3,6 +3,7 @@
PORTNAME= qmapshack
PORTVERSION= 1.10.0
+PORTREVISION= 1
CATEGORIES= astro
MASTER_SITES= https://bitbucket.org/maproom/qmapshack/downloads/
@@ -14,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libgdal.so:graphics/gdal \
libproj.so:graphics/proj \
- libquazip5.so:archivers/quazip-qt5 \
+ libquazip5.so:archivers/quazip@qt5 \
libroutino.so:astro/routino
RUN_DEPENDS= ${LOCALBASE}/bin/bsdisks:sysutils/bsdisks
diff --git a/cad/qcad/Makefile b/cad/qcad/Makefile
index 7d74ecb53dd8..b9ba09b4a339 100644
--- a/cad/qcad/Makefile
+++ b/cad/qcad/Makefile
@@ -4,6 +4,7 @@
PORTNAME= qcad
PORTVERSION= 3.19.0.0
DISTVERSIONPREFIX= v
+PORTREVISION= 1
#PORTREVISION= 1
CATEGORIES= cad
DIST_SUBDIR= ${PORTNAME}
@@ -15,7 +16,7 @@ LICENSE= GPLv3
BUILD_DEPENDS= bash:shells/bash \
${LOCALBASE}/lib/libopenNURBS.a:graphics/opennurbs
-LIB_DEPENDS= libquazip.so:archivers/quazip
+LIB_DEPENDS= libquazip.so:archivers/quazip@qt4
MAKE_JOBS_UNSAFE=yes
diff --git a/editors/texstudio/Makefile b/editors/texstudio/Makefile
index c019911ec9d9..d42a9b49f26d 100644
--- a/editors/texstudio/Makefile
+++ b/editors/texstudio/Makefile
@@ -2,7 +2,7 @@
PORTNAME= texstudio
PORTVERSION= 2.11.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= editors
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/TeXstudio%20${PORTVERSION}
@@ -39,12 +39,12 @@ QMAKE_ARGS= USE_SYSTEM_HUNSPELL=true USE_SYSTEM_QUAZIP=true
TOOLKIT_DESC= Qt toolkit
QT4_USE= ${_USE_QT4:S/^/QT4=/}
QT4_LIB_DEPENDS=libpoppler-qt4.so:graphics/poppler-qt4 \
- libquazip.so:archivers/quazip
+ libquazip.so:archivers/quazip@qt4
QT4_QMAKE_ON= QUAZIP_INCLUDE="${LOCALBASE}/include/quazip" \
QUAZIP_LIB="-lquazip"
QT5_USE= ${_USE_QT5:S/^/QT5=/}
QT5_LIB_DEPENDS=libpoppler-qt5.so:graphics/poppler-qt5 \
- libquazip5.so:archivers/quazip-qt5
+ libquazip5.so:archivers/quazip@qt5
QT5_QMAKE_ON= QUAZIP_INCLUDE="${LOCALBASE}/include/quazip5" \
QUAZIP_LIB="-lquazip5"
diff --git a/emulators/mupen64plus-qt/Makefile b/emulators/mupen64plus-qt/Makefile
index 59f3a54fd07d..e2b65b14ca60 100644
--- a/emulators/mupen64plus-qt/Makefile
+++ b/emulators/mupen64plus-qt/Makefile
@@ -2,6 +2,7 @@
PORTNAME= mupen64plus-qt
PORTVERSION= 1.10
+PORTREVISION= 1
CATEGORIES= emulators
MAINTAINER= maintainer@hasting.email
@@ -13,7 +14,7 @@ BROKEN= wrong dependencies, mupen64plus executable is not provided by emulators
DEPRECATED= Broken for more than 6 months
EXPIRATION_DATE= 2018-05-19
-LIB_DEPENDS= libquazip.so:archivers/quazip
+LIB_DEPENDS= libquazip.so:archivers/quazip@qt4
RUN_DEPENDS= mupen64plus:emulators/mupen64plus
USES= qmake
diff --git a/graphics/tulip/Makefile b/graphics/tulip/Makefile
index c5820e840a0c..aaeb9593b024 100644
--- a/graphics/tulip/Makefile
+++ b/graphics/tulip/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tulip
PORTVERSION= 4.10.0
-PORTREVISION= 3
+PORTREVISION= 4
DISTVERSIONSUFFIX= _src
CATEGORIES= graphics
MASTER_SITES= SF/auber/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -13,7 +13,7 @@ COMMENT= System dedicated to the visualization of huge graphs
LICENSE= LGPL3
-LIB_DEPENDS= libquazip.so:archivers/quazip \
+LIB_DEPENDS= libquazip.so:archivers/quazip@qt4 \
libpng.so:graphics/png \
libOGDF.so:math/ogdf \
libfreetype.so:print/freetype2