aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/libunrar/Makefile (renamed from devel/libunrar/Makefile)6
-rw-r--r--archivers/libunrar/distinfo (renamed from devel/libunrar/distinfo)0
-rw-r--r--archivers/libunrar/files/patch-makefile.unix (renamed from devel/libunrar/files/patch-aa)26
-rw-r--r--archivers/libunrar/pkg-descr (renamed from devel/libunrar/pkg-descr)0
-rw-r--r--archivers/libunrar/pkg-plist (renamed from devel/libunrar/pkg-plist)0
-rw-r--r--devel/Makefile1
7 files changed, 7 insertions, 27 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 385d19797971..ab5d5f1d7371 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -39,6 +39,7 @@
SUBDIR += libcomprex
SUBDIR += liblzxcomp
SUBDIR += libmspack
+ SUBDIR += libunrar
SUBDIR += lzma
SUBDIR += lzo
SUBDIR += lzo2
diff --git a/devel/libunrar/Makefile b/archivers/libunrar/Makefile
index 92497cece6c2..100ea533e562 100644
--- a/devel/libunrar/Makefile
+++ b/archivers/libunrar/Makefile
@@ -1,13 +1,13 @@
# New ports collection makefile for: unrar
-# Date created: 23 Sep 2005
-# Whom: samm
+# Date created: 23 Sep 2005
+# Whom: samm@os2.kiev.ua
#
# $FreeBSD$
#
PORTNAME= libunrar
PORTVERSION= 3.53
-CATEGORIES+= devel
+CATEGORIES= archivers
MASTER_SITES= http://files1.rarlab.com/rar/ \
http://files2.rarlab.com/rar/ \
http://files3.rarlab.com/rar/ \
diff --git a/devel/libunrar/distinfo b/archivers/libunrar/distinfo
index 42b3359a7986..42b3359a7986 100644
--- a/devel/libunrar/distinfo
+++ b/archivers/libunrar/distinfo
diff --git a/devel/libunrar/files/patch-aa b/archivers/libunrar/files/patch-makefile.unix
index fa413fe8267a..60649ebfb41a 100644
--- a/devel/libunrar/files/patch-aa
+++ b/archivers/libunrar/files/patch-makefile.unix
@@ -1,13 +1,12 @@
-diff -ruN unrar.orig/makefile.unix unrar/makefile.unix
---- makefile.unix 2005-04-30 11:00:12.000000000 +0400
-+++ makefile.unix 2005-05-19 16:13:53.000000000 +0400
+--- makefile.unix.orig Sat Apr 30 04:00:12 2005
++++ makefile.unix Fri Sep 23 16:22:04 2005
@@ -7,9 +7,10 @@
# Linux using GCC
CXX=g++
-CXXFLAGS=-O2
-DEFINES=-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
-+CXXFLAGS=-O2 -fPIC -DPIC
++CXXFLAGS=$(CFLAGS) -fPIC -DPIC
+DEFINES=-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DGUI -DSILENT
STRIP=strip
+RANLIB=ranlib
@@ -39,22 +38,3 @@ diff -ruN unrar.orig/makefile.unix unrar/makefile.unix
+ @rm -f libunrar.a
+ $(AR) rc libunrar.a $(OBJECTS) $(LIB_OBJ) $(UNRAR_OBJ)
+ $(RANLIB) libunrar.a
-diff -ruN unrar.orig/dll.hpp unrar/dll.hpp
---- dll.hpp 2004-09-08 17:57:20.000000000 +0400
-+++ dll.hpp 2004-10-22 10:43:08.000000000 +0400
-@@ -26,13 +26,13 @@
-
- #define RAR_DLL_VERSION 4
-
--#ifdef _UNIX
-+//#ifdef _UNIX
- #define CALLBACK
- #define PASCAL
- #define LONG long
- #define HANDLE void *
- #define UINT unsigned int
--#endif
-+//#endif
-
- struct RARHeaderData
- {
diff --git a/devel/libunrar/pkg-descr b/archivers/libunrar/pkg-descr
index 00485e08f9c1..00485e08f9c1 100644
--- a/devel/libunrar/pkg-descr
+++ b/archivers/libunrar/pkg-descr
diff --git a/devel/libunrar/pkg-plist b/archivers/libunrar/pkg-plist
index 75244d95c068..75244d95c068 100644
--- a/devel/libunrar/pkg-plist
+++ b/archivers/libunrar/pkg-plist
diff --git a/devel/Makefile b/devel/Makefile
index 43adf73bc798..365004af19bd 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -521,7 +521,6 @@
SUBDIR += libtool15
SUBDIR += libukcprog
SUBDIR += libunicode
- SUBDIR += libunrar
SUBDIR += libusb
SUBDIR += libvanessa_adt
SUBDIR += libvanessa_logger