aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--multimedia/webcamd/Makefile19
-rw-r--r--multimedia/webcamd/distinfo6
-rw-r--r--multimedia/webcamd/files/webcamd.conf.in2
-rw-r--r--multimedia/webcamd/files/webcamd.in8
4 files changed, 28 insertions, 7 deletions
diff --git a/multimedia/webcamd/Makefile b/multimedia/webcamd/Makefile
index 3f0c0ece2599..57fa88e938a0 100644
--- a/multimedia/webcamd/Makefile
+++ b/multimedia/webcamd/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= webcamd
-PORTVERSION= 0.1.14
-PORTREVISION= 1
+PORTVERSION= 0.1.16
CATEGORIES= multimedia
MASTER_SITES= http://www.selasky.org/hans_petter/video4bsd/releases/
@@ -22,11 +21,25 @@ LIB_DEPENDS= v4l1.0:${PORTSDIR}/multimedia/libv4l
USE_RC_SUBR= webcamd
USE_BZIP2= yes
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
LIBDIR= ${PREFIX}/lib
+OPTIONS= HAL "Build with HAL and DBUS support" On
+
.include <bsd.port.pre.mk>
+LIBCUSE=${LIBDIR}/libcuse4bsd.so
+
+.if defined(WITH_HAL)
+MAKE_ARGS+="HAVE_HAL=YES"
+LIBHAL=${LIBDIR}/libhal.so:${LIBDIR}/libdbus-1.so:
+LIB_DEPENDS+=hal.1:${PORTSDIR}/sysutils/hal
+LIB_DEPENDS+=dbus-1:${PORTSDIR}/devel/dbus
+.else
+LIBHAL=
+.endif
+
.if ${OSVERSION} < 800000
IGNORE= requires FreeBSD 8.0-RELEASE or later
.endif
@@ -38,6 +51,8 @@ post-patch:
post-install:
@${MKDIR} ${PREFIX}/etc/devd
@${SED} -e "s|%%PREFIX%%|${PREFIX}|g" \
+ -e "s|%%LIBHAL%%|${LIBHAL}|g" \
+ -e "s|%%LIBCUSE%%|${LIBCUSE}|g" \
< ${FILESDIR}/webcamd.conf.in > ${WRKDIR}/webcamd.conf
${INSTALL_DATA} "${WRKDIR}/webcamd.conf" ${PREFIX}/etc/devd
@${CAT} ${PKGMESSAGE}
diff --git a/multimedia/webcamd/distinfo b/multimedia/webcamd/distinfo
index 122f5626bac2..9df9e7479530 100644
--- a/multimedia/webcamd/distinfo
+++ b/multimedia/webcamd/distinfo
@@ -1,3 +1,3 @@
-MD5 (webcamd-0.1.14.tar.bz2) = e20b5946ef7e7b4c519303625709b46b
-SHA256 (webcamd-0.1.14.tar.bz2) = eedb054dcaa4aced9ef680ab909e3f44d67687495eb264daceccaead8ca87826
-SIZE (webcamd-0.1.14.tar.bz2) = 3583100
+MD5 (webcamd-0.1.16.tar.bz2) = 2e48673e4f729ac4ebfcbddf9985c18e
+SHA256 (webcamd-0.1.16.tar.bz2) = ab5e5b7253414c822ce434317e5a0b0c82827765433bf4d115812d6e5ad8b192
+SIZE (webcamd-0.1.16.tar.bz2) = 3543806
diff --git a/multimedia/webcamd/files/webcamd.conf.in b/multimedia/webcamd/files/webcamd.conf.in
index 194066e26418..c1f79bbd20e0 100644
--- a/multimedia/webcamd/files/webcamd.conf.in
+++ b/multimedia/webcamd/files/webcamd.conf.in
@@ -3,5 +3,5 @@ notify 100 {
match "subsystem" "INTERFACE";
match "type" "ATTACH";
match "intclass" "(0x0e|0xff)";
- action "env LD_PRELOAD=%%PREFIX%%/lib/libcuse4bsd.so %%PREFIX%%/etc/rc.d/webcamd start $cdev";
+ action "env LD_PRELOAD=%%LIBHAL%%%%LIBCUSE%% %%PREFIX%%/etc/rc.d/webcamd start $cdev";
};
diff --git a/multimedia/webcamd/files/webcamd.in b/multimedia/webcamd/files/webcamd.in
index a082fb1a839c..4271b72c0893 100644
--- a/multimedia/webcamd/files/webcamd.in
+++ b/multimedia/webcamd/files/webcamd.in
@@ -10,6 +10,7 @@
#
webcamd_enable=${webcamd_enable-"NO"}
+hald_enable=${hald_enable-"NO"}
. /etc/rc.subr
@@ -17,7 +18,12 @@ name=webcamd
rcvar=`set_rcvar`
command=%%PREFIX%%/sbin/webcamd
command_args="-B"
-pidfile="/var/run/webcamd.$cdev.0.pid"
+
+if [ -n "$hald_enable" ]; then
+ command_args="$command_args -H"
+fi
+
+pidfile="/var/run/webcamd.*.0.pid"
load_rc_config $name
if [ $# -gt 1 ]; then