aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--astro/xplanet/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/astro/xplanet/Makefile b/astro/xplanet/Makefile
index ad04899b731c..8a753435407f 100644
--- a/astro/xplanet/Makefile
+++ b/astro/xplanet/Makefile
@@ -58,7 +58,14 @@ LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
CONFIGURE_ARGS+= --without-png
.endif
-.if !defined(WITH_TIFF)
+.if !defined(WITHOUT_PNM)
+CONFIGURE_ARGS+= --with-pnm
+LIB_DEPENDS+= netpbm.1:${PORTSDIR}/graphics/netpbm
+.else
+CONFIGURE_ARGS+= --without-pnm
+.endif
+
+.if !defined(WITHOUT_TIFF)
CONFIGURE_ARGS+= --with-tiff
LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
.else