aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11-wm/e17-module-calendar/Makefile36
-rw-r--r--x11-wm/e17-module-calendar/distinfo3
-rw-r--r--x11-wm/e17-module-calendar/files/patch-configure11
-rw-r--r--x11-wm/e17-module-calendar/pkg-descr4
-rw-r--r--x11-wm/e17-module-calendar/pkg-plist22
-rw-r--r--x11/Makefile1
-rw-r--r--x11/e17-module-calendar/Makefile36
-rw-r--r--x11/e17-module-calendar/distinfo3
-rw-r--r--x11/e17-module-calendar/files/patch-configure11
-rw-r--r--x11/e17-module-calendar/pkg-descr4
-rw-r--r--x11/e17-module-calendar/pkg-plist22
11 files changed, 153 insertions, 0 deletions
diff --git a/x11-wm/e17-module-calendar/Makefile b/x11-wm/e17-module-calendar/Makefile
new file mode 100644
index 000000000000..464c6cddaaf3
--- /dev/null
+++ b/x11-wm/e17-module-calendar/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: e17-module-calendar
+# Date created: 23 June 2006
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= calendar
+PORTVERSION= 23062006
+CATEGORIES= x11
+MASTER_SITES= http://mbsd.msk.ru/dist/
+PKGNAMEPREFIX= e17-module-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= Nice calendar module for e17
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment-devel
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-wm/e17-module-calendar/distinfo b/x11-wm/e17-module-calendar/distinfo
new file mode 100644
index 000000000000..3e641ac6c035
--- /dev/null
+++ b/x11-wm/e17-module-calendar/distinfo
@@ -0,0 +1,3 @@
+MD5 (calendar-23062006.tar.bz2) = 161a388d25c7abd9a73142aad0792f4b
+SHA256 (calendar-23062006.tar.bz2) = 3c96faa84c4776c9a1d970962ade1b36113d2226ed657ee0290fc98328f90e4d
+SIZE (calendar-23062006.tar.bz2) = 554819
diff --git a/x11-wm/e17-module-calendar/files/patch-configure b/x11-wm/e17-module-calendar/files/patch-configure
new file mode 100644
index 000000000000..f699d297dc52
--- /dev/null
+++ b/x11-wm/e17-module-calendar/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Fri Jun 23 16:03:16 2006
++++ configure Fri Jun 23 16:03:40 2006
+@@ -23394,7 +23394,7 @@
+
+
+
+-MODULE_ARCH="$host_os-$host_cpu"
++MODULE_ARCH=""
+
+
+ cat >>confdefs.h <<_ACEOF
diff --git a/x11-wm/e17-module-calendar/pkg-descr b/x11-wm/e17-module-calendar/pkg-descr
new file mode 100644
index 000000000000..e42638fcfd68
--- /dev/null
+++ b/x11-wm/e17-module-calendar/pkg-descr
@@ -0,0 +1,4 @@
+Calendar - a desktop calendar module for E17.
+
+Author: NASA (Nathan Smith) <nasa01@comcast.net>
+WWW: http://www.enlightenment.org
diff --git a/x11-wm/e17-module-calendar/pkg-plist b/x11-wm/e17-module-calendar/pkg-plist
new file mode 100644
index 000000000000..2032666f74b9
--- /dev/null
+++ b/x11-wm/e17-module-calendar/pkg-plist
@@ -0,0 +1,22 @@
+lib/enlightenment/modules/calendar/NoImage_icon.png
+lib/enlightenment/modules/calendar/arrow.edj
+lib/enlightenment/modules/calendar/backimage.edj
+lib/enlightenment/modules/calendar/calendar.edj
+lib/enlightenment/modules/calendar/label.edj
+lib/enlightenment/modules/calendar/module.a
+lib/enlightenment/modules/calendar/module.eap
+lib/enlightenment/modules/calendar/module.la
+lib/enlightenment/modules/calendar/module.so
+lib/enlightenment/modules/calendar/module_icon.png
+lib/enlightenment/modules/calendar/today.edj
+lib/enlightenment/modules/calendar/topimage.edj
+lib/enlightenment/modules/calendar/weekday.edj
+lib/enlightenment/modules/calendar/weekend.edj
+%%NLS%%share/locale/bg/LC_MESSAGES/calendar.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/calendar.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/calendar.mo
+%%NLS%%share/locale/it/LC_MESSAGES/calendar.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/calendar.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/calendar.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/calendar.mo
+@dirrm lib/enlightenment/modules/calendar
diff --git a/x11/Makefile b/x11/Makefile
index 640a1f8c5e97..2574cf812707 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -38,6 +38,7 @@
SUBDIR += docker
SUBDIR += dxpc
SUBDIR += dynamag
+ SUBDIR += e17-module-calendar
SUBDIR += e17-module-weather
SUBDIR += ebuttons
SUBDIR += ecore
diff --git a/x11/e17-module-calendar/Makefile b/x11/e17-module-calendar/Makefile
new file mode 100644
index 000000000000..464c6cddaaf3
--- /dev/null
+++ b/x11/e17-module-calendar/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: e17-module-calendar
+# Date created: 23 June 2006
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= calendar
+PORTVERSION= 23062006
+CATEGORIES= x11
+MASTER_SITES= http://mbsd.msk.ru/dist/
+PKGNAMEPREFIX= e17-module-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= Nice calendar module for e17
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment-devel
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11/e17-module-calendar/distinfo b/x11/e17-module-calendar/distinfo
new file mode 100644
index 000000000000..3e641ac6c035
--- /dev/null
+++ b/x11/e17-module-calendar/distinfo
@@ -0,0 +1,3 @@
+MD5 (calendar-23062006.tar.bz2) = 161a388d25c7abd9a73142aad0792f4b
+SHA256 (calendar-23062006.tar.bz2) = 3c96faa84c4776c9a1d970962ade1b36113d2226ed657ee0290fc98328f90e4d
+SIZE (calendar-23062006.tar.bz2) = 554819
diff --git a/x11/e17-module-calendar/files/patch-configure b/x11/e17-module-calendar/files/patch-configure
new file mode 100644
index 000000000000..f699d297dc52
--- /dev/null
+++ b/x11/e17-module-calendar/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Fri Jun 23 16:03:16 2006
++++ configure Fri Jun 23 16:03:40 2006
+@@ -23394,7 +23394,7 @@
+
+
+
+-MODULE_ARCH="$host_os-$host_cpu"
++MODULE_ARCH=""
+
+
+ cat >>confdefs.h <<_ACEOF
diff --git a/x11/e17-module-calendar/pkg-descr b/x11/e17-module-calendar/pkg-descr
new file mode 100644
index 000000000000..e42638fcfd68
--- /dev/null
+++ b/x11/e17-module-calendar/pkg-descr
@@ -0,0 +1,4 @@
+Calendar - a desktop calendar module for E17.
+
+Author: NASA (Nathan Smith) <nasa01@comcast.net>
+WWW: http://www.enlightenment.org
diff --git a/x11/e17-module-calendar/pkg-plist b/x11/e17-module-calendar/pkg-plist
new file mode 100644
index 000000000000..2032666f74b9
--- /dev/null
+++ b/x11/e17-module-calendar/pkg-plist
@@ -0,0 +1,22 @@
+lib/enlightenment/modules/calendar/NoImage_icon.png
+lib/enlightenment/modules/calendar/arrow.edj
+lib/enlightenment/modules/calendar/backimage.edj
+lib/enlightenment/modules/calendar/calendar.edj
+lib/enlightenment/modules/calendar/label.edj
+lib/enlightenment/modules/calendar/module.a
+lib/enlightenment/modules/calendar/module.eap
+lib/enlightenment/modules/calendar/module.la
+lib/enlightenment/modules/calendar/module.so
+lib/enlightenment/modules/calendar/module_icon.png
+lib/enlightenment/modules/calendar/today.edj
+lib/enlightenment/modules/calendar/topimage.edj
+lib/enlightenment/modules/calendar/weekday.edj
+lib/enlightenment/modules/calendar/weekend.edj
+%%NLS%%share/locale/bg/LC_MESSAGES/calendar.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/calendar.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/calendar.mo
+%%NLS%%share/locale/it/LC_MESSAGES/calendar.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/calendar.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/calendar.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/calendar.mo
+@dirrm lib/enlightenment/modules/calendar