aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--editors/calligra/Makefile5
-rw-r--r--editors/koffice-kde3/Makefile5
-rw-r--r--editors/koffice-kde4/Makefile5
-rw-r--r--misc/kdeedu3/Makefile7
-rw-r--r--misc/kdeedu4/Makefile7
5 files changed, 29 insertions, 0 deletions
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index 12caf4d920aa..dd9fb61c41ef 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -44,6 +44,11 @@ USE_PGSQL= yes
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.pre.mk>
+PG_INCDIR!= ${LOCALBASE}/bin/pg_config --includedir
+PG_LIBDIR!= ${LOCALBASE}/bin/pg_config --libdir
+
+CONFIGURE_ARGS+=--with-pgsqlincdir=${PG_INCDIR} --with-pgsqllibdir=${PG_LIBDIR}
+
.if ${OSVERSION} < 500035
EXTRA_PATCHES= ${PATCHDIR}/extrapatch-kexi-main-keximainwindowimpl.cpp
.endif
diff --git a/editors/koffice-kde3/Makefile b/editors/koffice-kde3/Makefile
index 12caf4d920aa..dd9fb61c41ef 100644
--- a/editors/koffice-kde3/Makefile
+++ b/editors/koffice-kde3/Makefile
@@ -44,6 +44,11 @@ USE_PGSQL= yes
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.pre.mk>
+PG_INCDIR!= ${LOCALBASE}/bin/pg_config --includedir
+PG_LIBDIR!= ${LOCALBASE}/bin/pg_config --libdir
+
+CONFIGURE_ARGS+=--with-pgsqlincdir=${PG_INCDIR} --with-pgsqllibdir=${PG_LIBDIR}
+
.if ${OSVERSION} < 500035
EXTRA_PATCHES= ${PATCHDIR}/extrapatch-kexi-main-keximainwindowimpl.cpp
.endif
diff --git a/editors/koffice-kde4/Makefile b/editors/koffice-kde4/Makefile
index 12caf4d920aa..dd9fb61c41ef 100644
--- a/editors/koffice-kde4/Makefile
+++ b/editors/koffice-kde4/Makefile
@@ -44,6 +44,11 @@ USE_PGSQL= yes
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.pre.mk>
+PG_INCDIR!= ${LOCALBASE}/bin/pg_config --includedir
+PG_LIBDIR!= ${LOCALBASE}/bin/pg_config --libdir
+
+CONFIGURE_ARGS+=--with-pgsqlincdir=${PG_INCDIR} --with-pgsqllibdir=${PG_LIBDIR}
+
.if ${OSVERSION} < 500035
EXTRA_PATCHES= ${PATCHDIR}/extrapatch-kexi-main-keximainwindowimpl.cpp
.endif
diff --git a/misc/kdeedu3/Makefile b/misc/kdeedu3/Makefile
index 28284dbc46a7..f53f5fa42e75 100644
--- a/misc/kdeedu3/Makefile
+++ b/misc/kdeedu3/Makefile
@@ -41,4 +41,11 @@ CONFIGURE_ARGS+=--disable-kig-python-scripting
PLIST_SUB+= BOOST_PYTHON="@comment "
.endif
+PYTHON_LIBDIR!= ${LOCALBASE}/bin/python -c 'import sys;print sys.prefix'
+
+pre-configure:
+ ${REINPLACE_CMD} \
+ -e 's|pylibdir in.*|pylibdir in "${PYTHON_LIBDIR}/lib" \\|g' \
+ ${WRKSRC}/configure
+
.include <bsd.port.post.mk>
diff --git a/misc/kdeedu4/Makefile b/misc/kdeedu4/Makefile
index 28284dbc46a7..f53f5fa42e75 100644
--- a/misc/kdeedu4/Makefile
+++ b/misc/kdeedu4/Makefile
@@ -41,4 +41,11 @@ CONFIGURE_ARGS+=--disable-kig-python-scripting
PLIST_SUB+= BOOST_PYTHON="@comment "
.endif
+PYTHON_LIBDIR!= ${LOCALBASE}/bin/python -c 'import sys;print sys.prefix'
+
+pre-configure:
+ ${REINPLACE_CMD} \
+ -e 's|pylibdir in.*|pylibdir in "${PYTHON_LIBDIR}/lib" \\|g' \
+ ${WRKSRC}/configure
+
.include <bsd.port.post.mk>