aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--comms/minicom/Makefile4
-rw-r--r--comms/minicom/distinfo4
-rw-r--r--comms/minicom/files/patch-ac6
-rw-r--r--comms/minicom/files/patch-af12
-rw-r--r--comms/minicom/files/patch-minirc.dfl6
-rw-r--r--comms/minicom/files/patch-src-main.c11
-rw-r--r--comms/minicom/files/patch-src-minicom.h12
-rw-r--r--comms/minicom/files/patch-src-script.c11
-rw-r--r--comms/minicom/files/patch-sysdep1.c14
9 files changed, 51 insertions, 29 deletions
diff --git a/comms/minicom/Makefile b/comms/minicom/Makefile
index 9f9ef38df8d7..9afb465d4be5 100644
--- a/comms/minicom/Makefile
+++ b/comms/minicom/Makefile
@@ -7,9 +7,9 @@
#
PORTNAME= minicom
-PORTVERSION= 2.5
+PORTVERSION= 2.6
CATEGORIES= comms
-MASTER_SITES= http://alioth.debian.org/frs/download.php/3487/
+MASTER_SITES= http://alioth.debian.org/frs/download.php/3689/
MAINTAINER= johans@FreeBSD.org
COMMENT= An MS-DOS Telix serial communication program "workalike"
diff --git a/comms/minicom/distinfo b/comms/minicom/distinfo
index 9a051e52e380..da90a5537cac 100644
--- a/comms/minicom/distinfo
+++ b/comms/minicom/distinfo
@@ -1,2 +1,2 @@
-SHA256 (minicom-2.5.tar.gz) = 2aa43f98580d3c9c59b12895f15783695cde85472f6bfc7974bcc0935af0a8fd
-SIZE (minicom-2.5.tar.gz) = 822499
+SHA256 (minicom-2.6.tar.gz) = ea5fe79c22dcb115cf5ed287b0e7a69e069bedd39889aa89b1a23f64f53fceb3
+SIZE (minicom-2.6.tar.gz) = 830255
diff --git a/comms/minicom/files/patch-ac b/comms/minicom/files/patch-ac
index 56431e4f56e6..05fee081d74b 100644
--- a/comms/minicom/files/patch-ac
+++ b/comms/minicom/files/patch-ac
@@ -1,6 +1,6 @@
---- src/updown.c.orig 2008-04-17 19:52:52.000000000 +0200
-+++ src/updown.c 2008-04-17 19:53:27.000000000 +0200
-@@ -244,7 +244,7 @@
+--- src/updown.c.orig 2011-09-07 23:04:32.000000000 +0200
++++ src/updown.c 2011-12-28 16:07:59.000000000 +0100
+@@ -296,7 +296,7 @@ void updown(int what, int nr)
do_log("%s", cmdline); /* jl 22.06.97 */
if (P_PFULL(g) == 'N') {
diff --git a/comms/minicom/files/patch-af b/comms/minicom/files/patch-af
index c721ec7c927d..f52faa6af245 100644
--- a/comms/minicom/files/patch-af
+++ b/comms/minicom/files/patch-af
@@ -1,6 +1,6 @@
---- src/window.c.orig 2008-02-06 22:49:55.000000000 +0100
-+++ src/window.c 2008-04-17 20:08:10.000000000 +0200
-@@ -70,6 +70,7 @@
+--- src/window.c.orig 2010-12-12 14:56:25.000000000 +0100
++++ src/window.c 2011-12-28 16:07:59.000000000 +0100
+@@ -66,6 +66,7 @@ static const char *CE, *Al, *Dl, *AL, *D
static const char *CS, *SF, *SR, *VB, *BL;
static const char *VE, *VI, *KS, *KE;
static const char *CD, *CL, *IC, *DC;
@@ -8,7 +8,7 @@
static const char *CR, *NL;
#ifdef ST_LINE
static const char *TS, *FS, *DS;
-@@ -342,8 +343,8 @@
+@@ -335,8 +336,8 @@ static void _gotoxy(int x, int y)
else if (NL != NULL && x == 0 && x == curx && y == cury + 1)
outstr(NL);
#endif
@@ -19,7 +19,7 @@
else
outstr(tgoto(CM, x, y));
curx = x;
-@@ -2007,7 +2008,7 @@
+@@ -2000,7 +2001,7 @@ int win_init(int fg, int bg, int attr)
CL = tgetstr("cl", &_tptr);
IC = tgetstr("ic", &_tptr);
DC = tgetstr("dc", &_tptr);
@@ -28,7 +28,7 @@
CR = tgetstr("cr", &_tptr);
NL = tgetstr("nl", &_tptr);
AC = tgetstr("ac", &_tptr);
-@@ -2066,11 +2067,11 @@
+@@ -2059,11 +2060,11 @@ int win_init(int fg, int bg, int attr)
_has_am = tgetflag("am");
_mv_standout = tgetflag("ms");
if (tgetflag("bs")) {
diff --git a/comms/minicom/files/patch-minirc.dfl b/comms/minicom/files/patch-minirc.dfl
index 1e588d621a42..a6cc21985043 100644
--- a/comms/minicom/files/patch-minirc.dfl
+++ b/comms/minicom/files/patch-minirc.dfl
@@ -1,7 +1,7 @@
---- doc/minirc.dfl.orig 2003-03-30 20:55:39.000000000 +0200
-+++ doc/minirc.dfl 2008-04-17 20:17:35.000000000 +0200
+--- doc/minirc.dfl.orig 2009-12-12 16:47:47.000000000 +0100
++++ doc/minirc.dfl 2011-12-28 16:07:59.000000000 +0100
@@ -1,2 +1,7 @@
- # $Id: minirc.dfl,v 1.1.1.1 2003/03/30 18:55:39 al-guest Exp $
+ # $Id: minirc.dfl,v 1.1.1.1 2003-03-30 18:55:39 al-guest Exp $
# Machine-generated file - use "minicom -s" to change parameters.
+pr port /dev/cuad0
+pu baudrate 9600
diff --git a/comms/minicom/files/patch-src-main.c b/comms/minicom/files/patch-src-main.c
new file mode 100644
index 000000000000..2dd01963c443
--- /dev/null
+++ b/comms/minicom/files/patch-src-main.c
@@ -0,0 +1,11 @@
+--- src/main.c.orig 2011-09-30 09:57:00.000000000 +0200
++++ src/main.c 2011-12-28 16:07:59.000000000 +0100
+@@ -112,7 +112,7 @@ char *esc_key(void)
+ static void get_alrm(int dummy)
+ {
+ (void)dummy;
+- errno = ETIME;
++ errno = ETIMEDOUT;
+ longjmp(albuf, 1);
+ }
+
diff --git a/comms/minicom/files/patch-src-minicom.h b/comms/minicom/files/patch-src-minicom.h
index 74c4b7c2a0cf..10c553f9dddb 100644
--- a/comms/minicom/files/patch-src-minicom.h
+++ b/comms/minicom/files/patch-src-minicom.h
@@ -1,10 +1,10 @@
---- src/minicom.h.orig 2008-04-17 20:06:14.000000000 +0200
-+++ src/minicom.h 2008-04-17 20:06:22.000000000 +0200
-@@ -34,6 +34,7 @@
- #include "libport.h"
+--- src/minicom.h.orig 2011-09-30 09:57:22.000000000 +0200
++++ src/minicom.h 2011-12-28 16:12:54.000000000 +0100
+@@ -35,6 +35,7 @@
#include <time.h>
+ #include <stdbool.h>
+#include <limits.h>
- #ifdef USE_SOCKET
- #include <sys/socket.h>
+ #if HAVE_LOCKDEV
+ #include <ttylock.h>
diff --git a/comms/minicom/files/patch-src-script.c b/comms/minicom/files/patch-src-script.c
new file mode 100644
index 000000000000..6cc638522a92
--- /dev/null
+++ b/comms/minicom/files/patch-src-script.c
@@ -0,0 +1,11 @@
+--- src/script.c.orig 2011-07-23 19:58:32.000000000 +0200
++++ src/script.c 2011-12-28 16:07:59.000000000 +0100
+@@ -69,7 +69,7 @@ struct env {
+ struct env *curenv; /* Execution environment */
+ int gtimeout = 120; /* Global Timeout */
+ int etimeout = 0; /* Timeout in expect routine */
+-jmp_buf ejmp; /* To jump to if expect times out */
++sigjmp_buf ejmp; /* To jump to if expect times out */
+ int inexpect = 0; /* Are we in the expect routine */
+ const char *newline; /* What to print for '\n'. */
+ const char *s_login = "name"; /* User's login name */
diff --git a/comms/minicom/files/patch-sysdep1.c b/comms/minicom/files/patch-sysdep1.c
index 467e1858167a..dbe756a9d059 100644
--- a/comms/minicom/files/patch-sysdep1.c
+++ b/comms/minicom/files/patch-sysdep1.c
@@ -1,6 +1,6 @@
---- src/sysdep1.c.orig 2007-10-10 22:18:20.000000000 +0200
-+++ src/sysdep1.c 2008-04-17 19:48:58.000000000 +0200
-@@ -84,13 +84,13 @@
+--- src/sysdep1.c.orig 2009-12-12 16:47:47.000000000 +0100
++++ src/sysdep1.c 2011-12-28 16:07:59.000000000 +0100
+@@ -65,13 +65,13 @@ static void m_setrts(int fd)
if (portfd_is_socket)
return;
#endif
@@ -16,8 +16,8 @@
+ ioctl(fd, TIOCMSET, &mcs);
}
#endif
- #ifdef _COHERENT
-@@ -213,11 +213,11 @@
+ }
+@@ -180,11 +180,11 @@ int m_getdcd(int fd)
return portfd_is_connected;
}
#endif
@@ -31,7 +31,7 @@
return -1;
return mcs & TIOCM_CAR ? 1 : 0;
}
-@@ -260,8 +260,8 @@
+@@ -227,8 +227,8 @@ void m_savestate(int fd)
ioctl(fd, TIOCLGET, &lsw);
# endif
#endif
@@ -42,7 +42,7 @@
#endif
}
-@@ -285,8 +285,8 @@
+@@ -252,8 +252,8 @@ void m_restorestate(int fd)
ioctl(fd, TIOCLSET, &lsw);
# endif
#endif
mit/archivers?h=gnome-3.28&id=8d1f60681b459f68c3282d5460f5d07fd016b675'>Update to 1.8.2bapt2018-05-083-25/+10 * - Update to 0.0.10kmoore2018-05-082-4/+4 * Update to 1.30. Noteworthy changes:naddy2018-05-027-23/+60 * Update KDE Applications to 18.04.0tcberner2018-04-292-6/+5 * Update KDE Frameworks to 5.45.0tcberner2018-04-271-3/+3 * Fix msgpack dependencysunpoet2018-04-261-0/+4 * Switch all pypi.python.org WWWs to a new PyPi home pypi.org whereamdmi32018-04-265-5/+5 * Fix msgpack dependencysunpoet2018-04-251-2/+5 * Move devel/py-msgpack-python to devel/py-msgpacksunpoet2018-04-232-3/+5 * Remove the PORTDOCS duplicate.osa2018-04-211-1/+1 * devel/boost-*: update to 1.67.0jbeich2018-04-182-2/+2 * archivers/py-borgbackup: Update to 1.1.5joneum2018-04-173-15/+4 * Update to 2.082sunpoet2018-04-172-4/+4 * Update to version 2.2.11krion2018-04-173-4/+5 * archivers/laszip: Update to 3.2.2dbaio2018-04-163-17/+16 * New port: archivers/urbackup-serverpi2018-04-167-0/+248 * New port: archivers/urbackup-clientpi2018-04-167-0/+233 * Update `archivers/libdeflate' to version 1.0.danfe2018-04-152-4/+4 * devel/qjson, devel-qjson-qt5 create flavorstcberner2018-04-141-2/+2 * Updating MATE ports to and patch for MATE 1.20ericbsd2018-04-143-4/+5 * Upgrade from 1.0.2 to 1.0.4.osa2018-04-123-125/+4 * Update to 1.0.4sunpoet2018-04-122-4/+4 * Upgrade rpm4 from 4.13.0.2 to 4.13.1rodrigo2018-04-103-9/+9 * Update to 2.081sunpoet2018-04-102-4/+4 * Update to 2.081sunpoet2018-04-102-4/+4 * Update to 2.081sunpoet2018-04-102-4/+4 * Update to 2.081sunpoet2018-04-102-4/+4 * Update to 2.081sunpoet2018-04-102-4/+4 * Update to 2.081sunpoet2018-04-102-4/+4 * Update to 2.081sunpoet2018-04-102-4/+4 * archivers/py-zstandard: Change to use the external zstandard libraryyuri2018-04-091-2/+4 * archivers/py-zstandard: Update 0.8.2 -> 0.9.0yuri2018-04-092-5/+5 * Allow compiler and strip command with space.sunpoet2018-04-091-1/+1 * Fix build of archivers/ark on 10.3 (old clang). Make the returnadridg2018-04-081-0/+11 * New port: archivers/arktcberner2018-04-075-0/+148 * Remove CONFLICTS: 4 ports have been removed over 7.5 yearssunpoet2018-04-071-2/+0 * devel/icu: update to 61.1jbeich2018-04-061-1/+1 * - Add LICENSE_FILEamdmi32018-04-062-1/+2 * Fix build with clang 6.ehaupt2018-04-052-8/+12 * - Migrate Mk/bsd.fpc.mk to Mk/Uses/fpc.mkacm2018-04-053-4/+5 * archivers/py-zstd: Update 1.3.3 -> 1.3.4yuri2018-04-052-4/+4 * Update to 1.1.0sunpoet2018-04-052-5/+4 * Update to 2.080sunpoet2018-04-052-4/+4 * Update to 2.080sunpoet2018-04-052-4/+4 * Update to 2.080sunpoet2018-04-052-4/+4 * Update to 2.080sunpoet2018-04-052-4/+4 * Update to 2.080sunpoet2018-04-052-4/+4 * Update to 2.080sunpoet2018-04-052-4/+4 * Update to 2.080sunpoet2018-04-052-4/+4 * - Update to 1.14.2lwhsu2018-04-042-4/+4 * Update to 1.3.4sunpoet2018-04-042-5/+4 * archivers/py-borgbackup: Fix use of FLAVORfeld2018-03-281-3/+3 * . Fix the build with libressl-develglewis2018-03-272-4/+17 * Rename MASTER_SITE_SOURCEFORGE_JP to MASTER_SITE_OSDNsunpoet2018-03-251-1/+1 * archivers/unalz: Update to 0.66yuri2018-03-194-11/+29 * archivers/py-zstandard: Update to 0.8.2yuri2018-03-182-4/+4 * archivers/py-zstd: Update to 1.3.3yuri2018-03-162-4/+4 * Update KDE Frameworks to 5.44tcberner2018-03-131-3/+3 * Return maho@'s ports to the pool after his commit bit expired.rene2018-03-111-1/+1 * Convert archivers/quazip and archivers/quazip-qt5 into flavorstcberner2018-03-113-13/+7 * Bump PORTREVISIONs of all users of math/mpc that we just updated togerald2018-03-112-1/+2 * Introduce PHP flavors.mat2018-03-096-10/+7 * archivers/lazperf: Update to 1.2.0yuri2018-03-082-7/+7 * Add LICENSE_FILEsunpoet2018-03-071-0/+1 * - Update to 3.0miwi2018-03-062-4/+4 * Update to 1.0.3sunpoet2018-03-042-4/+4 * Remove unnecessary rubygem-backportssunpoet2018-02-281-1/+5 * Fix r463123sunpoet2018-02-281-1/+0 * - Update to 1.7danilo2018-02-282-4/+4 * Switch some MASTER_SITES from http/ftp to https.mat2018-02-271-1/+2 * Replaced my old rawbw.com maintainer's address with yuri@FreeBSD.orgyuri2018-02-252-2/+2 * Give the KDE SC4 applications ports a -kde4 suffixtcberner2018-02-236-2/+2 * Fix build by adding chm to USE_FPCantoine2018-02-221-1/+1 * Fix build on 12.0-CURRENT after upgrading clang, llvm, lld, lldb, compiler-rtehaupt2018-02-211-1/+8 * Update to 1.0.0sunpoet2018-02-182-4/+4 * Update KDE Frameworks to 5.43.0tcberner2018-02-161-3/+3 * Update to 0.23.2sunpoet2018-02-152-4/+4 * - Add LICENSEamdmi32018-02-151-4/+10 * Add p5-Archive-Tar-Wrapper 0.23sunpoet2018-02-135-0/+43 * archivers/py-python-lhafile: Update to 0.2.2yuri2018-02-123-8/+11 * archivers/gzip: Update WWW in pkg-descryuri2018-02-121-1/+1 * Update to 0.23.1sunpoet2018-02-112-4/+4 * Add missing RUN_DEPENDSsunpoet2018-02-111-3/+4 * - Switch to new test frameworkamdmi32018-02-111-6/+5 * Unbreak the fetch from ftp.warwick.ac.uk by switching to http:// fromdanfe2018-02-111-1/+1 * Add patch for CVE-2018-5996rakuco2018-02-102-1/+212 * Add patch from CVE-2017-17969rakuco2018-02-102-1/+36 * Rename KDE4 meta portstcberner2018-02-101-1/+1 * Switch C compiler used to compile GHC to base Clang.tcberner2018-02-105-2/+5 * Canonicalize PyPi WWWs:amdmi32018-02-091-1/+1 * Upddate to GNU gzip 1.9 (bugfix release)johans2018-02-082-3/+6 * - Switch to new test frameworkamdmi32018-02-071-1/+1 * Update to 0.21.6sunpoet2018-02-062-4/+4 * Update to 0.5.2antoine2018-02-042-5/+8 * Update to 0.20.1sunpoet2018-02-042-4/+4 * Update to 0.19.2sunpoet2018-02-032-4/+4 * Update PHP 7.1 from 7.1.13 to 7.1.14tz2018-02-021-9/+0 * Unbreak the build against Clang 6.0.0 and respect CXXFLAGS.danfe2018-02-021-1/+4 * - Switch to new test frameworkamdmi32018-02-011-1/+1 * - Update to 6.5.0acm2018-02-012-6/+16 * Revert recent fpc changes, they were obviously untestedantoine2018-01-312-16/+6 * - Update to 6.5.0acm2018-01-312-6/+16 * remove IGNORE_WITH_PHP= 70 71joneum2018-01-301-1/+0 * Update to 0.11.0sunpoet2018-01-292-4/+4 * Update gcab to 0.8.kwm2018-01-273-6/+6 * Make portlint happier with my ports (reorder variables)martymac2018-01-251-2/+2 * Update to 0.19.1sunpoet2018-01-223-5/+14 * Unbreak the build on sparc64: unlike e.g. on powerpc, gcc on sparc64 doesdanfe2018-01-222-5/+9 * Update to 0.18.2sunpoet2018-01-212-4/+4 * archivers/xmill: unbreak build with Clang 6 (C++14 by default)jbeich2018-01-211-0/+18 * Update to 1.8.1.2sunpoet2018-01-183-16/+5 * Fix build with include/lz4.h which is in UTF-8 formatsunpoet2018-01-181-0/+11 * Update debian patch collection to version 17 since 16 is not available anymoregarga2018-01-182-5/+5 * devel/boost-*: update to 1.66.0jbeich2018-01-182-2/+2 * archivers/c-blosc: Update to 1.13.1dbaio2018-01-182-5/+4 * Update KDE Frameworks to 5.42.0tcberner2018-01-171-3/+3 * New port: archivers/py-zstandard: Zstandard bindings for Python, a full-featu...yuri2018-01-164-0/+40 * - fix bad line inserted by vimdinoex2018-01-151-1/+0 * - Add license informationdinoex2018-01-152-1/+61 * Add a port of libdeflate, a library for fast, whole-buffer DEFLATE-baseddanfe2018-01-144-0/+58 * Update to 1.8.1sunpoet2018-01-143-4/+15 * Return kevlo's ports to the pool, he handed in his commit bit.rene2018-01-121-1/+1 * Update PHP 7.1 from 7.1.12 to 7.1.13tz2018-01-111-1/+0 * New port: archivers/py-zstd: Python binding for Zstandard compression libraryyuri2018-01-104-0/+40 * Add a patch to fix the build with Clang 6.0.rakuco2018-01-061-0/+33 * Update to 0.18.1sunpoet2018-01-042-4/+4 * Update to 0.6.8antoine2018-01-032-4/+4 * Update to 0.18.0sunpoet2018-01-022-4/+4 * Update archivers/py-borgbackup to 1.1.4tcberner2017-12-312-5/+6 * Simplify some USES=pythonantoine2017-12-291-1/+1 * Update to 2.4.delphij2017-12-292-4/+4 * Update to 0.17.0sunpoet2017-12-282-4/+4 * New port: archivers/py-acefileantoine2017-12-274-0/+35 * - Update to 0.16.6lwhsu2017-12-273-7/+4 * Update to 0.14.0sunpoet2017-12-253-9/+9 * - Simplify Makefileamdmi32017-12-251-10/+3 * Convert to USES=autoreconf and remove unneeded -fPIC.tijl2017-12-251-5/+5 * Remove BROKEN_sparc64 statement which was originally added in r277772 bydanfe2017-12-241-3/+2 * Update to 0.13.0sunpoet2017-12-242-4/+4 * Add LZ4 optionsunpoet2017-12-241-0/+7 * Update to 1.3.3sunpoet2017-12-232-5/+5 * Add missing @ before ${FLAVOR}pawel2017-12-221-1/+1 * Update to 0.12.0sunpoet2017-12-222-5/+7 * Update to 1.60sunpoet2017-12-222-4/+4 * archivers/lua51-zlib: set LLD_UNSAFEemaste2017-12-201-0/+1 * Update KDE Frameworks to 5.41tcberner2017-12-151-3/+3 * Add missing IGNORE_WITH_PHP for various pecl-ports.tz2017-12-141-1/+1 * - Add LICENSEamdmi32017-12-121-2/+10 * archivers/brotli: Update to 1.0.2brnrd2017-12-124-18/+142 * Update to 1.0.2sunpoet2017-12-112-7/+9 * - Those ports fail to build with python3antoine2017-12-111-2/+2 * archivers/php71-phar: Unbreak if devel/re2c is installedtz2017-12-052-0/+10 * Unbreakantoine2017-12-041-1/+1 * Add LICENSE_FILEsunpoet2017-12-041-3/+4 * Change from USES=python:2 to USES=python:2.7sunpoet2017-12-041-3/+2 * Fix configure options for gnustep-maketheraven2017-12-033-3/+3 * - Add LICENSEamdmi32017-12-031-1/+4 * Convert Python ports to FLAVORS.mat2017-11-30