aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--japanese/expect/Makefile13
-rw-r--r--lang/expect/Makefile17
2 files changed, 12 insertions, 18 deletions
diff --git a/japanese/expect/Makefile b/japanese/expect/Makefile
index 5796ed3f756f..89279dbfc1e1 100644
--- a/japanese/expect/Makefile
+++ b/japanese/expect/Makefile
@@ -3,7 +3,7 @@
# Date created: 17 Oct 1997
# Whom: taguchi
#
-# $Id: Makefile,v 1.4 1997/10/17 05:58:02 asami Exp $
+# $Id: Makefile,v 1.5 1998/02/17 15:13:00 steve Exp $
#
PKGNAME= ja-expect-5.25
@@ -14,15 +14,12 @@ MAINTAINER= taguchi@tohoku.iij.ad.jp
LIB_DEPENDS= tk42jp\\.1\\.:${PORTSDIR}/japanese/tk42
FILESDIR= ${.CURDIR}/../../lang/expect/files
-
-NO_MAN_INSTALL= yes
-.include "${.CURDIR}/../../lang/expect/Makefile"
-
-CFLAGS+= -DKANJI -DKINPUT2
+CFLAGS= -DKANJI -DKINPUT2
CONFIGURE_ARGS= --enable-shared --with-tclconfig=${PREFIX}/lib/tcl7.6jp \
--with-tkconfig=${PREFIX}/lib/tk4.2jp \
--with-tclinclude=${PREFIX}/include/tcl7.6jp \
--with-tkinclude=${PREFIX}/include/tk4.2jp
-test:
- @(cd ${WRKSRC}; make test)
+NO_MAN_INSTALL= yes
+
+.include "${.CURDIR}/../../lang/expect/Makefile"
diff --git a/lang/expect/Makefile b/lang/expect/Makefile
index 86ace2c9b8a5..86a435dcb166 100644
--- a/lang/expect/Makefile
+++ b/lang/expect/Makefile
@@ -3,27 +3,27 @@
# Whom: pst
# Version required: 5.25
#
-# $Id: Makefile,v 1.28 1997/12/29 11:42:10 asami Exp $
+# $Id: Makefile,v 1.29 1998/01/27 01:11:47 fenner Exp $
#
+# Note this file is included from japanese/extract/Makefile
DISTNAME= expect
-PKGNAME= expect-5.25
-CATEGORIES= lang tcl80 tk80
+PKGNAME?= expect-5.25
+CATEGORIES?= lang tcl80 tk80
MASTER_SITES= http://expect.nist.gov/
-MAINTAINER= ports@freebsd.org
+MAINTAINER?= ports@freebsd.org
-LIB_DEPENDS= tk80\\.1:${PORTSDIR}/x11/tk80
+LIB_DEPENDS?= tk80\\.1:${PORTSDIR}/x11/tk80
WRKSRC= ${WRKDIR}/expect-5.25
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-shared \
+CONFIGURE_ARGS?= --enable-shared \
--with-tclconfig=${PREFIX}/lib/tcl8.0 \
--with-tclinclude=${PREFIX}/include/tcl8.0 \
--with-tkconfig=${PREFIX}/lib/tk8.0 \
--with-tkinclude=${PREFIX}/include/tk8.0
-# needed for japanese/expect
.if !defined(NO_MAN_INSTALL)
MAN1= autoexpect.1 cryptdir.1 decryptdir.1 dislocate.1 \
expect.1 expectk.1 kibitz.1 mkpasswd.1 passmass.1 \
@@ -31,9 +31,6 @@ MAN1= autoexpect.1 cryptdir.1 decryptdir.1 dislocate.1 \
MAN3= libexpect.3
.endif
-test:
- @(cd ${WRKSRC}; make test)
-
post-install:
${LDCONFIG} -m ${PREFIX}/lib