aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--emulators/vmware2/Makefile1
-rw-r--r--emulators/vmware2/files/vmware10
-rw-r--r--emulators/vmware3/Makefile1
-rw-r--r--emulators/vmware3/files/vmware10
4 files changed, 22 insertions, 0 deletions
diff --git a/emulators/vmware2/Makefile b/emulators/vmware2/Makefile
index ee9f2c7e8912..8c3e94090f8a 100644
--- a/emulators/vmware2/Makefile
+++ b/emulators/vmware2/Makefile
@@ -76,6 +76,7 @@ setoptions:
${FILESDIR}/vmware.sh > ${WRKDIR}/vmware.sh
${SED} -e 's;@@PREFIX@@;${PREFIX};' \
+ -e 's;@@LINUX_DIR@@;${LINUX_DIR};' \
${FILESDIR}/vmware > ${WRKDIR}/vmware
pre-install: setoptions
diff --git a/emulators/vmware2/files/vmware b/emulators/vmware2/files/vmware
index 8bf4e133d6c7..7109da2fdb63 100644
--- a/emulators/vmware2/files/vmware
+++ b/emulators/vmware2/files/vmware
@@ -4,6 +4,16 @@
#
# $FreeBSD$
+if [ ! -e @@LINUX_DIR@@/proc/cpuinfo ]; then
+ echo "************************************************************"
+ echo "It seems Linux procfs is not mounted on @@LINUX_DIR@@/proc."
+ echo "VMware does not work without Linux procfs mounted."
+ echo
+ echo "For details, see linprocfs(5) manpage."
+ echo "************************************************************"
+ exit 1
+fi
+
LANG=C
PATH=/bin:$PATH
diff --git a/emulators/vmware3/Makefile b/emulators/vmware3/Makefile
index ee9f2c7e8912..8c3e94090f8a 100644
--- a/emulators/vmware3/Makefile
+++ b/emulators/vmware3/Makefile
@@ -76,6 +76,7 @@ setoptions:
${FILESDIR}/vmware.sh > ${WRKDIR}/vmware.sh
${SED} -e 's;@@PREFIX@@;${PREFIX};' \
+ -e 's;@@LINUX_DIR@@;${LINUX_DIR};' \
${FILESDIR}/vmware > ${WRKDIR}/vmware
pre-install: setoptions
diff --git a/emulators/vmware3/files/vmware b/emulators/vmware3/files/vmware
index 8bf4e133d6c7..7109da2fdb63 100644
--- a/emulators/vmware3/files/vmware
+++ b/emulators/vmware3/files/vmware
@@ -4,6 +4,16 @@
#
# $FreeBSD$
+if [ ! -e @@LINUX_DIR@@/proc/cpuinfo ]; then
+ echo "************************************************************"
+ echo "It seems Linux procfs is not mounted on @@LINUX_DIR@@/proc."
+ echo "VMware does not work without Linux procfs mounted."
+ echo
+ echo "For details, see linprocfs(5) manpage."
+ echo "************************************************************"
+ exit 1
+fi
+
LANG=C
PATH=/bin:$PATH