aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dns/bind9-devel/Makefile4
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl18
-rw-r--r--dns/bind9-devel/files/patch-configure8
4 files changed, 18 insertions, 18 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index d79044d7d746..796bef28e8db 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -30,8 +30,8 @@ COMMENT= BIND DNS suite with updated DNSSEC and DNS64
LICENSE= MPL
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.12.0a.2016.12.28
-HASH= eff07b5
+ISCVERSION= 9.12.0a.2017.01.12
+HASH= d2e1b47
USES= cpe libedit
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index cd67427bd9d4..45bf851f03b7 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1483349274
-SHA256 (bind9-eff07b5.tar.gz) = 50dc288d3d4e576bdae6cd2e14d5146712230983e2e856354a39dd5fc8941298
-SIZE (bind9-eff07b5.tar.gz) = 11811939
+TIMESTAMP = 1484208237
+SHA256 (bind9-d2e1b47.tar.gz) = 8945ede00fd1adf336ee0c92149f195d4dd3a6364422721a8ebfa4047cc7fb55
+SIZE (bind9-d2e1b47.tar.gz) = 11845654
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index c13bfea1fc5f..626ff171aae7 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
---- bin/named/config.c.orig 2016-12-04 23:46:43 UTC
+--- bin/named/config.c.orig 2017-01-12 03:25:45 UTC
+++ bin/named/config.c
-@@ -154,6 +154,8 @@ options {\n\
+@@ -158,6 +158,8 @@ options {\n\
lame-ttl 600;\n\
servfail-ttl 1;\n\
max-ncache-ttl 10800; /* 3 hours */\n\
@@ -9,9 +9,9 @@
max-cache-ttl 604800; /* 1 week */\n\
transfer-format many-answers;\n\
max-cache-size 90%;\n\
---- bin/named/server.c.orig 2016-12-04 23:46:43 UTC
+--- bin/named/server.c.orig 2017-01-12 03:25:45 UTC
+++ bin/named/server.c
-@@ -3638,6 +3638,16 @@ configure_view(dns_view_t *view, dns_vie
+@@ -3635,6 +3635,16 @@ configure_view(dns_view_t *view, dns_vie
}
obj = NULL;
@@ -28,7 +28,7 @@
result = ns_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2016-12-04 23:46:43 UTC
+--- lib/dns/include/dns/view.h.orig 2017-01-12 03:25:45 UTC
+++ lib/dns/include/dns/view.h
@@ -146,6 +146,8 @@ struct dns_view {
isc_boolean_t requestnsid;
@@ -39,9 +39,9 @@
dns_ttl_t maxncachettl;
isc_uint32_t nta_lifetime;
isc_uint32_t nta_recheck;
---- lib/dns/resolver.c.orig 2016-12-04 23:46:43 UTC
+--- lib/dns/resolver.c.orig 2017-01-12 03:25:45 UTC
+++ lib/dns/resolver.c
-@@ -5433,6 +5433,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
+@@ -5462,6 +5462,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
}
/*
@@ -60,9 +60,9 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl)
---- lib/isccfg/namedconf.c.orig 2016-12-04 23:46:43 UTC
+--- lib/isccfg/namedconf.c.orig 2017-01-12 03:25:45 UTC
+++ lib/isccfg/namedconf.c
-@@ -1760,6 +1760,8 @@ view_clauses[] = {
+@@ -1782,6 +1782,8 @@ view_clauses[] = {
{ "nosit-udp-size", &cfg_type_uint32, CFG_CLAUSEFLAG_OBSOLETE },
{ "max-acache-size", &cfg_type_sizenodefault, 0 },
{ "max-cache-size", &cfg_type_sizeorpercent, 0 },
diff --git a/dns/bind9-devel/files/patch-configure b/dns/bind9-devel/files/patch-configure
index c24b1ea468b2..2948fd96e571 100644
--- a/dns/bind9-devel/files/patch-configure
+++ b/dns/bind9-devel/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2016-12-04 23:46:43 UTC
+--- configure.orig 2017-01-12 03:25:45 UTC
+++ configure
-@@ -14385,27 +14385,9 @@ done
+@@ -14389,27 +14389,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -30,7 +30,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -14448,47 +14430,7 @@ $as_echo "no" >&6; } ;;
+@@ -14452,47 +14434,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -79,7 +79,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -22648,7 +22590,7 @@ $as_echo "" >&6; }
+@@ -22654,7 +22596,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).