aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/dap/Makefile2
-rw-r--r--audio/dap/files/patch-ad14
-rw-r--r--audio/dap/files/patch-ae16
-rw-r--r--audio/xtuner/Makefile2
-rw-r--r--audio/xtuner/files/patch-ab9
-rw-r--r--emulators/bfe/Makefile4
-rw-r--r--ftp/xrmftp/Makefile2
-rw-r--r--ftp/xrmftp/files/patch-aa13
-rw-r--r--graphics/xmrm/files/patch-aa13
-rw-r--r--graphics/xmrm/files/patch-ab13
-rw-r--r--japanese/lyx/Makefile2
-rw-r--r--japanese/lyx/files/patch-ab57
-rw-r--r--japanese/lyx/files/patch-ac12
-rw-r--r--math/apc/Makefile2
-rw-r--r--math/apc/files/patch-aa15
15 files changed, 138 insertions, 38 deletions
diff --git a/audio/dap/Makefile b/audio/dap/Makefile
index c9bade39e979..4cc9ee0527e0 100644
--- a/audio/dap/Makefile
+++ b/audio/dap/Makefile
@@ -13,7 +13,7 @@ EXTRACT_SUFX=.tgz
MAINTAINER= yoshiaki@kt.rim.or.jp
-LIB_DEPENDS= xforms.0:${PORTSDIR}/x11-toolkits/xforms
+LIB_DEPENDS= forms.0:${PORTSDIR}/x11-toolkits/xforms
MAKEFILE= Makefile.linux
USE_X_PREFIX= yes
diff --git a/audio/dap/files/patch-ad b/audio/dap/files/patch-ad
index d7d50441956a..8822b938ff1e 100644
--- a/audio/dap/files/patch-ad
+++ b/audio/dap/files/patch-ad
@@ -1,6 +1,6 @@
---- spkit/spkit/Makefile.linux.orig Sun Jul 1 13:36:58 2001
-+++ spkit/spkit/Makefile.linux Sun Jul 1 13:38:17 2001
-@@ -1,16 +1,16 @@
+--- spkit/spkit/Makefile.linux.orig Wed Aug 9 18:27:20 2000
++++ spkit/spkit/Makefile.linux Tue Jul 2 02:11:41 2002
+@@ -1,16 +1,19 @@
-CC = gcc
-CXX = g++
+CC ?= gcc
@@ -12,9 +12,13 @@
MAINDIR = ../../main
HOMEDIR = $(HOME)
-X11DIR = /usr/X11R6
-+X11DIR = ${X11BASE}
- INCDIR = -I. -I.. -I../.. -I$(SOUND) -I$(FORMS) -I$(MAINDIR) -I$(TOOLTIP) -I$(X11DIR)/include
+-INCDIR = -I. -I.. -I../.. -I$(SOUND) -I$(FORMS) -I$(MAINDIR) -I$(TOOLTIP) -I$(X11DIR)/include
-CCFLAGS = $(INCDIR) $(DEBUG) $(OPTIM) -DLINUX -DBIGENDIAN -DUSINGGCC -Wall -Wno-unused
++X11DIR = ${X11BASE}
++.if exists(${X11BASE}/include/X11/forms.h)
++XFORMSINC = -I${X11BASE}/include/X11
++.endif
++INCDIR = -I. -I.. -I../.. -I$(SOUND) -I$(FORMS) -I$(MAINDIR) -I$(TOOLTIP) -I$(X11DIR)/include ${XFORMSINC}
+CCFLAGS += $(INCDIR) $(OPTIM) -DLINUX -DBIGENDIAN -DUSINGGCC -Wall -Wno-unused
DEBUG = -g3
-OPTIM = -O2
diff --git a/audio/dap/files/patch-ae b/audio/dap/files/patch-ae
index f18dd87302dc..c50786623061 100644
--- a/audio/dap/files/patch-ae
+++ b/audio/dap/files/patch-ae
@@ -1,5 +1,5 @@
---- main/Makefile.linux.orig Sun Jul 1 13:42:55 2001
-+++ main/Makefile.linux Sun Jul 1 13:42:31 2001
+--- main/Makefile.linux.orig Tue Nov 7 18:16:54 2000
++++ main/Makefile.linux Tue Jul 2 02:16:04 2002
@@ -1,5 +1,5 @@
-CC = gcc
-CXX = g++
@@ -8,21 +8,23 @@
FORMS = ../../xforms/FORMS
SOUND = ../sound
SPKIT = ../spkit
-@@ -8,13 +8,13 @@
+@@ -8,12 +8,15 @@
AUDIOF = ../libaudiofile
BACKDIR = ../bak/main
HOMEDIR = $(HOME)
-X11DIR = /usr/X11R6
+-INCDIR = -I. -I.. -I$(SOUND) -I$(SPKIT) -I$(FORMS) -I$(TOOLTIP) -I$(X11DIR)/include
+X11DIR = ${X11BASE}
- INCDIR = -I. -I.. -I$(SOUND) -I$(SPKIT) -I$(FORMS) -I$(TOOLTIP) -I$(X11DIR)/include
++.if exists(${X11BASE}/include/X11/forms.h)
++XFORMSINC = -I${X11BASE}/include/X11
++.endif
++INCDIR = -I. -I.. -I$(SOUND) -I$(SPKIT) -I$(FORMS) -I$(TOOLTIP) -I$(X11DIR)/include ${XFORMSINC}
LIBDIR = -L$(SPKIT)/spkit -L$(FORMS) -L$(AUDIO) -L$(AUDIOF) -L$(TOOLTIP) -L$(X11DIR)/lib
-CCFLAGS = $(INCDIR) $(DEBUG) $(OPTIM) -DLINUX -DBIGENDIAN -DUSINGGCC -Wall -Wno-unused
+CCFLAGS = $(INCDIR) $(OPTIM) -DLINUX -DBIGENDIAN -DUSINGGCC -Wall -Wno-unused
DEBUG = -g3
-OPTIM = -O1
--LDFLAGS = $(LIBDIR) -ldsp -laudio -laudiofile -ltooltips -lforms -lXpm -lX11 -lm
+OPTIM = ${CXXFLAGS}
-+LDFLAGS = $(LIBDIR) -ldsp -laudio -laudiofile -ltooltips -lxforms -lXpm -lX11 -lm
+ LDFLAGS = $(LIBDIR) -ldsp -laudio -laudiofile -ltooltips -lforms -lXpm -lX11 -lm
PROGS = DAP
- OBJS = DPTich.o DPTich_cb.o DPTich_DSP.o DPTich_edit_cb.o DPTich_macros.o \
diff --git a/audio/xtuner/Makefile b/audio/xtuner/Makefile
index 296b56d00348..f9ab2577d082 100644
--- a/audio/xtuner/Makefile
+++ b/audio/xtuner/Makefile
@@ -13,7 +13,7 @@ DISTNAME= Xtuner-${PORTVERSION}
MAINTAINER= Lars.Koeller@Uni-Bielefeld.DE
-LIB_DEPENDS= xforms.0:${PORTSDIR}/x11-toolkits/xforms
+LIB_DEPENDS= forms.0:${PORTSDIR}/x11-toolkits/xforms
USE_IMAKE= YES
USE_XPM= YES
diff --git a/audio/xtuner/files/patch-ab b/audio/xtuner/files/patch-ab
index 7aba581cc857..b340533ac820 100644
--- a/audio/xtuner/files/patch-ab
+++ b/audio/xtuner/files/patch-ab
@@ -1,5 +1,5 @@
---- Imakefile.orig Fri Dec 20 04:31:12 1996
-+++ Imakefile Sun Dec 10 17:12:58 2000
+--- Imakefile.orig Thu Dec 19 14:31:12 1996
++++ Imakefile Mon Jul 1 00:30:04 2002
@@ -25,9 +25,13 @@
*/
@@ -7,10 +7,11 @@
- CC= gcc
+XCOMM CC= gcc
EXTRA_DEFINES= -D_HAVE_PARAM_H
+- LOCAL_LIBRARIES= -lxforms -lXpm -lX11 -lm
+#if defined (AlphaArchitecture)
-+ LOCAL_LIBRARIES= -lxforms -lXpm -lX11 -lm -lio
++ LOCAL_LIBRARIES= -lforms -lXpm -lX11 -lm -lio
+#else
- LOCAL_LIBRARIES= -lxforms -lXpm -lX11 -lm
++ LOCAL_LIBRARIES= -lforms -lXpm -lX11 -lm
+#endif
#else
CFLAGS= -O2 -m486
diff --git a/emulators/bfe/Makefile b/emulators/bfe/Makefile
index 3b899a9adce5..8ead93038b6c 100644
--- a/emulators/bfe/Makefile
+++ b/emulators/bfe/Makefile
@@ -12,16 +12,18 @@ MASTER_SITES= http://www.qzx.com/bfe/_download/
MAINTAINER= greid@FreeBSD.org
-LIB_DEPENDS= xforms.0:${PORTSDIR}/x11-toolkits/xforms
+LIB_DEPENDS= forms.0:${PORTSDIR}/x11-toolkits/xforms
RUN_DEPENDS= bochs:${PORTSDIR}/emulators/bochs
USE_X_PREFIX= yes
+USE_XPM= yes
WRKSRC= ${WRKDIR}/bfe
pre-build:
${PERL} -pi -e "s@/usr/X11R6@${X11BASE}@g; \
s@/usr/local@${LOCALBASE}@g; \
+ s@-lforms@-lforms -lXpm@g; \
s@gcc@${CC}@g; s@-O2@${CFLAGS}@g" ${WRKSRC}/Makefile
do-install:
diff --git a/ftp/xrmftp/Makefile b/ftp/xrmftp/Makefile
index 7fbcb5ac9eb8..cec61d188afa 100644
--- a/ftp/xrmftp/Makefile
+++ b/ftp/xrmftp/Makefile
@@ -14,7 +14,7 @@ EXTRACT_SUFX= .src.tgz
MAINTAINER= matt@LUCIDA.CA
-LIB_DEPENDS= xforms.0:${PORTSDIR}/x11-toolkits/xforms
+LIB_DEPENDS= forms.0:${PORTSDIR}/x11-toolkits/xforms
USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/xrmftp-1.2.4.src
diff --git a/ftp/xrmftp/files/patch-aa b/ftp/xrmftp/files/patch-aa
index 817b793bd0c1..95c208e83f76 100644
--- a/ftp/xrmftp/files/patch-aa
+++ b/ftp/xrmftp/files/patch-aa
@@ -1,18 +1,23 @@
--- Makefile.orig Tue Nov 17 19:25:43 1998
-+++ Makefile Sun Mar 11 05:59:19 2001
-@@ -1,17 +1,20 @@
++++ Makefile Mon Jul 1 01:56:44 2002
+@@ -1,17 +1,24 @@
-CC=gcc
-XFORMSLIBPATH=/usr/X11R6/lib # path to xforms library
-XFORMSINCPATH=/usr/X11R6/include # path to xforms header file <forms.h>
-XLIBSPATH=/usr/X11R6/lib # path to standard X libraries
-XINCPATH=/usr/X11R6/include # path to standard X header files
+-LIBS= -lm -lX11 -lforms # libraries
+X11BASE?=/usr/X11R6
+CC ?=gcc
+XFORMSLIBPATH=${X11BASE}/lib # path to xforms library
-+XFORMSINCPATH=${X11BASE}/include # path to xforms header file <forms.h>
++.if exists (${X11BASE}/include/X11/forms.h)
++XFORMSINCPATH=${X11BASE}/include/X11
++.else
++XFORMSINCPATH=${X11BASE}/include
++.endif
+XLIBSPATH=${X11BASE}/lib # path to standard X libraries
+XINCPATH=${X11BASE}/include # path to standard X header files
- LIBS= -lm -lX11 -lforms # libraries
++LIBS= -lm -lX11 -lforms -lXpm # libraries
#EXTRALIBS=-lnsl -lsocket # additional libraries needed by some unices
SRC=xftp.c fd_xftp.c
OBJ=$(SRC:.c=.o)
diff --git a/graphics/xmrm/files/patch-aa b/graphics/xmrm/files/patch-aa
index 7b1f38b31bc0..dd13f58e8a17 100644
--- a/graphics/xmrm/files/patch-aa
+++ b/graphics/xmrm/files/patch-aa
@@ -1,5 +1,5 @@
---- Makefile.orig Tue Mar 10 00:00:00 1998
-+++ Makefile Sun Mar 11 15:48:25 2001
+--- Makefile.orig Mon Mar 9 18:00:00 1998
++++ Makefile Mon Jul 1 03:46:01 2002
@@ -16,8 +16,8 @@
#
##############################################################################
@@ -11,12 +11,17 @@
# -c: don't link yet
# -g: produce debugging-information, don't use together with link_flag -s
-@@ -29,14 +29,14 @@
+@@ -28,15 +28,19 @@
+ # -c: don't link yet
#COMPILE_FLAGS = -O3 -m486 -c
++.if exists(${X11BASE}/include/X11/forms.h)
++XFORMSINC = -I${X11BASE}/include/X11
++.endif
++
# -O: normal optimization level -c: don't link yet
-COMPILE_FLAGS = -O -c
-+COMPILE_FLAGS = ${CFLAGS} -I${PREFIX}/include -I${X11BASE}/include -c
++COMPILE_FLAGS = ${CFLAGS} -I${PREFIX}/include -I${X11BASE}/include ${XFORMSINC} -c
# -s: DESTROYS symbol-table
-LINK_FLAGS = -s
diff --git a/graphics/xmrm/files/patch-ab b/graphics/xmrm/files/patch-ab
index 6403b6168169..6806849d26e0 100644
--- a/graphics/xmrm/files/patch-ab
+++ b/graphics/xmrm/files/patch-ab
@@ -1,6 +1,6 @@
---- const.h.orig Mon Mar 9 17:00:00 1998
-+++ const.h Tue Mar 28 15:23:34 2000
-@@ -3,7 +3,7 @@
+--- const.h.orig Mon Mar 9 18:00:00 1998
++++ const.h Mon Jul 1 03:46:45 2002
+@@ -3,12 +3,14 @@
// Programming: Gerhard Waldhör, Andreas Artmann
#include <stdio.h>
@@ -9,3 +9,10 @@
#include <errno.h>
#include <math.h>
++#ifndef TRUE
+ #define TRUE 1
+ #define FALSE 0
++#endif
+
+ #define MAX_PIC_NUM 999
+
diff --git a/japanese/lyx/Makefile b/japanese/lyx/Makefile
index 2cbf8e9f9219..bec89c217945 100644
--- a/japanese/lyx/Makefile
+++ b/japanese/lyx/Makefile
@@ -22,7 +22,7 @@ MAINTAINER= flathill@FreeBSD.ORG
#.if defined(WITH_ISPELL)
#RUN_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
#.endif
-LIB_DEPENDS= xforms.0:${PORTSDIR}/x11-toolkits/xforms
+LIB_DEPENDS= forms.0:${PORTSDIR}/x11-toolkits/xforms
USE_XPM= yes
USE_PERL5= yes
diff --git a/japanese/lyx/files/patch-ab b/japanese/lyx/files/patch-ab
new file mode 100644
index 000000000000..90179d0a41c1
--- /dev/null
+++ b/japanese/lyx/files/patch-ab
@@ -0,0 +1,57 @@
+--- src/main.C.orig Tue Jul 2 00:11:14 2002
++++ src/main.C Tue Jul 2 00:11:52 2002
+@@ -21,16 +21,6 @@
+ static char vcid[] = "$Id: main.C,v 1.2 1998/06/22 05:50:57 arrae Exp $";
+ #endif /* lint */
+
+-// I keep these here so that it will be processed as early in
+-// the compilation process as possible.
+-#if !defined(FL_REVISION) || (FL_REVISION != 81 && FL_REVISION != 86 &&\
+- FL_REVISION != 87 && FL_REVISION != 88) \
+- || FL_VERSION != 0
+-#error LyX will not compile with this version of XForms.\
+- Please get version 0.88 (0.81 and 0.86 also work).\
+- If you want to try to compile anyway, delete this test in src/main.C.
+-#endif
+-
+
+ int main(int argc, char *argv[])
+ {
+--- src/lyx_gui_misc.h.orig Tue Jul 2 00:23:13 2002
++++ src/lyx_gui_misc.h Tue Jul 2 00:23:32 2002
+@@ -64,7 +64,7 @@
+ inline
+ void LyXBell() {
+ // if (audio()) ON/OFF switch yet to be implemented
+-#if FL_REVISION > 85
++#if FL_VERSION > 0 || FL_REVISION > 85
+ fl_ringbell(20);
+ #else
+ ringbell();
+--- src/lyx_gui_misc.C.orig Tue Jul 2 00:27:17 2002
++++ src/lyx_gui_misc.C Tue Jul 2 00:30:10 2002
+@@ -379,7 +379,7 @@
+ {
+ fl_set_resource("flQuestion.yes.label", idex(_("Yes|Yy#y")));
+ fl_set_resource("flQuestion.no.label", idex(_("No|Nn#n")));
+-#if FL_REVISION > 85
++#if FL_VERSION > 0 || FL_REVISION > 85
+ return fl_show_question((s1 + "\n" + s2 + "\n" + s3).c_str(), 0);
+ #else
+ return fl_show_question(s1.c_str(), s2.c_str(), s3.c_str());
+@@ -392,13 +392,12 @@
+ fl_set_choices_shortcut(scex(_("Yes|Yy#y")),
+ scex(_("No|Nn#n")),
+ scex(_("Cancel|^[")));
+-#if FL_REVISION < 86
++#if FL_VERSION == 0 && FL_REVISION < 86
+ return fl_show_choice(s1.c_str(), s2.c_str(), s3.c_str(),
+ 3, idex(_("Yes|Yy#y")),
+ idex(_("No|Nn#n")),
+ idex(_("Cancel|^[")));
+-#endif
+-#if FL_REVISION > 85
++#else
+ return fl_show_choice(s1.c_str(), s2.c_str(), s3.c_str(),
+ 3, idex(_("Yes|Yy#y")),
+ idex(_("No|Nn#n")),
diff --git a/japanese/lyx/files/patch-ac b/japanese/lyx/files/patch-ac
new file mode 100644
index 000000000000..7531db9275d1
--- /dev/null
+++ b/japanese/lyx/files/patch-ac
@@ -0,0 +1,12 @@
+--- src/screen.C.orig Tue Jul 2 00:53:03 2002
++++ src/screen.C Tue Jul 2 00:53:23 2002
+@@ -809,9 +809,6 @@
+ // I want the buttons back before 0.12. OK, this is very simple,
+ // like what is done in xforms sources. (Ale)
+
+- // This one is too dirty. Get rid of it.
+- extern GC fl_gc;
+-
+ // Please comment this annonymous variable.
+ int d = 2;
+
diff --git a/math/apc/Makefile b/math/apc/Makefile
index 7bc1ff049b6d..2b0a1fd2246d 100644
--- a/math/apc/Makefile
+++ b/math/apc/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= http://members.global2000.net/~eagriff/
MAINTAINER= eagriff@global2000.net
-LIB_DEPENDS= xforms.0:${PORTSDIR}/x11-toolkits/xforms
+LIB_DEPENDS= forms.0:${PORTSDIR}/x11-toolkits/xforms
USE_X_PREFIX= yes
MAN1= apc.1
diff --git a/math/apc/files/patch-aa b/math/apc/files/patch-aa
index 7fe0dcbbfc50..9d55486bc273 100644
--- a/math/apc/files/patch-aa
+++ b/math/apc/files/patch-aa
@@ -1,11 +1,16 @@
---- Makefile.orig Fri Aug 31 23:39:56 2001
-+++ Makefile Fri Aug 31 23:40:02 2001
-@@ -2,7 +2,7 @@
+--- Makefile.orig Mon Oct 13 15:25:38 1997
++++ Makefile Tue Jul 2 01:04:00 2002
+@@ -1,8 +1,11 @@
+ # New Makefile for apc (13 October 1997)
#
- CFLAGS+=-DOS=\"$(OSTYPE)\" -I${X11BASE}/include
+-CFLAGS+=-DOS=\"$(OSTYPE)\" -I${X11BASE}/include
++.if exists(${X11BASE}/include/X11/forms.h)
++XFORMSINC=-I${X11BASE}/include/X11
++.endif
++CFLAGS+=-DOS=\"$(OSTYPE)\" -I${X11BASE}/include ${XFORMSINC}
LDFLAGS+=-L${X11BASE}/lib
-LDADD+=-lxforms -lX11 -lm
-+LDADD+=-lxforms -lX11 -lm -lXpm
++LDADD+=-lforms -lX11 -lm -lXpm
BINDIR=${X11BASE}/bin
MANDIR=${X11BASE}/man/man
PROG= apc