aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/apache24/Makefile5
-rw-r--r--www/apache24/files/README_modules.d14
-rw-r--r--www/apache24/files/patch-docs__conf__httpd.conf.in18
-rw-r--r--www/apache24/pkg-plist2
4 files changed, 33 insertions, 6 deletions
diff --git a/www/apache24/Makefile b/www/apache24/Makefile
index c2f9e988785f..464cc25da7ad 100644
--- a/www/apache24/Makefile
+++ b/www/apache24/Makefile
@@ -64,7 +64,7 @@ SSL_USE= OPENSSL=yes
.include <bsd.port.options.mk>
-ETC_SUBDIRS= Includes envvars.d extra
+ETC_SUBDIRS= Includes envvars.d extra modules.d
.if ! ${PORT_OPTIONS:MDOCS}
MAKE_ENV+= NOPORTDOCS=yes
@@ -148,7 +148,8 @@ post-configure:
post-install:
@${MKDIR} ${ETC_SUBDIRS:S|^|${STAGEDIR}${ETCDIR}/|}
- @${INSTALL_DATA} ${FILESDIR}/no-accf.conf ${STAGEDIR}${ETCDIR}/Includes/
+ ${INSTALL_DATA} ${FILESDIR}/no-accf.conf ${STAGEDIR}${ETCDIR}/Includes/
+ ${INSTALL_DATA} ${FILESDIR}/README_modules.d ${STAGEDIR}/${ETCDIR}/modules.d/
.if ${PORT_OPTIONS:MLOG_FORENSIC}
@${INSTALL_SCRIPT} ${WRKSRC}/support/check_forensic ${STAGEDIR}${PREFIX}/sbin
diff --git a/www/apache24/files/README_modules.d b/www/apache24/files/README_modules.d
new file mode 100644
index 000000000000..2d50ce539aeb
--- /dev/null
+++ b/www/apache24/files/README_modules.d
@@ -0,0 +1,14 @@
+# ===================================================
+# Directory for third party module config files.
+#
+# Modules can be disabled by adding a '#' in front
+# of the "LoadModule" line e.g. "#LoadModule"
+#
+# Files are automatically included if the name
+# begins with a three digit number followed by '_'
+# and ending in '.conf' e.g. '080_mod_php.conf'
+#
+# Maintainers can also include instructions how to
+# use the module (instead pkg-message).
+#
+
diff --git a/www/apache24/files/patch-docs__conf__httpd.conf.in b/www/apache24/files/patch-docs__conf__httpd.conf.in
index 244f0267d06d..b7ea014c1914 100644
--- a/www/apache24/files/patch-docs__conf__httpd.conf.in
+++ b/www/apache24/files/patch-docs__conf__httpd.conf.in
@@ -1,6 +1,16 @@
--- ./docs/conf/httpd.conf.in.orig 2012-11-08 04:05:38.000000000 +0100
+++ ./docs/conf/httpd.conf.in 2013-10-26 19:29:20.000000000 +0200
-@@ -74,8 +74,8 @@
+@@ -65,6 +65,9 @@
+ #
+ @@LoadModule@@
+
++# Third party modules
++IncludeOptional @rel_sysconfdir@/modules.d/[0-9[0-9][0-9]_*.conf
++
+ <IfModule unixd_module>
+ #
+ # If you wish httpd to run as a different user or group, you must run
+@@ -74,8 +77,8 @@
# It is usually good practice to create a dedicated user and group for
# running httpd, as with most system services.
#
@@ -11,7 +21,7 @@
</IfModule>
-@@ -181,7 +181,7 @@
+@@ -181,7 +184,7 @@
# logged here. If you *do* define an error logfile for a <VirtualHost>
# container, that host's errors will be logged there and not here.
#
@@ -20,7 +30,7 @@
#
# LogLevel: Control the number of messages logged to the error_log.
-@@ -210,13 +210,13 @@
+@@ -210,13 +213,13 @@
# define per-<VirtualHost> access logfiles, transactions will be
# logged therein and *not* in this file.
#
@@ -36,7 +46,7 @@
</IfModule>
<IfModule alias_module>
-@@ -418,3 +418,5 @@
+@@ -418,3 +421,5 @@
#RequestHeader unset DNT env=bad_DNT
#</IfModule>
diff --git a/www/apache24/pkg-plist b/www/apache24/pkg-plist
index b787093d76cd..211a552e24fe 100644
--- a/www/apache24/pkg-plist
+++ b/www/apache24/pkg-plist
@@ -10,6 +10,7 @@ bin/htpasswd
bin/httxt2dbm
bin/logresolve
%%ETCDIR%%/Includes/no-accf.conf
+%%ETCDIR%%/modules.d/README_modules.d
include/apache24/ap_compat.h
include/apache24/ap_config.h
include/apache24/ap_config_auto.h
@@ -558,6 +559,7 @@ sbin/split-logfile
@dirrmtry libexec/apache24
@dirrmtry include/apache24
@unexec rm -f %D/%%ETCDIR%%/httpd.conf.bak 2> /dev/null || true
+@dirrmtry %%ETCDIR%%/modules.d
@dirrmtry %%ETCDIR%%/extra
@dirrmtry %%ETCDIR%%/envvars.d
@dirrmtry %%ETCDIR%%/Includes