aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/par/Makefile37
-rw-r--r--archivers/par/distinfo2
-rw-r--r--archivers/par/pkg-descr4
4 files changed, 44 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 95f146e17780..d0cc67be2162 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -122,6 +122,7 @@
SUBDIR += p7zip
SUBDIR += packddir
SUBDIR += paq
+ SUBDIR += par
SUBDIR += par2cmdline
SUBDIR += par2cmdline-tbb
SUBDIR += parchive
diff --git a/archivers/par/Makefile b/archivers/par/Makefile
new file mode 100644
index 000000000000..a4bebf4c3ee0
--- /dev/null
+++ b/archivers/par/Makefile
@@ -0,0 +1,37 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= par
+PORTVERSION= 0.03.01
+CATEGORIES= archivers games
+MASTER_SITES= http://ibiblio.org/pub/linux/games/quake/
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Archiver for Quake I and II packed data files
+
+LICENSE= GPLv2
+
+MAKEFILE= Makefile.Linux
+MAKE_ARGS= CC="${CC}"
+
+PLIST_FILES= bin/${PORTNAME}
+MAN1= ${PORTNAME}.1
+PORTDOCS= ChangeLog README
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,-Wall.*-pipe,${CFLAGS}, ; \
+ s,\"Linux,\"${OPSYS},' ${WRKSRC}/${MAKEFILE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/archivers/par/distinfo b/archivers/par/distinfo
new file mode 100644
index 000000000000..de445df41377
--- /dev/null
+++ b/archivers/par/distinfo
@@ -0,0 +1,2 @@
+SHA256 (par-0.03.01.tar.gz) = e68a3b78586cd762b29f5d5edca8ea9f263fa100423f4d4fee36c7e0a5061122
+SIZE (par-0.03.01.tar.gz) = 21380
diff --git a/archivers/par/pkg-descr b/archivers/par/pkg-descr
new file mode 100644
index 000000000000..b8832ec684c4
--- /dev/null
+++ b/archivers/par/pkg-descr
@@ -0,0 +1,4 @@
+This is par, an archiver for Quake I and II packed data files (pakX.pak).
+It supports listing, extraction, and creation of .pak archives.
+
+WWW: http://ibiblio.org/pub/linux/games/quake/