aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--deskutils/xfce4-notification-daemon/Makefile2
-rw-r--r--devel/p5-Data-TreeDumper-Renderer-GTK/Makefile4
-rw-r--r--devel/p5-Eval-Context/Makefile30
-rw-r--r--games/textmaze/Makefile2
-rw-r--r--graphics/asciio/Makefile38
-rw-r--r--mail/delatt/Makefile2
-rw-r--r--mail/p5-Sendmail-AccessDB/Makefile2
-rw-r--r--ports-mgmt/distilator/Makefile2
-rw-r--r--textproc/p5-Text-vCard/Makefile4
-rw-r--r--www/p5-Reddit/Makefile2
10 files changed, 44 insertions, 44 deletions
diff --git a/deskutils/xfce4-notification-daemon/Makefile b/deskutils/xfce4-notification-daemon/Makefile
index 3b064f487874..f58fd987e144 100644
--- a/deskutils/xfce4-notification-daemon/Makefile
+++ b/deskutils/xfce4-notification-daemon/Makefile
@@ -19,7 +19,7 @@ COMMENT= Port of Gnome's notification-daemon for the Xfce desktop
LICENSE= GPLv2
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
LIB_DEPENDS= sexy.2:${PORTSDIR}/x11-toolkits/libsexy \
dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
RUN_DEPENDS= dbus-daemon:${PORTSDIR}/devel/dbus
diff --git a/devel/p5-Data-TreeDumper-Renderer-GTK/Makefile b/devel/p5-Data-TreeDumper-Renderer-GTK/Makefile
index a93045284b25..2fe3767d8284 100644
--- a/devel/p5-Data-TreeDumper-Renderer-GTK/Makefile
+++ b/devel/p5-Data-TreeDumper-Renderer-GTK/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= GTK renderer for Data::TreeDumper
-BUILD_DEPENDS= ${SITE_PERL}/Data/TreeDumper.pm:${PORTSDIR}/devel/p5-Data-TreeDumper \
- ${SITE_PERL}/${PERL_ARCH}/Gtk2.pm:${PORTSDIR}/x11-toolkits/p5-Gtk2
+BUILD_DEPENDS= p5-Data-TreeDumper>=0:${PORTSDIR}/devel/p5-Data-TreeDumper \
+ p5-Gtk2>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Eval-Context/Makefile b/devel/p5-Eval-Context/Makefile
index c994a006e88c..3d046edfa9a5 100644
--- a/devel/p5-Eval-Context/Makefile
+++ b/devel/p5-Eval-Context/Makefile
@@ -15,21 +15,21 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Evalute perl code in context wraper
-BUILD_DEPENDS= ${SITE_PERL}/Test/Output.pm:${PORTSDIR}/devel/p5-Test-Output \
- ${SITE_PERL}/Package/Generator.pm:${PORTSDIR}/devel/p5-Package-Generator \
- ${SITE_PERL}/Test/Spelling.pm:${PORTSDIR}/devel/p5-Test-Spelling \
- ${SITE_PERL}/Test/Block.pm:${PORTSDIR}/devel/p5-Test-Block \
- ${SITE_PERL}/Test/NoWarnings.pm:${PORTSDIR}/devel/p5-Test-NoWarnings \
- ${SITE_PERL}/Test/Distribution.pm:${PORTSDIR}/devel/p5-Test-Distribution \
- ${SITE_PERL}/Test/Warn.pm:${PORTSDIR}/devel/p5-Test-Warn \
- ${SITE_PERL}/Test/Pod.pm:${PORTSDIR}/devel/p5-Test-Pod \
- ${SITE_PERL}/Test/Dependencies.pm:${PORTSDIR}/devel/p5-Test-Dependencies \
- ${SITE_PERL}/${PERL_ARCH}/version.pm:${PORTSDIR}/devel/p5-version \
- ${SITE_PERL}/Test/Strict.pm:${PORTSDIR}/devel/p5-Test-Strict \
- ${SITE_PERL}/Directory/Scratch/Structured.pm:${PORTSDIR}/devel/p5-Directory-Scratch-Structured \
- ${SITE_PERL}/Data/TreeDumper.pm:${PORTSDIR}/devel/p5-Data-TreeDumper \
- ${SITE_PERL}/Data/Compare.pm:${PORTSDIR}/devel/p5-Data-Compare \
- ${SITE_PERL}/File/Slurp.pm:${PORTSDIR}/devel/p5-File-Slurp
+BUILD_DEPENDS= p5-Test-Output>=0:${PORTSDIR}/devel/p5-Test-Output \
+ p5-Package-Generator>=0:${PORTSDIR}/devel/p5-Package-Generator \
+ p5-Test-Spelling>=0:${PORTSDIR}/devel/p5-Test-Spelling \
+ p5-Test-Block>=0:${PORTSDIR}/devel/p5-Test-Block \
+ p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings \
+ p5-Test-Distribution>=0:${PORTSDIR}/devel/p5-Test-Distribution \
+ p5-Test-Warn>=0:${PORTSDIR}/devel/p5-Test-Warn \
+ p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-Test-Dependencies>=0:${PORTSDIR}/devel/p5-Test-Dependencies \
+ p5-version>=0:${PORTSDIR}/devel/p5-version \
+ p5-Test-Strict>=0:${PORTSDIR}/devel/p5-Test-Strict \
+ p5-Directory-Scratch-Structured>=0:${PORTSDIR}/devel/p5-Directory-Scratch-Structured \
+ p5-Data-TreeDumper>=0:${PORTSDIR}/devel/p5-Data-TreeDumper \
+ p5-Data-Compare>=0:${PORTSDIR}/devel/p5-Data-Compare \
+ p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_MODBUILD= yes
diff --git a/games/textmaze/Makefile b/games/textmaze/Makefile
index f726dfdc415c..f5dd5c80920d 100644
--- a/games/textmaze/Makefile
+++ b/games/textmaze/Makefile
@@ -16,7 +16,7 @@ DISTNAME= ${PORTNAME}_v${PORTVERSION}
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Generates mazes on a text terminal and lets you traverse them
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Curses.pm:${PORTSDIR}/devel/p5-Curses
+RUN_DEPENDS= p5-Curses>=0:${PORTSDIR}/devel/p5-Curses
USE_PERL5= yes
NO_BUILD= yes
diff --git a/graphics/asciio/Makefile b/graphics/asciio/Makefile
index 11d0640135bf..c31657bc82eb 100644
--- a/graphics/asciio/Makefile
+++ b/graphics/asciio/Makefile
@@ -16,25 +16,25 @@ DISTNAME= App-Asciio-${PORTVERSION}
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= A Perl/GTK application that lets you draw ASCII charts using a GUI
-BUILD_DEPENDS= ${SITE_PERL}/Directory/Scratch.pm:${PORTSDIR}/devel/p5-Directory-Scratch \
- ${SITE_PERL}/${PERL_ARCH}/Gtk2.pm:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
- ${SITE_PERL}/${PERL_ARCH}/Compress/Bzip2.pm:${PORTSDIR}/archivers/p5-Compress-Bzip2 \
- ${SITE_PERL}/Test/Block.pm:${PORTSDIR}/devel/p5-Test-Block \
- ${SITE_PERL}/Test/Pod.pm:${PORTSDIR}/devel/p5-Test-Pod \
- ${SITE_PERL}/Test/Distribution.pm:${PORTSDIR}/devel/p5-Test-Distribution \
- ${SITE_PERL}/Test/NoWarnings.pm:${PORTSDIR}/devel/p5-Test-NoWarnings \
- ${SITE_PERL}/Test/Warn.pm:${PORTSDIR}/devel/p5-Test-Warn \
- ${SITE_PERL}/Test/Strict.pm:${PORTSDIR}/devel/p5-Test-Strict \
- ${SITE_PERL}/Test/Dependencies.pm:${PORTSDIR}/devel/p5-Test-Dependencies \
- ${SITE_PERL}/Test/Spelling.pm:${PORTSDIR}/devel/p5-Test-Spelling \
- ${SITE_PERL}/${PERL_ARCH}/version.pm:${PORTSDIR}/devel/p5-version \
- ${SITE_PERL}/Data/TreeDumper/Renderer/GTK.pm:${PORTSDIR}/devel/p5-Data-TreeDumper-Renderer-GTK \
- ${SITE_PERL}/Algorithm/Diff.pm:${PORTSDIR}/devel/p5-Algorithm-Diff \
- ${SITE_PERL}/Data/Compare.pm:${PORTSDIR}/devel/p5-Data-Compare \
- ${SITE_PERL}/Module/Util.pm:${PORTSDIR}/devel/p5-Module-Util \
- ${SITE_PERL}/Sub/Exporter.pm:${PORTSDIR}/devel/p5-Sub-Exporter \
- ${SITE_PERL}/Eval/Context.pm:${PORTSDIR}/devel/p5-Eval-Context \
- ${SITE_PERL}/Check/ISA.pm:${PORTSDIR}/devel/p5-Check-ISA
+BUILD_DEPENDS= p5-Directory-Scratch>=0:${PORTSDIR}/devel/p5-Directory-Scratch \
+ p5-Gtk2>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
+ p5-Compress-Bzip2>=0:${PORTSDIR}/archivers/p5-Compress-Bzip2 \
+ p5-Test-Block>=0:${PORTSDIR}/devel/p5-Test-Block \
+ p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-Test-Distribution>=0:${PORTSDIR}/devel/p5-Test-Distribution \
+ p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings \
+ p5-Test-Warn>=0:${PORTSDIR}/devel/p5-Test-Warn \
+ p5-Test-Strict>=0:${PORTSDIR}/devel/p5-Test-Strict \
+ p5-Test-Dependencies>=0:${PORTSDIR}/devel/p5-Test-Dependencies \
+ p5-Test-Spelling>=0:${PORTSDIR}/devel/p5-Test-Spelling \
+ p5-version>=0:${PORTSDIR}/devel/p5-version \
+ p5-Data-TreeDumper-Renderer-GTK>=0:${PORTSDIR}/devel/p5-Data-TreeDumper-Renderer-GTK \
+ p5-Algorithm-Diff>=0:${PORTSDIR}/devel/p5-Algorithm-Diff \
+ p5-Data-Compare>=0:${PORTSDIR}/devel/p5-Data-Compare \
+ p5-Module-Util>=0:${PORTSDIR}/devel/p5-Module-Util \
+ p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter \
+ p5-Eval-Context>=0:${PORTSDIR}/devel/p5-Eval-Context \
+ p5-Check-ISA>=0:${PORTSDIR}/devel/p5-Check-ISA
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_MODBUILD= yes
diff --git a/mail/delatt/Makefile b/mail/delatt/Makefile
index 26a8c9e5ea65..d7e9131e9c89 100644
--- a/mail/delatt/Makefile
+++ b/mail/delatt/Makefile
@@ -16,7 +16,7 @@ COMMENT= Strip attachments from email
LICENSE= GPLv2
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+RUN_DEPENDS= p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64
USE_PERL5_RUN= 5.8.6+
NO_BUILD= yes
diff --git a/mail/p5-Sendmail-AccessDB/Makefile b/mail/p5-Sendmail-AccessDB/Makefile
index 1745050a9b58..27552ab136c9 100644
--- a/mail/p5-Sendmail-AccessDB/Makefile
+++ b/mail/p5-Sendmail-AccessDB/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Perl5 interface to the Sendmail access.db list
-BUILD_DEPENDS= ${SITE_PERL}/mach/BerkeleyDB.pm:${PORTSDIR}/databases/p5-BerkeleyDB
+BUILD_DEPENDS= p5-BerkeleyDB>=0:${PORTSDIR}/databases/p5-BerkeleyDB
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/ports-mgmt/distilator/Makefile b/ports-mgmt/distilator/Makefile
index 04c1a1431361..1200d363eb2d 100644
--- a/ports-mgmt/distilator/Makefile
+++ b/ports-mgmt/distilator/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ehaupt@FreeBSD.org
COMMENT= A command-line script to check the availability of a ports distfiles
RUN_DEPENDS= p5-URI>=1.56:${PORTSDIR}/net/p5-URI \
- ${SITE_PERL}/HTTP/Request.pm:${PORTSDIR}/www/p5-libwww
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= 5.10.1+
diff --git a/textproc/p5-Text-vCard/Makefile b/textproc/p5-Text-vCard/Makefile
index cb6f91fac919..2a01130bac17 100644
--- a/textproc/p5-Text-vCard/Makefile
+++ b/textproc/p5-Text-vCard/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= A package to parse, edit and create multiple vCards (RFC 2426)
-BUILD_DEPENDS= ${SITE_PERL}/File/Slurp.pm:${PORTSDIR}/devel/p5-File-Slurp \
- ${SITE_PERL}/Text/vFile/asData.pm:${PORTSDIR}/devel/p5-Text-vFile-asData
+BUILD_DEPENDS= p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp \
+ p5-Text-vFile-asData>=0:${PORTSDIR}/devel/p5-Text-vFile-asData
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/www/p5-Reddit/Makefile b/www/p5-Reddit/Makefile
index 45b264f5a0ca..0971dabe4dcc 100644
--- a/www/p5-Reddit/Makefile
+++ b/www/p5-Reddit/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Module for interacting with Reddit
-BUILD_DEPENDS= ${SITE_PERL}/Module/Install.pm:${PORTSDIR}/devel/p5-Module-Install \
+BUILD_DEPENDS= p5-Module-Install>=0:${PORTSDIR}/devel/p5-Module-Install \
p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
p5-ExtUtils-MakeMaker>=6.42:${PORTSDIR}/devel/p5-ExtUtils-MakeMaker \
p5-common-sense>=3.2:${PORTSDIR}/devel/p5-common-sense