aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/crystalspace-devel/Makefile4
-rw-r--r--graphics/crystalspace/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/graphics/crystalspace-devel/Makefile b/graphics/crystalspace-devel/Makefile
index a91a357f330f..09a23383ddd5 100644
--- a/graphics/crystalspace-devel/Makefile
+++ b/graphics/crystalspace-devel/Makefile
@@ -58,8 +58,8 @@ OPTIONS= DEBUG "Build with debugging information" on \
BROKEN= "Does not compile"
.endif
-.if ${ARCH} == "sparc64"
-BROKEN= "Does not compile on sparc64"
+.if ${ARCH} != "i386"
+BROKEN= Does not compile on ${ARCH}
.endif
.if !defined(WITHOUT_DEBUG)
diff --git a/graphics/crystalspace/Makefile b/graphics/crystalspace/Makefile
index a91a357f330f..09a23383ddd5 100644
--- a/graphics/crystalspace/Makefile
+++ b/graphics/crystalspace/Makefile
@@ -58,8 +58,8 @@ OPTIONS= DEBUG "Build with debugging information" on \
BROKEN= "Does not compile"
.endif
-.if ${ARCH} == "sparc64"
-BROKEN= "Does not compile on sparc64"
+.if ${ARCH} != "i386"
+BROKEN= Does not compile on ${ARCH}
.endif
.if !defined(WITHOUT_DEBUG)