aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-dill/Makefile21
-rw-r--r--devel/py-dill/distinfo3
-rw-r--r--devel/py-dill/pkg-descr6
4 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f3aa66a519c8..bdf8f169fed9 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4191,6 +4191,7 @@
SUBDIR += py-dexml
SUBDIR += py-dialog
SUBDIR += py-diazo
+ SUBDIR += py-dill
SUBDIR += py-dirspec
SUBDIR += py-distorm
SUBDIR += py-django-rq
diff --git a/devel/py-dill/Makefile b/devel/py-dill/Makefile
new file mode 100644
index 000000000000..b1e5e13dae96
--- /dev/null
+++ b/devel/py-dill/Makefile
@@ -0,0 +1,21 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= dill
+PORTVERSION= 0.2.5
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Serialize all of python
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python tar:tgz
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-dill/distinfo b/devel/py-dill/distinfo
new file mode 100644
index 000000000000..0e0735562756
--- /dev/null
+++ b/devel/py-dill/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1479597021
+SHA256 (dill-0.2.5.tgz) = 431c9d46e190dcdf1397234cf659d66e2e22e33b0474ed6ee2d0b16c9c0ea319
+SIZE (dill-0.2.5.tgz) = 60572
diff --git a/devel/py-dill/pkg-descr b/devel/py-dill/pkg-descr
new file mode 100644
index 000000000000..8dc7db203d26
--- /dev/null
+++ b/devel/py-dill/pkg-descr
@@ -0,0 +1,6 @@
+Dill extends python's 'pickle' module for serializing and de-serializing
+python objects to the majority of the built-in python types. Serialization
+is the process of converting an object to a byte stream, and the inverse
+of which is converting a byte stream back to on python object hierarchy.
+
+WWW: https://pypi.python.org/pypi/dill