aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/qmail/Makefile33
-rw-r--r--mail/qmail/distinfo6
2 files changed, 34 insertions, 5 deletions
diff --git a/mail/qmail/Makefile b/mail/qmail/Makefile
index 27f6b9a2576f..658dc1ad1c79 100644
--- a/mail/qmail/Makefile
+++ b/mail/qmail/Makefile
@@ -178,7 +178,9 @@ OPTIONS+= TLS "SMTP TLS support" on \
XF_QUITASAP "Close SMTP session ASAP (SMTPEXTFORK)" off \
SENDERCHECK4 "LOOSE checks exclusively for RELAY clients" off \
ENHACELOGS "Enhace qmail-smtpd logs (spamcontrol-like)" off \
- GRTDELAY "Add jms1's Greet Delay feature" off
+ GRTDELAY "Add jms1's Greet Delay feature" off \
+ SMTPAUTHUSER "create env SMTPAUTHUSER containing authuser" off\
+ SRS "Sender Rewriting Scheme support" off
LDAP_PARAMS= ALTQUEUE BIGBROTHER BIGTODO BIND_8_COMPAT\
CLEARTEXTPASSWD DASH_EXT DATA_COMPRESS\
@@ -305,16 +307,16 @@ BOOTFILES= home home+df proc proc+df binm1 binm1+df \
CONFIGUREPROGRAMS= install dnsfq hostname dnsip ipmeprint dnsptr
CONFIGURESCRIPTS= config config-fast
-.include "${.CURDIR}/../../Mk/bsd.mail.mk"
+WANT_QMAIL= yes
-.if (${PREFIX} != ${LOCALBASE})
+.include <bsd.port.pre.mk>
+
+.if ${PREFIX} != ${LOCALBASE}
DOCSDIR= ${PREFIX}/doc
.endif
NO_MTREE= yes
-.include <bsd.port.pre.mk>
-
.if ${OSVERSION} >= 900007
. if defined(SLAVE_LDAP)
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-utmpx-ldap
@@ -349,6 +351,13 @@ PLIST_SUB+= EXTERNAL_TODO=""
PLIST_SUB+= EXTERNAL_TODO="@comment "
. endif
+. if defined(WITH_SRS)
+BUILD_DEPENDS= srs:${PORTSDIR}/mail/libsrs2
+MASTER_SITES+= http://qmail-ldap-smtpauthuser.googlecode.com/svn/trunk/:srs_ldap
+SRS_LDAP_PATCH = qmail-ldap-1.03-20060201-SRS.patch
+DISTFILES+= ${SRS_LDAP_PATCH}:srs_ldap
+. endif
+
.endif
.if defined(WITH_SMTP_AUTH_PATCH) && !defined(BARRIER_SMTP_AUTH_PATCH)
@@ -515,6 +524,17 @@ PATCH_SITE_SUBDIR+= garga/qmail/:ldapenhacelog
PATCHFILES+= enhacelogging-ldap-${LDAP_PATCH_DATE}_4.patch:ldapenhacelog
.endif
+.if defined(SLAVE_LDAP) && defined(WITH_SMTPAUTHUSER)
+PATCH_SITES+= http://qmail-ldap-smtpauthuser.googlecode.com/svn/trunk/:smtpauthuser \
+ ${MASTER_SITE_LOCAL:S/$/:smtpauthuser/}
+PATCH_SITE_SUBDIR+= garga/qmail/:smtpauthuser
+. if defined(WITH_ENHACELOGS)
+PATCHFILES+= qmail-1.03-enhaceloggingSMTPAUTHUSER:smtpauthuser
+. else
+PATCHFILES+= SMTPAUTHUSER.patch:smtpauthuser
+. endif
+.endif
+
.if defined(SLAVE_SPAMCONTROL)
MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:ucspi_ssl/} \
http://www.superscript.com/ucspi-ssl/:ucspi_ssl \
@@ -708,6 +728,9 @@ post-patch:
@${REINPLACE_CMD} "s|^#LDAPFLAGS=.*$$|LDAPFLAGS=${LDAPFLAGS}|" \
${WRKSRC}/Makefile
. endif
+. if defined(WITH_SRS)
+ @${PATCH} -d ${WRKSRC} < ${DISTDIR}/${DIST_SUBDIR}/${SRS_LDAP_PATCH}
+. endif
.endif
.if defined(EXT_BIG_TODO_PATCH)
@${PATCH} -d ${WRKSRC} < ${DISTDIR}/${DIST_SUBDIR}/${EXT_BIG_TODO_PATCH}
diff --git a/mail/qmail/distinfo b/mail/qmail/distinfo
index f075b6c52bc2..5548cefdeb87 100644
--- a/mail/qmail/distinfo
+++ b/mail/qmail/distinfo
@@ -78,3 +78,9 @@ SHA256 (qmail/ucspi-ssl-0.70.tar.gz) = 8834aaa83a6862457c853818ce829291285043a55
SIZE (qmail/ucspi-ssl-0.70.tar.gz) = 85111
SHA256 (qmail/ucspi-ssl-0.70_ucspitls-0.6.patch_) = 35ae45bd17a9ecb9cd79c25a751af47af787189c8b833b26d464b47bed1472ac
SIZE (qmail/ucspi-ssl-0.70_ucspitls-0.6.patch_) = 12351
+SHA256 (qmail/SMTPAUTHUSER.patch) = 25d55714df2fc61e2cb6ec7853476e2c15f14207fa2218b5d5b68200450beb9c
+SIZE (qmail/SMTPAUTHUSER.patch) = 347
+SHA256 (qmail/qmail-1.03-enhaceloggingSMTPAUTHUSER) = 4e92498aaa2a6d08bf6535524e5220520f97ca9cf28ff464519f5f6f14ec3779
+SIZE (qmail/qmail-1.03-enhaceloggingSMTPAUTHUSER) = 552
+SHA256 (qmail/qmail-ldap-1.03-20060201-SRS.patch) = 2c54abef2af35e7e7a54b94e06cd002877db3ea96fa06f1b53e6d741a62a2154
+SIZE (qmail/qmail-ldap-1.03-20060201-SRS.patch) = 25883 \ No newline at end of file