aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/gnudoku/Makefile3
-rw-r--r--games/hexxagon/Makefile3
-rw-r--r--games/monster-masher/Makefile3
3 files changed, 6 insertions, 3 deletions
diff --git a/games/gnudoku/Makefile b/games/gnudoku/Makefile
index 340d4ecbab91..10d80250da48 100644
--- a/games/gnudoku/Makefile
+++ b/games/gnudoku/Makefile
@@ -13,7 +13,8 @@ COMMENT= Free program for creating and solving Su Doku puzzles
LIB_DEPENDS= libgtkmm-2.4.so:x11-toolkits/gtkmm24
-USES= gmake pkgconfig
+USES= compiler:c++11-lang gmake pkgconfig
+USE_CXXSTD= c++11
MAKE_ENV= CXXLAGS="${CXXFLAGS}"
MAKE_ARGS= PREFIX="${STAGEDIR}${PREFIX}"
diff --git a/games/hexxagon/Makefile b/games/hexxagon/Makefile
index 17a647998668..cf55433cdc32 100644
--- a/games/hexxagon/Makefile
+++ b/games/hexxagon/Makefile
@@ -10,7 +10,8 @@ COMMENT= Strategy hexagon game
LIB_DEPENDS= libgtkmm-2.4.so:x11-toolkits/gtkmm24
-USES= gmake pkgconfig tar:bzip2
+USES= compiler:c++11-lang gmake pkgconfig tar:bzip2
+USE_CXXSTD= c++11
GNU_CONFIGURE= yes
DESKTOP_ENTRIES="Hexxagon" "Strategy Game" "" \
diff --git a/games/monster-masher/Makefile b/games/monster-masher/Makefile
index 6599f7998328..cc93256b5f1b 100644
--- a/games/monster-masher/Makefile
+++ b/games/monster-masher/Makefile
@@ -16,7 +16,8 @@ LIB_DEPENDS= libgnomecanvasmm-2.6.so:graphics/libgnomecanvasmm26 \
libgconfmm-2.6.so:devel/gconfmm26 \
libglademm-2.4.so:devel/libglademm24
-USES= pathfix gettext gmake pkgconfig tar:bzip2
+USES= compiler:c++11-lang pathfix gettext gmake pkgconfig tar:bzip2
+USE_CXXSTD= c++11
USE_GNOME= gnomeprefix intlhack libgnome esound
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include