aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/ntop/Makefile1
-rw-r--r--net/ntop/files/patch-ntop.h11
2 files changed, 12 insertions, 0 deletions
diff --git a/net/ntop/Makefile b/net/ntop/Makefile
index 382f174a3a32..674f06168672 100644
--- a/net/ntop/Makefile
+++ b/net/ntop/Makefile
@@ -78,6 +78,7 @@ CONFIGURE_ARGS+= --enable-i18n \
.endif
.if defined(WITH_XMLDUMP)
+BROKEN= Does not build with XML dump support
LIB_DEPENDS+= gdome.8:${PORTSDIR}/textproc/gdome2
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include/libxml2 \
-I${LOCALBASE}/include/libxml2/libxml \
diff --git a/net/ntop/files/patch-ntop.h b/net/ntop/files/patch-ntop.h
new file mode 100644
index 000000000000..f12499f5e385
--- /dev/null
+++ b/net/ntop/files/patch-ntop.h
@@ -0,0 +1,11 @@
+--- ntop.h.orig Mon Aug 1 12:07:39 2005
++++ ntop.h Mon Aug 1 12:08:13 2005
+@@ -447,7 +447,7 @@
+ #endif
+
+ #ifndef EMBEDDED
+-#include "rrd.h"
++#include "myrrd/rrd.h"
+ #endif
+
+ #ifdef HAVE_GETOPT_H