aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dns/dnsmasq-devel/Makefile2
-rw-r--r--dns/dnsmasq-devel/files/dnsmasq.in2
-rw-r--r--dns/dnsmasq/Makefile9
-rw-r--r--dns/dnsmasq/distinfo4
-rw-r--r--dns/dnsmasq/files/patch-CVE-2015-329436
-rw-r--r--dns/dnsmasq/files/patch-dnsmasq.conf.example4
-rw-r--r--dns/dnsmasq/pkg-plist4
7 files changed, 11 insertions, 50 deletions
diff --git a/dns/dnsmasq-devel/Makefile b/dns/dnsmasq-devel/Makefile
index b9d740e3444f..2a4bd3819070 100644
--- a/dns/dnsmasq-devel/Makefile
+++ b/dns/dnsmasq-devel/Makefile
@@ -12,7 +12,7 @@ COMMENT= Lightweight DNS forwarder, DHCP, and TFTP server
LICENSE= GPLv2
-#IGNORE= build stable version instead, it is newer than this release candidate
+IGNORE= build stable version instead, it is newer than this release candidate
CONFLICTS_INSTALL=dnsmasq-2*
PORTDOCS= CHANGELOG CHANGELOG.archive FAQ doc.html setup.html
diff --git a/dns/dnsmasq-devel/files/dnsmasq.in b/dns/dnsmasq-devel/files/dnsmasq.in
index ae752c379bae..de9da9249b40 100644
--- a/dns/dnsmasq-devel/files/dnsmasq.in
+++ b/dns/dnsmasq-devel/files/dnsmasq.in
@@ -3,7 +3,7 @@
# $FreeBSD$
#
# PROVIDE: dnsmasq
-# REQUIRE: SERVERS
+# REQUIRE: SERVERS ldconfig
# BEFORE: DAEMON named
# KEYWORD: shutdown
#
diff --git a/dns/dnsmasq/Makefile b/dns/dnsmasq/Makefile
index 76a039d4c650..6b790cef1886 100644
--- a/dns/dnsmasq/Makefile
+++ b/dns/dnsmasq/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= dnsmasq
-DISTVERSION= 2.72
-PORTREVISION= 1
+DISTVERSION= 2.73
PORTEPOCH= 1
CATEGORIES= dns ipv6
MASTER_SITES= http://www.thekelleys.org.uk/dnsmasq/ \
@@ -46,7 +45,7 @@ CFLAGS+= -DNO_IPV6
.endif
.if ${PORT_OPTIONS:MNLS}
-USES+= pkgconfig gettext iconv gmake
+USES+= gettext gmake iconv pkgconfig
LIB_DEPENDS+= libidn.so:${PORTSDIR}/dns/libidn
PLIST_SUB+= NLS=""
ALL_TARGET= all-i18n
@@ -108,8 +107,8 @@ pre-configure: pretty-print-config
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/dnsmasq ${STAGEDIR}${PREFIX}/sbin
- ${INSTALL_DATA} ${WRKSRC}/dnsmasq.conf.example ${STAGEDIR}${PREFIX}/etc
- ${REINPLACE_CMD} -i '' 's}%%PREFIX%%}${PREFIX}}' ${STAGEDIR}${PREFIX}/etc/dnsmasq.conf.example
+ ${INSTALL_DATA} ${WRKSRC}/dnsmasq.conf.example ${STAGEDIR}${PREFIX}/etc/dnsmasq.conf.sample
+ ${REINPLACE_CMD} -i '' 's}%%PREFIX%%}${PREFIX}}' ${STAGEDIR}${PREFIX}/etc/dnsmasq.conf.sample
${INSTALL_MAN} ${WRKSRC}/man/${PORTNAME}.8 ${STAGEDIR}${PREFIX}/man/man8
${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/trust-anchors.conf ${STAGEDIR}${DATADIR}/
diff --git a/dns/dnsmasq/distinfo b/dns/dnsmasq/distinfo
index 4bf9065a7c94..6bc6407905d6 100644
--- a/dns/dnsmasq/distinfo
+++ b/dns/dnsmasq/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dnsmasq-2.72.tar.xz) = 7d0bd23f5d74b3a6b26a75d5ffcf9db81d461b47cbe578cb65a83a98008600b1
-SIZE (dnsmasq-2.72.tar.xz) = 454048
+SHA256 (dnsmasq-2.73.tar.xz) = 0bff81103e53fcab3a3c4d0fd6df1882f9446dca4fa74ff8270e1d2ab872d8f6
+SIZE (dnsmasq-2.73.tar.xz) = 470420
diff --git a/dns/dnsmasq/files/patch-CVE-2015-3294 b/dns/dnsmasq/files/patch-CVE-2015-3294
deleted file mode 100644
index 37d25d308ccd..000000000000
--- a/dns/dnsmasq/files/patch-CVE-2015-3294
+++ /dev/null
@@ -1,36 +0,0 @@
-X-Git-Url: http://thekelleys.org.uk/gitweb/?p=dnsmasq.git;a=blobdiff_plain;f=src%2Frfc1035.c;h=a995ab50d74adde068c8839684f9b3a44f4976d0;hp=7a07b0cee90655e296f57fa79f4d4a3a409b7b89;hb=ad4a8ff7d9097008d7623df8543df435bfddeac8;hpb=04b0ac05377936d121a36873bb63d492cde292c9
-
-diff --git a/src/rfc1035.c b/src/rfc1035.c
-index 7a07b0c..a995ab5 100644
---- a/src/rfc1035.c
-+++ src/rfc1035.c
-@@ -1198,7 +1198,10 @@ unsigned int extract_request(struct dns_header *header, size_t qlen, char *name,
- size_t setup_reply(struct dns_header *header, size_t qlen,
- struct all_addr *addrp, unsigned int flags, unsigned long ttl)
- {
-- unsigned char *p = skip_questions(header, qlen);
-+ unsigned char *p;
-+
-+ if (!(p = skip_questions(header, qlen)))
-+ return 0;
-
- /* clear authoritative and truncated flags, set QR flag */
- header->hb3 = (header->hb3 & ~(HB3_AA | HB3_TC)) | HB3_QR;
-@@ -1214,7 +1217,7 @@ size_t setup_reply(struct dns_header *header, size_t qlen,
- SET_RCODE(header, NOERROR); /* empty domain */
- else if (flags == F_NXDOMAIN)
- SET_RCODE(header, NXDOMAIN);
-- else if (p && flags == F_IPV4)
-+ else if (flags == F_IPV4)
- { /* we know the address */
- SET_RCODE(header, NOERROR);
- header->ancount = htons(1);
-@@ -1222,7 +1225,7 @@ size_t setup_reply(struct dns_header *header, size_t qlen,
- add_resource_record(header, NULL, NULL, sizeof(struct dns_header), &p, ttl, NULL, T_A, C_IN, "4", addrp);
- }
- #ifdef HAVE_IPV6
-- else if (p && flags == F_IPV6)
-+ else if (flags == F_IPV6)
- {
- SET_RCODE(header, NOERROR);
- header->ancount = htons(1);
diff --git a/dns/dnsmasq/files/patch-dnsmasq.conf.example b/dns/dnsmasq/files/patch-dnsmasq.conf.example
index 8fa2d32845e6..2ec44e871198 100644
--- a/dns/dnsmasq/files/patch-dnsmasq.conf.example
+++ b/dns/dnsmasq/files/patch-dnsmasq.conf.example
@@ -1,5 +1,5 @@
---- ./dnsmasq.conf.example.orig 2014-04-09 21:36:53.000000000 +0200
-+++ ./dnsmasq.conf.example 2014-04-15 19:32:54.000000000 +0200
+--- dnsmasq.conf.example.orig 2015-06-12 20:39:11 UTC
++++ dnsmasq.conf.example
@@ -123,6 +123,12 @@
# running another nameserver on the same machine.
#bind-interfaces
diff --git a/dns/dnsmasq/pkg-plist b/dns/dnsmasq/pkg-plist
index f701f671ce37..7b4f201b6fe9 100644
--- a/dns/dnsmasq/pkg-plist
+++ b/dns/dnsmasq/pkg-plist
@@ -1,7 +1,5 @@
sbin/dnsmasq
-@unexec if cmp -s %D/etc/dnsmasq.conf %D/etc/dnsmasq.conf.example ; then rm -f %D/etc/dnsmasq.conf ; fi
-etc/dnsmasq.conf.example
-@exec if [ ! -f %D/etc/dnsmasq.conf ]; then cp -p %D/%F %B/dnsmasq.conf; fi
+@sample etc/dnsmasq.conf.sample
man/man8/dnsmasq.8.gz
%%DATADIR%%/trust-anchors.conf
%%EXAMPLESDIR%%/dnslist/dhcp.css