aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ruby-flex_rb/Makefile52
-rw-r--r--devel/ruby-flex_rb/distinfo2
-rw-r--r--devel/ruby-flex_rb/pkg-descr4
-rw-r--r--devel/ruby-flex_rb/pkg-plist11
5 files changed, 70 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b4441a9cd650..c3199804dd04 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1240,6 +1240,7 @@
SUBDIR += ruby-fam
SUBDIR += ruby-filelock
SUBDIR += ruby-filemagic
+ SUBDIR += ruby-flex_rb
SUBDIR += ruby-gconf2
SUBDIR += ruby-gemfinder
SUBDIR += ruby-gems
diff --git a/devel/ruby-flex_rb/Makefile b/devel/ruby-flex_rb/Makefile
new file mode 100644
index 000000000000..0b4f7818dee1
--- /dev/null
+++ b/devel/ruby-flex_rb/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: flex_rb
+# Date created: 20 July 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= flex_rb
+PORTVERSION= 0.10
+PORTREVISION= 1
+CATEGORIES= devel ruby
+MASTER_SITES= http://www.inf.bme.hu/~pts/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= Ruby flex regular expression matching extension
+
+BROKEN= Does not compile
+EXPIRATION_DATE=2004-08-20
+DEPRECATED= ${BROKEN}
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+DOCS= README
+EXAMPLES= examples/*.rb test*.rb
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
+post-patch:
+ ${RUBY} -i -pe 'gsub /-ansi\b/, ""' ${WRKSRC}/${RUBY_EXTCONF}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODEXAMPLESDIR}/
+.endfor
+ ${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/ruby-flex_rb/distinfo b/devel/ruby-flex_rb/distinfo
new file mode 100644
index 000000000000..06265e91fa65
--- /dev/null
+++ b/devel/ruby-flex_rb/distinfo
@@ -0,0 +1,2 @@
+MD5 (ruby/flex_rb-0.10.tar.gz) = 54a5f2fcf59e2e1663d3f4e7e9b3248e
+SIZE (ruby/flex_rb-0.10.tar.gz) = 145883
diff --git a/devel/ruby-flex_rb/pkg-descr b/devel/ruby-flex_rb/pkg-descr
new file mode 100644
index 000000000000..749974295d48
--- /dev/null
+++ b/devel/ruby-flex_rb/pkg-descr
@@ -0,0 +1,4 @@
+flex_rb is Ruby flex regular expression matching extension.
+
+Author: Szabo Peter <pts@fazekas.hu>
+WWW: http://www.inf.bme.hu/~pts/
diff --git a/devel/ruby-flex_rb/pkg-plist b/devel/ruby-flex_rb/pkg-plist
new file mode 100644
index 000000000000..6a1debff58f4
--- /dev/null
+++ b/devel/ruby-flex_rb/pkg-plist
@@ -0,0 +1,11 @@
+%%RUBY_SITEARCHLIBDIR%%/flex.so
+%%RUBY_SITELIBDIR%%/flex2.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/ex_fr.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/ex_rr.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test01.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test02.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test03.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test04.rb
+%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%