aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/scand/Makefile35
-rw-r--r--net/scand/distinfo1
-rw-r--r--net/scand/pkg-descr4
-rw-r--r--net/scand/pkg-plist5
5 files changed, 46 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index e1bc067931ba..493d26196fed 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -618,6 +618,7 @@
SUBDIR += sambasentinel
SUBDIR += samplicator
SUBDIR += satellite
+ SUBDIR += scand
SUBDIR += scdp
SUBDIR += scli
SUBDIR += scotty3
diff --git a/net/scand/Makefile b/net/scand/Makefile
new file mode 100644
index 000000000000..c29dadae9f20
--- /dev/null
+++ b/net/scand/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: scand
+# Date created: 13 May 2003
+# Whom: sand
+#
+# $FreeBSD$
+#
+
+PORTNAME= scand
+PORTVERSION= 0.11
+CATEGORIES= net
+MASTER_SITES= http://free.babolo.ru/src/
+
+MAINTAINER= sand@links.ru
+COMMENT= Scan detection and blocking daemon
+
+MAN8= scand.8 scandctl.8
+MANCOMPRESSED= yes
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/scandctl ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/scand.8.gz ${MANPREFIX}/man/man8
+ ${INSTALL_MAN} ${WRKSRC}/scandctl.8.gz ${MANPREFIX}/man/man8
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in README README.ru
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/scand/distinfo b/net/scand/distinfo
new file mode 100644
index 000000000000..8b04525dd7ac
--- /dev/null
+++ b/net/scand/distinfo
@@ -0,0 +1 @@
+MD5 (scand-0.11.tar.gz) = 0df9728e8180788cb7df05500a53bfad
diff --git a/net/scand/pkg-descr b/net/scand/pkg-descr
new file mode 100644
index 000000000000..9dd9282bc51a
--- /dev/null
+++ b/net/scand/pkg-descr
@@ -0,0 +1,4 @@
+This program provides a TCP SYN and UDP port scanning detection and blocking
+facility for use with divert(4) sockets under FreeBSD.
+
+WWW: http://www.duty.ru/~sand/scand/
diff --git a/net/scand/pkg-plist b/net/scand/pkg-plist
new file mode 100644
index 000000000000..e29c13dbb93a
--- /dev/null
+++ b/net/scand/pkg-plist
@@ -0,0 +1,5 @@
+bin/scand
+bin/scandctl
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README.ru
+%%PORTDOCS%%@dirrm %%DOCSDIR%%