aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/py-bleach/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/www/py-bleach/Makefile b/www/py-bleach/Makefile
index cb81c155c75a..5dfcc2f5c523 100644
--- a/www/py-bleach/Makefile
+++ b/www/py-bleach/Makefile
@@ -3,16 +3,18 @@
PORTNAME= bleach
PORTVERSION= 1.2.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= koobs@FreeBSD.org
-COMMENT= An easy whitelist-based HTML-sanitizing tool for Python
+COMMENT= Easy whitelist-based HTML-sanitizing tool for Python
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}html5lib==0.95:${PORTSDIR}/www/py-html5lib
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}html5lib>=0.95:${PORTSDIR}/www/py-html5lib
+TEST_DEPENDS:= ${RUN_DEPENDS} \
+ nosetests:${PORTSDIR}/devel/py-nose
USE_GITHUB= yes
USE_PYTHON= yes
@@ -23,9 +25,6 @@ GH_ACCOUNT= jsocol
GH_TAGNAME= v${PORTVERSION}
GH_COMMIT= baf1eac
-TEST_DEPENDS:= ${RUN_DEPENDS} \
- nosetests:${PORTSDIR}/devel/py-nose \
-
regression-test: build
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test