aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--comms/fldigi/Makefile18
-rw-r--r--comms/fldigi/distinfo6
-rw-r--r--comms/fldigi/files/patch-src_misc_newinstall.cxx2
3 files changed, 12 insertions, 14 deletions
diff --git a/comms/fldigi/Makefile b/comms/fldigi/Makefile
index c69540cd677d..d08744384e50 100644
--- a/comms/fldigi/Makefile
+++ b/comms/fldigi/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= fldigi
-PORTVERSION= 4.0.4
+PORTVERSION= 4.0.5
CATEGORIES= comms hamradio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
@@ -17,6 +17,8 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs\
libpng16.so:graphics/png \
libfltk.so:x11-toolkits/fltk \
libfontconfig.so:x11-fonts/fontconfig \
+ libportaudio.so:audio/portaudio \
+ libsndfile.so:audio/libsndfile \
libsamplerate.so:audio/libsamplerate
USE_CXXSTD= gnu++0x
@@ -26,27 +28,20 @@ USE_XORG= x11 xft xext xfixes xcursor xinerama
CONFIGURE_ENV= FLTK_CONFIG="${LOCALBASE}/bin/fltk-config" \
EXTRA_LIBS="-lexecinfo"
-OPTIONS_DEFINE= NATIVE_OPT FLARQ OSS SNDFILE PORTAUDIO PULSEAUDIO HAMLIB NLS DOCS
+OPTIONS_DEFINE= NATIVE_OPT FLARQ PULSEAUDIO HAMLIB NLS DOCS
NATIVE_OPT_DESC= Enable Native Optimizations
FLARQ_DESC= Compile flarq
-OSS_DESC= Support OSS
-SNDFILE_DESC= Support for libsndfile
-PORTAUDIO_DESC= PortAudio support
PULSEAUDIO_DESC= PulseAudio support
HAMLIB_DESC= Support rig control via hamlib
-OPTIONS_DEFAULT= FLARQ OSS HAMLIB
+OPTIONS_DEFAULT= FLARQ HAMLIB
OPTIONS_SUB= yes
NATIVE_OPT_CONFIGURE_ON= --enable-optimizations=native
NATIVE_OPT_CONFIGURE_OFF= --enable-optimizations=none
FLARQ_CONFIGURE_ENABLE= flarq
OSS_CONFIGURE_ENABLE= oss
-SNDFILE_CONFIGURE_WITH= sndfile
-SNDFILE_LIB_DEPENDS= libsndfile.so:audio/libsndfile
-PORTAUDIO_CONFIGURE_WITH= portaudio
-PORTAUDIO_LIB_DEPENDS= libportaudio.so:audio/portaudio
PULSEAUDIO_CONFIGURE_WITH= pulseaudio
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
HAMLIB_CONFIGURE_WITH= hamlib
@@ -56,6 +51,9 @@ NLS_USES= gettext
# Always need asciidoc for man pages
CONFIGURE_ARGS+=--with-asciidoc
+# Upstream as of 4.0.5 always uses portaudio and sndfile now
+# Which makes fldigi configure options portaudio & oss useless
+CONFIGURE_ARGS+=--with-portaudio --disable-oss
post-configure:
# force rebuild of man pages
diff --git a/comms/fldigi/distinfo b/comms/fldigi/distinfo
index 1744aae27f40..7e4e30a38af4 100644
--- a/comms/fldigi/distinfo
+++ b/comms/fldigi/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1495496607
-SHA256 (fldigi-4.0.4.tar.gz) = 9269bdb81c154c7cb60508749bebcbd7c5396962969e58e412d616f1224ef637
-SIZE (fldigi-4.0.4.tar.gz) = 3351853
+TIMESTAMP = 1498172257
+SHA256 (fldigi-4.0.5.tar.gz) = a8a047447b50bbba638791fa2cd9fa265eea2a589a8647f1ec17fb0c284b973d
+SIZE (fldigi-4.0.5.tar.gz) = 3611622
diff --git a/comms/fldigi/files/patch-src_misc_newinstall.cxx b/comms/fldigi/files/patch-src_misc_newinstall.cxx
index 7ee4f210e8b2..01bd3e4a8e1c 100644
--- a/comms/fldigi/files/patch-src_misc_newinstall.cxx
+++ b/comms/fldigi/files/patch-src_misc_newinstall.cxx
@@ -1,4 +1,4 @@
---- src/misc/newinstall.cxx.orig 2017-01-29 13:26:25 UTC
+--- src/misc/newinstall.cxx.orig 2017-05-12 11:32:10 UTC
+++ src/misc/newinstall.cxx
@@ -67,7 +67,7 @@ text[3] = " btu <NAME> <CALL> de <MYCALL
00'>2014-05-111-2/+2 * - Don't remove mtree directoriesamdmi32014-05-101-1/+0 * Support stagebapt2014-05-091-1/+0 * Re-add accidentally removed PLIST_DIRS and PLIST_FILES in r339059.jkim2014-05-072-1/+5 * Update to 4.1.6.jkim2014-05-071-4/+4 * Convert all :U to :tu and :L to :tlbapt2014-05-052-5/+5 * Remove the last @comment $FreeBSD$ from plists.mat2014-04-252-2/+0 * KDE/FreeBSD team presents KDE SC 4.12.4 and KDE Workspace 4.11.8!makc2014-04-032-2/+57 * Use USES=tar:bzip2.jkim2014-03-151-2/+1 * Simplify MASTER_SITES and use USES=tar:xz.jkim2014-03-151-3/+2 * - STAGEDIR supporthrs2014-03-114-13/+8 * Convert k* to USES=zipbapt2014-03-102-2/+2 * KDE/FreeBSD team presents KDE SC 4.12.3 and KDE Workspace 4.11.7!makc2014-03-051-2/+2 * Support stagingehaupt2014-02-271-6/+4 * Update to 4.1.5. It is partially based on the following PR.jkim2014-02-261-4/+4 * Remove trailing whitespaces from category koreanehaupt2014-02-211-1/+1 * Support stagingehaupt2014-02-201-9/+4 * Support stagingehaupt2014-02-201-4/+3 * Support stagingehaupt2014-02-201-8/+3 * Support stagingehaupt2014-02-201-2/+1 * Support stagingehaupt2014-02-201-2/+1 * Support stagingehaupt2014-02-201-5/+4 * KDE/FreeBSD team presents KDE SC 4.12.2 and KDE Workspace 4.11.6!makc2014-02-184-19/+46 * According to the Porter's Handbook (5.12.2.3.) default options must be added toehaupt2014-02-101-0/+3 * - Update gimp-help ports to 2.8.1. Polish translation has been removed, newmakc2014-02-011-3/+3 * Fix properties on pkg-plistbapt2014-01-224-4/+0 * Simplify and support staging.jkim2014-01-086-60/+19 * Stagefy, convert to USES=gmake, and convert LIB_DEPENDS to new format.jkim2014-01-071-13/+5 * - Stagefy, convert to USES=gmake, convert LIB_DEPENDS to new format.jkim2014-01-071-9/+14 * Stagefy, convert to USES=gmake, and convert LIB_DEPENDS to new format.jkim2014-01-072-11/+7 * In preparation for Qt 5 ports:makc2014-01-072-17/+2 * With gtk 2.4.22, immodule cache has moved from gtk.immodules toantoine2014-01-052-13/+5 * - Add a patch from upstram.jkim2013-12-252-2/+17 * - Quiesce portlintehaupt2013-11-291-1/+0 * - Replace QT_.*_REL with QT_.* in PLIST_SUB.avilla2013-11-171-4/+4 * - Update LICENSE accordingly, now that OFL10 and OFL11 are definedtabthorpe2013-11-052-8/+2 * Support stage, use bsdtar to extractbapt2013-11-041-5/+4 * - Update to 4.0.6.jkim2013-10-262-5/+4 * - Remove manual creation and removal of share/applications, as it's now in th...amdmi32013-10-221-1/+0 * Support for this language has ceased within the PHP documentation.edwin2013-10-212-11/+0 * Update Qt to 4.8.5 and Qt Creator to 2.8.0.rakuco2013-10-141-2/+1 * korean/scim-hangul: add <unistd.h> for modern compilersmarino2013-10-031-0/+10 * Remove NO_STAGE to ports natively stage ready shown by a FORCE_STAGE exp-runbapt2013-09-241-1/+0 * Add NO_STAGE all over the place in preparation for the staging support (cat: ...bapt2013-09-2143-56/+56 * Add explicit dependency on pkgconf (20 ports)marino2013-09-121-1/+1 * Use MAKE_ARGS to simplify patches.jkim2013-09-042-11/+1 * Add an explicit dependency on pkgconfbapt2013-09-031-1/+1 * Do not extract object files from the release tarball to simplify build.jkim2013-08-311-1/+1 * Fix build with Glib20 2.36.jkim2013-08-311-3/+4 * Fix build with Clang. Remove defunct master site.jkim2013-08-316-34/+337 * Update to 4.0.5.jkim2013-08-231-4/+4 * - Convert to new perl frameworkaz2013-07-311-1/+1 * - Convert to new perl frameworkaz2013-07-313-3/+6 * KDE3 and QT3 expired on 2013-07-01, remove these ports.rene2013-07-275-540/+0 * - switch simple inline replacement from perl to sedaz2013-07-261-6/+2 * Fix INDEX by really fixing the kde4-l10n portsbapt2013-07-101-0/+1 * KDE4 l10n fixes.rakuco2013-07-102-3/+1 * Add local distfiles.jkim2013-07-091-1/+3 * Add local distfile and trim makefile header.jkim2013-07-091-6/+3 * Update the KDE Software Compilation to 4.10.5.rakuco2013-07-051-2/+2 * Update to KDE SC 4.10.4, proudly presented by the KDE on FreeBSD team.rakuco2013-07-031-2/+2 * - Take over the maintainership. [1]jkim2013-06-251-12/+9 * Update to 1.4.2.jkim2013-06-222-16/+10 * Add an option to build with GTK+ 3.0.jkim2013-06-223-13/+37 * Update to 1.0.0.jkim2013-06-223-10/+15 * Update to 2.1.1.jkim2013-06-222-4/+3 * Remove extra line space.bsam2013-06-221-1/+0 * . delete an article from COMMENT;bsam2013-06-221-6/+2 * . NOPORTDOCS -> PORT_OPTIONS:MDOCS;bsam2013-06-222-6/+10 * Use @${MKDIR} instead of direct use of command command "mkdir -p".bsam2013-06-221-1/+1 * . incorporate PLIST_FILES;bsam2013-06-222-3/+1 * Update to 4.0.4.jkim2013-06-201-4/+4 * Remove redundant lines.jkim2013-06-181-2/+0 * - Re-add ftp.kaist.ac.kr and remove defunct ftp.kreonet.re.kr.jkim2013-06-1815-65/+181 * - Re-add ftp.kaist.ac.kr and remove defunct ftp.kreonet.re.kr.jkim2013-06-1810-33/+5271 * - Re-add ftp.kaist.ac.kr and remove defunct ftp.kreonet.re.kr.jkim2013-06-182-7/+10 * Update e-mail address on behalf of cjh as he personally requested.jkim2013-06-188-28/+8 * Update e-mail address on behalf of cjh as he personally requested.jkim2013-06-187-33/+7 * - Do not remove directories not created by this portmiwi2013-06-142-6/+1 * Add ftp.kaist.ac.kr back and remove ftp.kreonet.re.kr.jkim2013-06-131-2/+3 * - Fix build with Clang.jkim2013-06-135-43/+46 * KDE/FreeBSD team presents KDE SC 4.10.3 ports!makc2013-05-192-4/+2 * Rectify USE_TEX to support both of teTeX and TeXLive.hrs2013-05-123-3/+3 * Add DIST_SUBDIR to fix a fetch error because the distfiles are often replacedhrs2013-05-102-2/+3 * Update to 4.0.3.jkim2013-05-101-4/+4 * Convert from WITHOUT_NLS to PORT_OPTIONS:MNLSbapt2013-05-064-25/+17 * Remove *_DEPENDS from ports which depend on teTeX and add USE_TEX=tetexhrs2013-05-063-9/+4 * Update to 3.03.hrs2013-05-014-29/+55 * Rely on bsdtar to autodetermine the format of the distfiles when possiblebapt2013-04-291-1/+0 * - Convert USE_ICONV=yes to USES=iconvmva2013-04-272-2/+2 * - Convert USE_GETTEXT to USES (part 4)ak2013-04-261-1/+1 * - Convert USE_GETTEXT to USES (part 3)ak2013-04-255-5/+5 * - Convert USE_GETTEXT to USES (part 2)ak2013-04-241-1/+1 * - Convert USE_GETTEXT to USES (part 1)ak2013-04-241-2/+1 * Do not install UnBom font. There was a copyright dispute and the upstreamjkim2013-04-241-2/+2 * Finish converting the whole ports tree to USES=pkgconfigbapt2013-04-232-2/+2 * Update to 4.0.2.jkim2013-04-171-4/+4 * Trim Makefile header.jkim2013-04-171-5/+0 * Update to 3.1.jkim2013-04-173-11/+28 * KDE/FreeBSD team presents KDE SC 4.10.1 ports!makc2013-03-273-15/+69 * - Add explicit pkgconf dependencybdrewery2013-03-241-5/+2 * - convert USE_CMAKE to USESmakc2013-03-231-1/+1 * Update to 4.0.1.jkim2013-03-091-4/+4 * - Get rid of PTHREAD_CFLAGS and PTHREAD_LIBS (category: korean)gahr2013-02-071-2/+2 * Update to 3.6.5.jkim2013-02-051-4/+4 * KDE/FreeBSD team presents KDE SC 4.9.5 ports!makc2013-02-043-26/+13 * KDE/FreeBSD team presents Qt 4.8.4 and QtCreator 2.6.1 ports.makc2013-02-041-6/+1 * - Deprecate QT3, KDE3 and unmaintained ports depending on them. QT 3.3.8beat2012-12-301-0/+3 * - Update to 0.2.0wen2012-12-163-4/+6 * Add fcitx-hangul, Korean input back-end to the Fcitx IM framework.danfe2012-11-085-0/+47 * - Update to 0.4.0.jkim2012-11-035-22/+30 * - Update to 3.5.7.jkim2012-10-272-9/+4 * - Update to 0.5.6.jkim2012-10-092-8/+4 * - Update to 3.5.6.jkim2012-08-241-4/+4 * Fix typos in COMMENTcs2012-07-292-2/+2 * Fix typos in COMMENTcs2012-07-281-1/+1 * - Chase ibus update. [1]jkim2012-07-201-4/+6 * - Update LibreOffice and the language packs to 3.5.5.jkim2012-07-181-4/+4 * - The FreeBSD Office team is proud to announce LibreOffice.org 3.5.4 releasefluffy2012-07-011-4/+4 * Remove BROKEN now that imlib is fixed.kwm2012-06-201-2/+0 * KDE/FreeBSD team presents KDE SC 4.8.4, probably the last release in 4.8.x se...makc2012-06-152-3/+2 * - Mark BROKEN: does not compilepav2012-06-141-0/+2 * - Convert USE_QT_VER=4 and QT_COMPONETS to USE_QT4miwi2012-06-061-2/+1 * - update png to 1.5.10dinoex2012-06-0112-5/+12 * KDE/FreeBSD team presents long awaited KDE SC 4.8.3!makc2012-05-253-8/+12 * Fix PLIST.jkim2012-05-042-0/+2 * Fix newly added ibus-setup-hangul utility and desktop icons.jkim2012-05-013-0/+16 * Update to 1.4.1.jkim2012-05-014-86/+13 * - upgrade to 3.5.2bapt2012-04-234-0/+22 * korean/unfonts-ttf||2012-03-16|Was divided into korean/unfonts-core and korea...dougb2012-03-175-71/+0 * - Bump PORTREVISION to chase the update of multimedia/libvpxashish2012-02-161-0/+1 * The KDE/FreeBSD team is pleased to announce KDE SC 4.7.4, whichavilla2012-01-252-2/+4 * - Fix plistpav2012-01-221-0/+2 * Improve a patch for IBus 1.4.0 from upstream and reduce diff.jkim2012-01-102-11/+51 * Update to 1.3.2.jkim2012-01-105-16/+48 * - Update to 2.1.0.jkim2012-01-044-15/+5 * - Update to 0.99.11.jkim2012-01-043-5/+5 * - update to 0.1.0scheidell2011-12-21