aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--deskutils/gtg/Makefile7
-rw-r--r--net-p2p/deluge/Makefile4
2 files changed, 4 insertions, 7 deletions
diff --git a/deskutils/gtg/Makefile b/deskutils/gtg/Makefile
index 7546f8e882b3..69f103423106 100644
--- a/deskutils/gtg/Makefile
+++ b/deskutils/gtg/Makefile
@@ -17,8 +17,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}configobj>=0:${PORTSDIR}/devel/py-configobj
xset:${PORTSDIR}/x11/xset
FETCH_ARGS= -pRr
-USE_GNOME= desktopfileutils pygobject pygtk2
-USES= gettext
+USE_GNOME= pygobject pygtk2
+USES= gettext desktop-file-utils
INSTALLS_ICONS= yes
USE_PYTHON= -2.7
USE_PYDISTUTILS= yes
@@ -40,7 +40,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/bin|${PREFIX}/bin|' \
${WRKSRC}/org.gnome.GTG.service
-post-install:
- @-update-desktop-database
-
.include <bsd.port.mk>
diff --git a/net-p2p/deluge/Makefile b/net-p2p/deluge/Makefile
index 71ccf53f8cf5..c7751c323a90 100644
--- a/net-p2p/deluge/Makefile
+++ b/net-p2p/deluge/Makefile
@@ -63,7 +63,8 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}dbus>=0.83:${PORTSDIR}/devel/py-dbus \
xdg-utils>=1.0.2:${PORTSDIR}/devel/xdg-utils
PLIST_SUB+= PYGTK=""
-USE_GNOME+= desktopfileutils librsvg2 pygtk2
+USE_GNOME+= librsvg2 pygtk2
+USES+= desktop-file-utils
INSTALLS_ICONS= yes
.else
PLIST_SUB+= PYGTK="@comment "
@@ -106,7 +107,6 @@ post-install:
fi
${INSTALL_DATA} ${WRKSRC}/deluge/data/share/applications/deluge.desktop \
${PREFIX}/share/applications
- @-update-desktop-database
.endif
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}