aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-gettext_i18n_rails_js-rails52/Makefile26
-rw-r--r--devel/rubygem-gettext_i18n_rails_js-rails52/distinfo3
-rw-r--r--devel/rubygem-gettext_i18n_rails_js-rails52/pkg-descr7
4 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 384c1ba53f7c..92dc1e6935e3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5611,6 +5611,7 @@
SUBDIR += rubygem-gettext_i18n_rails
SUBDIR += rubygem-gettext_i18n_rails_js-rails5
SUBDIR += rubygem-gettext_i18n_rails_js-rails50
+ SUBDIR += rubygem-gettext_i18n_rails_js-rails52
SUBDIR += rubygem-gh
SUBDIR += rubygem-gibbler
SUBDIR += rubygem-gio2
diff --git a/devel/rubygem-gettext_i18n_rails_js-rails52/Makefile b/devel/rubygem-gettext_i18n_rails_js-rails52/Makefile
new file mode 100644
index 000000000000..dc0164707404
--- /dev/null
+++ b/devel/rubygem-gettext_i18n_rails_js-rails52/Makefile
@@ -0,0 +1,26 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= gettext_i18n_rails_js
+PORTVERSION= 1.3.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= -rails52
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Make gettext_i18n_rails .po files as JSON
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= rubygem-gettext>=3.0.2:devel/rubygem-gettext \
+ rubygem-gettext_i18n_rails>=0.7.1:devel/rubygem-gettext_i18n_rails \
+ rubygem-po_to_json>=1.0.0:converters/rubygem-po_to_json \
+ rubygem-rails52>=3.2.0:www/rubygem-rails52
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-gettext_i18n_rails_js-rails52/distinfo b/devel/rubygem-gettext_i18n_rails_js-rails52/distinfo
new file mode 100644
index 000000000000..739f5b181914
--- /dev/null
+++ b/devel/rubygem-gettext_i18n_rails_js-rails52/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1496105567
+SHA256 (rubygem/gettext_i18n_rails_js-1.3.0.gem) = 5d10afe4be3639bff78c50a56768c20f39aecdabc580c08aa45573911c2bd687
+SIZE (rubygem/gettext_i18n_rails_js-1.3.0.gem) = 24576
diff --git a/devel/rubygem-gettext_i18n_rails_js-rails52/pkg-descr b/devel/rubygem-gettext_i18n_rails_js-rails52/pkg-descr
new file mode 100644
index 000000000000..a7790d053d39
--- /dev/null
+++ b/devel/rubygem-gettext_i18n_rails_js-rails52/pkg-descr
@@ -0,0 +1,7 @@
+GettextI18nRailsJs extends gettext_i18n_rails, making your .PO files available
+to client side Javascript as JSON. It will find translations inside your .js,
+.coffee, .handlebars and .mustache files, then it will create JSON versions of
+your .PO files so you can serve them with the rest of your assets, thus letting
+you access all your translations offline from client side Javascript.
+
+WWW: https://github.com/webhippie/gettext_i18n_rails_js