aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/openldap24-server/Makefile6
-rw-r--r--net/openldap24-server/distinfo4
-rw-r--r--net/openldap24-server/files/patch-shlib-version17
-rw-r--r--net/openldap24-server/files/patch-smbk5pwd-Makefile41
4 files changed, 33 insertions, 35 deletions
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index d2f0dc203d49..fb42e6337f7d 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= openldap
-DISTVERSION= 2.4.33
+DISTVERSION= 2.4.34
PORTREVISION= ${OPENLDAP_PORTREVISION}
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
@@ -55,8 +55,8 @@ WANT_OPENLDAP_VER?= 24
BROKEN= incompatible OpenLDAP version: ${WANT_OPENLDAP_VER}
.endif
-PORTREVISION_CLIENT= 1
-PORTREVISION_SERVER= 2
+PORTREVISION_CLIENT= 0
+PORTREVISION_SERVER= 0
OPENLDAP_SHLIB_MAJOR= 8
OPTIONS_DEFINE= FETCH
diff --git a/net/openldap24-server/distinfo b/net/openldap24-server/distinfo
index 9aab3b2cfc95..cd7b2fcd45fa 100644
--- a/net/openldap24-server/distinfo
+++ b/net/openldap24-server/distinfo
@@ -1,2 +1,2 @@
-SHA256 (openldap-2.4.33.tgz) = 81e9eca20f17a69a5d15ebc4c66a323106da4f4f80a32105bc7cdea333aca14c
-SIZE (openldap-2.4.33.tgz) = 5463850
+SHA256 (openldap-2.4.34.tgz) = eaab4c4a6b09cc9e60f97e6ef9974f8327d977d1d7af7bc00c2bc5f90dfe0606
+SIZE (openldap-2.4.34.tgz) = 5485028
diff --git a/net/openldap24-server/files/patch-shlib-version b/net/openldap24-server/files/patch-shlib-version
index 2c534c85dfd7..ee22be8d9f21 100644
--- a/net/openldap24-server/files/patch-shlib-version
+++ b/net/openldap24-server/files/patch-shlib-version
@@ -1,14 +1,15 @@
# I have checked all headers and don't think the shared library
# bump is a needed one. We patch it back to prevent large
# rebuild need.
---- build/version.var.orig 2012-10-08 14:35:43.000000000 -0700
-+++ build/version.var 2012-10-08 14:40:08.046064513 -0700
+--- build/version.var.orig 2013-03-03 13:17:30.000000000 -0800
++++ build/version.var 2013-03-11 16:41:23.895046446 -0700
@@ -17,7 +17,7 @@
ol_minor=4
- ol_patch=33
- ol_api_inc=20433
--ol_api_current=10
+ ol_patch=34
+ ol_api_inc=20434
+-ol_api_current=11
+ol_api_current=8
- ol_api_revision=5
- ol_api_age=8
- ol_release_date="2012/10/13"
+ ol_api_revision=0
+-ol_api_age=9
++ol_api_age=8
+ ol_release_date="2013/03/01"
diff --git a/net/openldap24-server/files/patch-smbk5pwd-Makefile b/net/openldap24-server/files/patch-smbk5pwd-Makefile
index 6ad2430d46dc..64d5db8b6772 100644
--- a/net/openldap24-server/files/patch-smbk5pwd-Makefile
+++ b/net/openldap24-server/files/patch-smbk5pwd-Makefile
@@ -1,25 +1,22 @@
---- contrib/slapd-modules/smbk5pwd/Makefile.orig 2008-09-04 20:37:17.000000000 +0400
-+++ contrib/slapd-modules/smbk5pwd/Makefile 2008-09-04 21:06:32.000000000 +0400
-@@ -9,7 +9,6 @@
- # top-level directory of the distribution or, alternatively, at
- # <http://www.OpenLDAP.org/license.html>.
+--- contrib/slapd-modules/smbk5pwd/Makefile.orig 2013-03-03 13:17:30.000000000 -0800
++++ contrib/slapd-modules/smbk5pwd/Makefile 2013-03-11 15:58:44.155103784 -0700
+@@ -24,17 +24,16 @@
+ HEIMDAL_INC = -I/usr/heimdal/include
+ HEIMDAL_LIB = -L/usr/heimdal/lib -lkrb5 -lkadm5srv
--LIBTOOL=../../../libtool
- OPT=-g -O2
- CC=gcc
+-LIBTOOL = $(LDAP_BUILD)/libtool
+ CC = gcc
+ OPT = -g -O2 -Wall
+ # Omit DO_KRB5, DO_SAMBA or DO_SHADOW if you don't want to support it.
+ DEFS = -DDO_KRB5 -DDO_SAMBA -DDO_SHADOW
+ INCS = $(LDAP_INC) $(HEIMDAL_INC) $(SSL_INC)
+-LIBS = $(LDAP_LIB) $(HEIMDAL_LIB) $(SSL_LIB)
++LIBS = $(LDAP_LIB) $(SSL_LIB)
-@@ -24,7 +23,7 @@
- HEIMDAL_LIB=-L/usr/heimdal/lib -lkrb5 -lkadm5srv
- SSL_LIB=-lcrypto
- LDAP_LIB=-lldap_r -llber
--LIBS=$(LDAP_LIB) $(HEIMDAL_LIB) $(SSL_LIB)
-+LIBS=$(LDAP_LIB) $(SSL_LIB) $(LDFLAGS)
-
- all: smbk5pwd.la
-
-@@ -34,4 +33,4 @@
-
- smbk5pwd.la: smbk5pwd.lo
- $(LIBTOOL) --mode=link $(CC) $(OPT) -version-info 0:0:0 \
-- -rpath /usr/local/libexec/openldap -module -o $@ $? $(LIBS)
+ PROGRAMS = smbk5pwd.la
+ LTVER = 0:0:0
+-
+ -rpath $(PREFIX)/libexec/openldap -module -o $@ $? $(LIBS)
+ prefix=/usr/local
+ exec_prefix=$(prefix)
+ ldap_subdir=/openldap