aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/quake2lnx/Makefile3
-rw-r--r--games/quake2lnx/files/patch-src_linux_gl__glx.c9
-rw-r--r--games/quake2lnx/files/patch-src_linux_rw__x11.c9
3 files changed, 20 insertions, 1 deletions
diff --git a/games/quake2lnx/Makefile b/games/quake2lnx/Makefile
index c37719c6a41f..b2a73fbba15f 100644
--- a/games/quake2lnx/Makefile
+++ b/games/quake2lnx/Makefile
@@ -52,7 +52,7 @@ REDBLUE_DESC= Enable 3D glasses rendering
# ###
.if ${PORT_OPTIONS:MX11}
-USE_XORG= x11 xxf86dga
+USE_XORG= x11 xext xxf86dga xxf86vm
MAKE_ARGS+= BUILD_X11=YES
REF_TARGETS+= softx
PLIST_SUB+= X11=""
@@ -62,6 +62,7 @@ PLIST_SUB+= X11="@comment "
.if ${PORT_OPTIONS:MGLX} || ${PORT_OPTIONS:MEYECANDY}
USE_GL= gl
+USE_XORG= x11 xext xxf86dga xxf86vm
MAKE_ARGS+= BUILD_GLX=YES
REF_TARGETS+= glx
PLIST_SUB+= GLX=""
diff --git a/games/quake2lnx/files/patch-src_linux_gl__glx.c b/games/quake2lnx/files/patch-src_linux_gl__glx.c
index 0af126eb74da..0b2dac49b298 100644
--- a/games/quake2lnx/files/patch-src_linux_gl__glx.c
+++ b/games/quake2lnx/files/patch-src_linux_gl__glx.c
@@ -1,5 +1,14 @@
--- src/linux/gl_glx.c.orig Thu Jan 27 19:35:20 2005
+++ src/linux/gl_glx.c Wed Jul 26 22:32:32 2006
+@@ -54,7 +54,7 @@
+ #include <X11/keysym.h>
+ #include <X11/cursorfont.h>
+
+-#include <X11/extensions/xf86dga.h>
++#include <X11/extensions/Xxf86dga.h>
+ #include <X11/extensions/xf86vmode.h>
+ #ifdef Joystick
+ # if defined (__linux__)
@@ -428,7 +428,6 @@
while (XPending(dpy)) {
//ri.Con_Printf(PRINT_ALL,"Bar");
diff --git a/games/quake2lnx/files/patch-src_linux_rw__x11.c b/games/quake2lnx/files/patch-src_linux_rw__x11.c
index 52b74502d5c0..970574787663 100644
--- a/games/quake2lnx/files/patch-src_linux_rw__x11.c
+++ b/games/quake2lnx/files/patch-src_linux_rw__x11.c
@@ -1,5 +1,14 @@
--- src/linux/rw_x11.c.orig Wed Oct 9 03:54:25 2002
+++ src/linux/rw_x11.c Mon Jun 16 23:19:40 2003
+@@ -53,7 +53,7 @@
+ #include <X11/Xatom.h>
+ #include <X11/keysym.h>
+ #include <X11/extensions/XShm.h>
+-#include <X11/extensions/xf86dga.h>
++#include <X11/extensions/Xxf86dga.h>
+ #ifdef OPENGL
+ #include <X11/extensions/xf86vmode.h>
+ #endif
@@ -151,7 +151,7 @@
int config_notify_height;