aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/py-setuptools/Makefile1
-rw-r--r--devel/py-setuptools/files/patch-setuptools_command_install_egg_info.py11
2 files changed, 12 insertions, 0 deletions
diff --git a/devel/py-setuptools/Makefile b/devel/py-setuptools/Makefile
index f1b6cfea0c3a..f1c7d0fa2388 100644
--- a/devel/py-setuptools/Makefile
+++ b/devel/py-setuptools/Makefile
@@ -2,6 +2,7 @@
PORTNAME= setuptools
PORTVERSION= 1.1.7
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/devel/py-setuptools/files/patch-setuptools_command_install_egg_info.py b/devel/py-setuptools/files/patch-setuptools_command_install_egg_info.py
new file mode 100644
index 000000000000..11af1ec18581
--- /dev/null
+++ b/devel/py-setuptools/files/patch-setuptools_command_install_egg_info.py
@@ -0,0 +1,11 @@
+--- setuptools/command/install_egg_info.py.orig 2013-11-27 22:45:15.000000000 +0100
++++ setuptools/command/install_egg_info.py 2013-11-27 22:45:23.000000000 +0100
+@@ -23,7 +23,7 @@
+ ).egg_name()+'.egg-info'
+ self.source = ei_cmd.egg_info
+ self.target = os.path.join(self.install_dir, basename)
+- self.outputs = [self.target]
++ self.outputs = []
+
+ def run(self):
+ self.run_command('egg_info')