aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/php5/Makefile.ext4
-rw-r--r--lang/php53/Makefile.ext4
2 files changed, 4 insertions, 4 deletions
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 75d14fc807c6..7963d745d379 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -237,9 +237,9 @@ CONFIGURE_ARGS+=--enable-pcntl
.endif
.if ${PHP_MODNAME} == "pcre"
-LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+CONFIGURE_ARGS+=--with-pcre-regex=yes
-CONFIGURE_ARGS+=--with-pcre-regex=${LOCALBASE}
+PHP_HEADER_DIRS=pcrelib
.endif
.if ${PHP_MODNAME} == "pdo"
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index 75d14fc807c6..7963d745d379 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -237,9 +237,9 @@ CONFIGURE_ARGS+=--enable-pcntl
.endif
.if ${PHP_MODNAME} == "pcre"
-LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+CONFIGURE_ARGS+=--with-pcre-regex=yes
-CONFIGURE_ARGS+=--with-pcre-regex=${LOCALBASE}
+PHP_HEADER_DIRS=pcrelib
.endif
.if ${PHP_MODNAME} == "pdo"