aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sysutils/e2fsprogs/Makefile4
-rw-r--r--sysutils/e2fsprogs/distinfo6
-rw-r--r--sysutils/e2fsprogs/files/patch-SIGINFO-e2fck_unix.c10
-rw-r--r--sysutils/e2fsprogs/files/patch-configure11
-rw-r--r--sysutils/e2fsprogs/files/patch-misc_Makefile.in2
-rw-r--r--sysutils/e2fsprogs/pkg-descr2
6 files changed, 13 insertions, 22 deletions
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
index fcddc2c8cb7b..18684ff43573 100644
--- a/sysutils/e2fsprogs/Makefile
+++ b/sysutils/e2fsprogs/Makefile
@@ -6,14 +6,14 @@
#
PORTNAME= e2fsprogs
-PORTVERSION= 1.40.8
+PORTVERSION= 1.40.9
PORTREVISION?= 0
CATEGORIES?= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER?= matthias.andree@gmx.de
-COMMENT?= Utilities and library to manipulate ext2/ext3 filesystems
+COMMENT?= Utilities & library to manipulate ext2/ext3/ext4 filesystems
PATCH_STRIP= -p1
USE_LDCONFIG= yes
diff --git a/sysutils/e2fsprogs/distinfo b/sysutils/e2fsprogs/distinfo
index d00747eb68c4..c32050c6d7e3 100644
--- a/sysutils/e2fsprogs/distinfo
+++ b/sysutils/e2fsprogs/distinfo
@@ -1,3 +1,3 @@
-MD5 (e2fsprogs-1.40.8.tar.gz) = 450e2fb2461b2296fec770ff8fc147ed
-SHA256 (e2fsprogs-1.40.8.tar.gz) = 38df70f8b5ba121b11b02101cc399306a199d3c66c8185d8a2c0d07f5688eead
-SIZE (e2fsprogs-1.40.8.tar.gz) = 4102707
+MD5 (e2fsprogs-1.40.9.tar.gz) = 3b785d2cbe374818ca3f89a5cdb6144f
+SHA256 (e2fsprogs-1.40.9.tar.gz) = ab6852230dcb30d75f640125a5d0c7b496bbc31502afdb76528e3bcd4089c9e4
+SIZE (e2fsprogs-1.40.9.tar.gz) = 4092812
diff --git a/sysutils/e2fsprogs/files/patch-SIGINFO-e2fck_unix.c b/sysutils/e2fsprogs/files/patch-SIGINFO-e2fck_unix.c
index 2184e08bfde9..ae1a8d69c868 100644
--- a/sysutils/e2fsprogs/files/patch-SIGINFO-e2fck_unix.c
+++ b/sysutils/e2fsprogs/files/patch-SIGINFO-e2fck_unix.c
@@ -1,6 +1,6 @@
---- e2fsprogs-1.35/e2fsck/unix.c~ Sun Dec 7 18:11:38 2003
-+++ e2fsprogs-1.35/e2fsck/unix.c Tue Feb 24 22:13:52 2004
-@@ -461,6 +461,24 @@
+--- a/e2fsck/unix.c.orig 2008-04-23 20:56:25.000000000 +0200
++++ b/e2fsck/unix.c 2008-04-29 09:05:01.000000000 +0200
+@@ -462,6 +462,24 @@
return 0;
}
@@ -26,7 +26,7 @@
static void reserve_stdio_fds(void)
@@ -493,6 +511,17 @@
- ctx->progress_fd = 0;
+ ctx->progress = e2fsck_update_progress;
}
+static void signal_progress_now(int sig EXT2FS_ATTR((unused)))
@@ -43,7 +43,7 @@
static void signal_progress_off(int sig EXT2FS_ATTR((unused)))
{
e2fsck_t ctx = e2fsck_global_ctx;
-@@ -825,6 +854,8 @@
+@@ -830,6 +859,8 @@
sigaction(SIGUSR1, &sa, 0);
sa.sa_handler = signal_progress_off;
sigaction(SIGUSR2, &sa, 0);
diff --git a/sysutils/e2fsprogs/files/patch-configure b/sysutils/e2fsprogs/files/patch-configure
index 7e15828ae621..095d4e54e476 100644
--- a/sysutils/e2fsprogs/files/patch-configure
+++ b/sysutils/e2fsprogs/files/patch-configure
@@ -1,6 +1,6 @@
--- a/configure.orig Thu Jun 8 15:30:16 2006
+++ b/configure Thu Jun 8 15:30:34 2006
-@@ -9044,7 +9044,7 @@
+@@ -9045,7 +9045,7 @@
@@ -9,12 +9,3 @@
stdlib.h string.h unistd.h sys/param.h
do
as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
-@@ -15105,7 +15105,7 @@
- fi
- { echo "$as_me:$LINENO: checking for unified diff option" >&5
- echo $ECHO_N "checking for unified diff option... $ECHO_C" >&6; }
--if diff -u $0 $0 >& /dev/null ; then
-+if diff -u $0 $0 >/dev/null 2>&1 ; then
- UNI_DIFF_OPTS=-u
- else
- UNI_DIFF_OPTS=-c
diff --git a/sysutils/e2fsprogs/files/patch-misc_Makefile.in b/sysutils/e2fsprogs/files/patch-misc_Makefile.in
index b1c8d6c41d8c..a645b1b88cc8 100644
--- a/sysutils/e2fsprogs/files/patch-misc_Makefile.in
+++ b/sysutils/e2fsprogs/files/patch-misc_Makefile.in
@@ -19,7 +19,7 @@
LPROGS= @E2INITRD_PROG@
-@@ -311,11 +310,9 @@
+@@ -315,11 +314,9 @@
echo " INSTALL_DATA $(man5dir)/$$i"; \
$(INSTALL_DATA) $$i $(DESTDIR)$(man5dir)/$$i; \
done
diff --git a/sysutils/e2fsprogs/pkg-descr b/sysutils/e2fsprogs/pkg-descr
index 5351ee49c6e6..4f5026da62ed 100644
--- a/sysutils/e2fsprogs/pkg-descr
+++ b/sysutils/e2fsprogs/pkg-descr
@@ -1,3 +1,3 @@
-Set of utilities and library to manipulate an ext2 or ext3 filesystem.
+Set of utilities and library to manipulate an ext2, ext3 or ext4 filesystem.
WWW: http://e2fsprogs.sourceforge.net/