aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/fdm/Makefile3
-rw-r--r--mail/fdm/distinfo6
-rw-r--r--mail/fdm/files/patch-fix_cmdline_macros42
-rw-r--r--mail/fdm/files/patch-fix_regex_match_tags23
4 files changed, 4 insertions, 70 deletions
diff --git a/mail/fdm/Makefile b/mail/fdm/Makefile
index 26ec63e04086..54a0dda24837 100644
--- a/mail/fdm/Makefile
+++ b/mail/fdm/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= fdm
-PORTVERSION= 1.3.0.2
-DISTVERSION= 1.3c
+PORTVERSION= 1.4
CATEGORIES= mail
MASTER_SITES= SFE
diff --git a/mail/fdm/distinfo b/mail/fdm/distinfo
index 4d8911b0463a..5644432a8de3 100644
--- a/mail/fdm/distinfo
+++ b/mail/fdm/distinfo
@@ -1,3 +1,3 @@
-MD5 (fdm-1.3c.tar.gz) = 36df8737912f15cb9f695bfb0a983255
-SHA256 (fdm-1.3c.tar.gz) = 75b8f9dd4f48a9498d27a2b3c58ee24ba629f8615b01a5608e78961abb4fb289
-SIZE (fdm-1.3c.tar.gz) = 160993
+MD5 (fdm-1.4.tar.gz) = ca8b17cc9534122fafd9c1ca838cd699
+SHA256 (fdm-1.4.tar.gz) = b02fa366cd541dfa0a467496d00af70db07c4701e97aaa8278c360583a010f81
+SIZE (fdm-1.4.tar.gz) = 168731
diff --git a/mail/fdm/files/patch-fix_cmdline_macros b/mail/fdm/files/patch-fix_cmdline_macros
deleted file mode 100644
index 668111658076..000000000000
--- a/mail/fdm/files/patch-fix_cmdline_macros
+++ /dev/null
@@ -1,42 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## 05fix_cmdline_macros.dpatch by Frank Terbeck <ft@bewatermyfriend.org>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: Quick fix for a bug that breaks macros defined on the command line.
-## Written by Nicholas Marriott (fdm upstream). He will fix this issue
-## the upstream CVS repository as well.
-
-@DPATCH@
-diff -urNad fdm-1.3c~/fdm.c fdm-1.3c/fdm.c
---- fdm-1.3c~/fdm.c Wed Aug 1 11:58:54 2007
-+++ fdm.c Thu Aug 30 14:51:35 2007
-@@ -271,6 +271,8 @@
- conf.queue_high = -1;
- conf.queue_low = -1;
-
-+ TAILQ_INIT(&parse_macros);
-+
- ARRAY_INIT(&conf.incl);
- ARRAY_INIT(&conf.excl);
-
-diff -u ../fdm-1.3c.orig/parse.y ./parse.y
---- ../fdm-1.3c.orig/parse.y Wed Aug 1 11:58:56 2007
-+++ parse.y Thu Aug 30 14:51:25 2007
-@@ -70,8 +70,6 @@
- strb_create(&parse_tags);
- default_tags(&parse_tags, NULL);
-
-- TAILQ_INIT(&parse_macros);
--
- yyparse();
-
- if (!ARRAY_EMPTY(&parse_rulestack))
-@@ -667,7 +665,7 @@
- macro->fixed = 0;
- strlcpy(macro->name, $1, sizeof macro->name);
- TAILQ_INSERT_HEAD(&parse_macros, macro, entry);
-- } else
-+ } else if (!macro->fixed)
- xfree(macro->value.str);
- if (!macro->fixed) {
- macro->type = MACRO_STRING;
diff --git a/mail/fdm/files/patch-fix_regex_match_tags b/mail/fdm/files/patch-fix_regex_match_tags
deleted file mode 100644
index 57f526faf165..000000000000
--- a/mail/fdm/files/patch-fix_regex_match_tags
+++ /dev/null
@@ -1,23 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## 06fix_regex_match_tags.dpatch by Frank Terbeck <ft@bewatermyfriend.org>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: This is a fix for broken behaviour if regex matches are used on
-## messages with a From_ header, in which case the replacement tags
-## (like %1) break.
-## Written by Nicholas Marriott (fdm upstream).
-
-@DPATCH@
-diff -urNad fdm-1.3c~/replace.c fdm-1.3c/replace.c
---- fdm-1.3c~/replace.c Wed Aug 1 11:58:54 2007
-+++ replace.c Thu Aug 30 14:51:35 2007
-@@ -257,7 +257,7 @@ replace(char *src, struct strb *tags, st
- if (!rml->list[idx].valid)
- continue;
-
-- tptr = m->base + rml->list[idx].so;
-+ tptr = m->data + rml->list[idx].so;
- tlen = rml->list[idx].eo - rml->list[idx].so;
- break;
- }
-