aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/csound/Makefile38
-rw-r--r--audio/csound/distinfo4
-rw-r--r--audio/csound/files/patch-H__sysdep.h26
-rw-r--r--audio/csound/files/patch-Opcodes__tl__fractalnoise.cpp18
-rw-r--r--audio/csound/pkg-plist2
5 files changed, 48 insertions, 40 deletions
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
index cf98946c88d6..d3f26b6da8aa 100644
--- a/audio/csound/Makefile
+++ b/audio/csound/Makefile
@@ -6,15 +6,13 @@
#
PORTNAME= csound
-PORTVERSION= 5.17.6
-PORTREVISION= 1
+PORTVERSION= 5.17.11
CATEGORIES= audio lang
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}5/${PORTNAME}${PORTVERSION:R} \
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}5/${PORTNAME}${PORTVERSION} \
SF/${PORTNAME}/${PORTNAME}5/${PORTNAME}${PORTVERSION:R}/manual:manual
DISTNAME= ${PORTNAME:S/c/C/}${PORTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-DIST_SUBDIR= csound
MAINTAINER= ports@FreeBSD.org
COMMENT= Sound synthesizer
@@ -22,16 +20,22 @@ COMMENT= Sound synthesizer
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
+DIST_SUBDIR= csound
BUILD_DEPENDS= ${LOCALBASE}/bin/swig:${PORTSDIR}/devel/swig13 \
${LOCALBASE}/include/gmm/gmm.h:${PORTSDIR}/math/gmm++ \
${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile
-OPTIONS_DEFINE= ALSA LADSPA FLUIDSYNTH JACK OSC PORTAUDIO PULSEAUDIO FLTK
-OPTIONS_DEFAULT= FLTK
-FLTK_DESC= Build FLTK plugin and GUI
-OSC_DESC= Build OSC opcodes
-FLUIDSYNTH_DESC= Build FluidSynth opcodes
+OPTIONS_DEFINE= ALSA DSSI FLUIDSYNTH JACK OSC PORTAUDIO PULSEAUDIO FLTK
+OPTIONS_DEFAULT=FLTK
+ALSA_DESC= Build ALSA I/O module
+DSSI_DESC= Build DSSI/LADSPA host opcodes
+FLUIDSYNTH_DESC=Building FluidSynth opcodes
+JACK_DESC= Build Jack I/O module and opcodes
+OSC_DESC= Build OSC opcodes
+PORTAUDIO_DESC= Build the PortAudio I/O module
+PULSEAUDIO_DESC=Build the PulseAudio I/O module
+FLTK_DESC= Build FLTK plugin and GUI
CONFLICTS_INSTALL= outguess-*
@@ -64,14 +68,14 @@ PLIST_SUB+= ALSA="@comment "
ALSA_H= ##alsa/asoundlib.h##
.endif
-.if ${PORT_OPTIONS:MLADSPA}
+.if ${PORT_OPTIONS:MDSSI}
BUILD_DEPENDS+= dssi>=0:${PORTSDIR}/audio/dssi
RUN_DEPENDS+= dssi>=0:${PORTSDIR}/audio/dssi
-SCONS_ARGS+= buildLADSPA=1
-PLIST_SUB+= LADSPA=""
+SCONS_ARGS+= buildDSSI=1
+PLIST_SUB+= DSSI=""
.else
-SCONS_ARGS+= buildLADSPA=0
-PLIST_SUB+= LADSPA="@comment "
+SCONS_ARGS+= buildDSSI=0
+PLIST_SUB+= DSSI="@comment "
.endif
.if ${PORT_OPTIONS:MFLUIDSYNTH}
@@ -185,12 +189,8 @@ post-patch:
s| pthread | |" ${WRKSRC}/SConstruct
@${REINPLACE_CMD} -e "s|<portaudio.h>|<portaudio2/portaudio.h>|" \
${WRKSRC}/InOut/rtpa.c
- @${REINPLACE_CMD} -e "s|linux/if.h|sys/socket.h|" \
+ @${REINPLACE_CMD} -e "s|linux/if.h|sys/types.h|" \
${WRKSRC}/OOps/remote.c
- @${REINPLACE_CMD} -e "s|values.h|limits.h|" \
- ${WRKSRC}/Opcodes/cpumeter.c
- @${REINPLACE_CMD} -e "s|malloc.h|stdlib.h|" \
- ${WRKSRC}/frontends/CsoundAC/Counterpoint.hpp
post-install:
@${LN} -sf libcsound64.so.5 ${PREFIX}/lib/libcsound64.so
diff --git a/audio/csound/distinfo b/audio/csound/distinfo
index eee4068a104c..dbca3a54162e 100644
--- a/audio/csound/distinfo
+++ b/audio/csound/distinfo
@@ -1,4 +1,4 @@
-SHA256 (csound/Csound5.17.6.tar.gz) = d161acddb4a419fc15097e4f508b7b4e09fadb25b72906cf4f485ca9415fe6d1
-SIZE (csound/Csound5.17.6.tar.gz) = 9132954
+SHA256 (csound/Csound5.17.11.tar.gz) = a86595c4328b63e9b37205b40bf1441182a453451b0ea20558a7777dbc0380b7
+SIZE (csound/Csound5.17.11.tar.gz) = 9152189
SHA256 (csound/Csound5.17_manual_html.zip) = cad3ee307c801c972d9d5f626a79c88dddda6872d8a4af64dd4f3edfe7c0f626
SIZE (csound/Csound5.17_manual_html.zip) = 9621312
diff --git a/audio/csound/files/patch-H__sysdep.h b/audio/csound/files/patch-H__sysdep.h
new file mode 100644
index 000000000000..2e1b26a6162c
--- /dev/null
+++ b/audio/csound/files/patch-H__sysdep.h
@@ -0,0 +1,26 @@
+--- H/sysdep.h.orig 2012-05-29 02:41:30.000000000 +0900
++++ H/sysdep.h 2012-05-31 11:19:28.000000000 +0900
+@@ -96,7 +96,11 @@
+ #define EXP exp
+ #define LOG log
+ #define LOG10 log10
++#if __FreeBSD_version <= 704100 || (__FreeBSD_version >= 800000 && __FreeBSD_version < 802502) || (__FreeBSD_version >= 900000 && __FreeBSD_version < 900027)
++ #define LOG2(x) (log(x) / log(2))
++#else
+ #define LOG2 log2
++#endif
+ #define POWER pow
+ #define SQRT sqrt
+ #define HYPOT hypot
+@@ -122,7 +126,11 @@
+ #define EXP expf
+ #define LOG logf
+ #define LOG10 log10f
++#if __FreeBSD_version <= 704100 || (__FreeBSD_version >= 800000 && __FreeBSD_version < 802502) || (__FreeBSD_version >= 900000 && __FreeBSD_version < 900027)
++ #define LOG2(x) (logf(x) / logf(2))
++#else
+ #define LOG2 log2f
++#endif
+ #define POWER powf
+ #define SQRT sqrtf
+ #define HYPOT hypotf
diff --git a/audio/csound/files/patch-Opcodes__tl__fractalnoise.cpp b/audio/csound/files/patch-Opcodes__tl__fractalnoise.cpp
deleted file mode 100644
index 311b608d4c69..000000000000
--- a/audio/csound/files/patch-Opcodes__tl__fractalnoise.cpp
+++ /dev/null
@@ -1,18 +0,0 @@
---- Opcodes/tl/fractalnoise.cpp.orig 2012-02-06 20:21:34.000000000 +0900
-+++ Opcodes/tl/fractalnoise.cpp 2012-02-08 00:36:44.000000000 +0900
-@@ -34,6 +34,7 @@
- return int(((unsigned int)x) >> n);
- }
-
-+#if 0
- /* VECTOR INTRINSICS */
-
- inline void *aligned_calloc(size_t nmemb, size_t size)
-@@ -41,6 +42,7 @@
- return (void*)((unsigned long)(calloc((nmemb*size)+15,
- (sizeof(char)))+15) & 0xfffffff0);
- }
-+#endif
-
- /* ABSTRACT USER INTERFACE */
-
diff --git a/audio/csound/pkg-plist b/audio/csound/pkg-plist
index b2b9e07b0de3..d587d2067df7 100644
--- a/audio/csound/pkg-plist
+++ b/audio/csound/pkg-plist
@@ -53,7 +53,7 @@ lib/csound/plugins64/libcellular.so
lib/csound/plugins64/libcontrol.so
lib/csound/plugins64/libcs_date.so
lib/csound/plugins64/libdoppler.so
-%%LADSPA%%lib/csound/plugins64/libdssi4cs.so
+%%DSSI%%lib/csound/plugins64/libdssi4cs.so
lib/csound/plugins64/libfareygen.so
%%FLUIDSYNTH%%lib/csound/plugins64/libfluidOpcodes.so
lib/csound/plugins64/libfractalnoise.so