aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/gcc43/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/gcc43/Makefile b/lang/gcc43/Makefile
index 282f0778d7c1..e1ce4c1d4dd2 100644
--- a/lang/gcc43/Makefile
+++ b/lang/gcc43/Makefile
@@ -29,7 +29,7 @@ DISTFILES+= gcc-testsuite-${VERSIONSTRING}${EXTRACT_SUFX}
BUILD_DEPENDS+= runtest:${PORTSDIR}/misc/dejagnu
.endif
-SUFFIX= ${PORTVERSION:C/([0-9]).([0-9]).*/\1\2/}
+SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
LATEST_LINK= gcc${SUFFIX}${PKGNAMESUFFIX}
NOT_FOR_ARCHS= alpha ia64 powerpc
USE_BISON= build
@@ -41,7 +41,7 @@ MAKE_JOBS_SAFE= yes
WANT_GNOME= yes
PATCH_WRKSRC= ${SRCDIR}
-CONFIGURE_SCRIPT= ../${SRCDIR:C/${WRKDIR}//}/configure
+CONFIGURE_SCRIPT= ../${SRCDIR:S/${WRKDIR}\///}/configure
.include <bsd.port.pre.mk>