aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--editors/calligra/Makefile3
-rw-r--r--editors/deforaos-editor/Makefile2
-rw-r--r--editors/fxite/Makefile2
-rw-r--r--editors/libreoffice/Makefile3
-rw-r--r--editors/texworks/Makefile2
-rw-r--r--emulators/dolphin-emu-devel/Makefile3
-rw-r--r--emulators/fceux/Makefile2
-rw-r--r--emulators/higan/Makefile2
-rw-r--r--emulators/open-vm-tools/Makefile2
-rw-r--r--emulators/qemu-devel/Makefile4
-rw-r--r--emulators/qemu-devel/pkg-plist1
-rw-r--r--emulators/tme/Makefile2
-rw-r--r--emulators/vice/Makefile2
13 files changed, 14 insertions, 16 deletions
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index fdb98695830c..c4314e103577 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -42,13 +42,12 @@ USE_ICONV= yes
USE_KDE4= kactivities kdehier kdelibs kdeprefix libkdcraw nepomuk-core \
okular pimlibs attica automoc4 sharedmime soprano
USE_PERL5= yes
-USE_PKGCONFIG= yes
USE_QT4= dbus designer_build gui opengl phonon porting_build qt3support \
qtestlib_build script sql svg webkit xml xmlpatterns \
moc_build qmake_build rcc_build uic_build uic3_build
USE_SQLITE= 3
USE_BZIP2= yes
-USES= cmake:outsource
+USES= cmake:outsource pkgconfig
CMAKE_ARGS= -DCMAKE_INCLUDE_PATH:STRING="${QT_INCDIR} ${LOCALBASE}/include" \
-DIHAVEPATCHEDQT:BOOL=TRUE # To be removed with Qt 4.8.2.
MAKE_JOBS_SAFE= yes
diff --git a/editors/deforaos-editor/Makefile b/editors/deforaos-editor/Makefile
index 8f8f666e5dbe..b94cdce72e9b 100644
--- a/editors/deforaos-editor/Makefile
+++ b/editors/deforaos-editor/Makefile
@@ -17,8 +17,8 @@ LIB_DEPENDS= System:${PORTSDIR}/devel/deforaos-libsystem \
Desktop:${PORTSDIR}/x11/deforaos-libdesktop
MAKE_ARGS= PREFIX=${PREFIX}
+USES= pkgconfig
USE_GNOME= gtk20 desktopfileutils
-USE_PKGCONFIG= build
USE_GETTEXT= yes
.include <bsd.port.mk>
diff --git a/editors/fxite/Makefile b/editors/fxite/Makefile
index 20fc08d4d413..6caf5ba831a9 100644
--- a/editors/fxite/Makefile
+++ b/editors/fxite/Makefile
@@ -21,8 +21,8 @@ GH_ACCOUNT= yetanothergeek
GH_TAGNAME= FXITE-0_91
GH_COMMIT= c2ecac3
+USES= pkgconfig
USE_LUA= yes
-USE_PKGCONFIG= build
USE_AUTOTOOLS= aclocal autoconf automake
ACLOCAL_ARGS= --force -I m4
AUTOMAKE_ARGS= --gnu --add-missing --copy
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index 0022ef7bc3fa..34fcc540edde 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -66,12 +66,11 @@ USE_GL= gl glu
USE_GMAKE= yes
USE_OPENLDAP= yes
USE_PERL5_BUILD= yes
-USE_PKGCONFIG= build
USE_PYTHON= yes
USE_QT4= # empty but required
USE_XORG= xaw xrandr
USE_XZ= yes
-USES= bison
+USES= bison pkgconfig
WANT_GNOME= yes
DISTFILES+= ${PORTNAME}-${LOVERSION}${EXTRACT_SUFX}
diff --git a/editors/texworks/Makefile b/editors/texworks/Makefile
index ea2ce281714a..7d70385e075f 100644
--- a/editors/texworks/Makefile
+++ b/editors/texworks/Makefile
@@ -16,7 +16,7 @@ LICENSE= GPLv2
BUILD_DEPENDS= hunspell:${PORTSDIR}/textproc/hunspell
LIB_DEPENDS= poppler-qt4:${PORTSDIR}/graphics/poppler-qt4
-USE_PKGCONFIG= build
+USES= pkgconfig
USE_QT4= qmake_build gui corelib rcc_build moc_build uic_build \
dbus xml scripttools designer_build
QMAKE_ARGS= INSTALL_PREFIX=${PREFIX} \
diff --git a/emulators/dolphin-emu-devel/Makefile b/emulators/dolphin-emu-devel/Makefile
index bd83d5d08d41..65f3b3ec0fa0 100644
--- a/emulators/dolphin-emu-devel/Makefile
+++ b/emulators/dolphin-emu-devel/Makefile
@@ -22,7 +22,6 @@ LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo \
REVDATE= 20130415
USE_ICONV= yes
-USE_PKGCONFIG= build
USE_SDL= sdl
USE_OPENAL= yes
USE_XORG= ice xext x11 xrandr
@@ -38,7 +37,7 @@ DOS2UNIX_REGEX= .*\.(h|c|cpp)
USE_GCC= 4.6+
.endif
-USES= cmake
+USES= cmake pkgconfig
CMAKE_BUILD_TYPE= Release
# Disable ao (seems buggy) and ALSA (emulated)
CMAKE_ARGS+= -DDISABLE_AO:BOOL=ON \
diff --git a/emulators/fceux/Makefile b/emulators/fceux/Makefile
index a887338d97ed..45318ca6a019 100644
--- a/emulators/fceux/Makefile
+++ b/emulators/fceux/Makefile
@@ -10,7 +10,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}.src
MAINTAINER= c.petrik.sosa@gmail.com
COMMENT= Portable NES/Famicom emulator based on Bero's original FCE
-USE_PKGCONFIG= build
+USES= pkgconfig
USE_SCONS= yes
SCONS_BUILDENV= CC="${CC}" CXX="${CXX}" \
CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
diff --git a/emulators/higan/Makefile b/emulators/higan/Makefile
index 659702c4f870..95979e254995 100644
--- a/emulators/higan/Makefile
+++ b/emulators/higan/Makefile
@@ -10,10 +10,10 @@ DISTNAME= ${PORTNAME}_v${PORTVERSION:S/.//}-source
MAINTAINER= cyberbotx@cyberbotx.com
COMMENT= Nintendo multi-system emulator
+USES= pkgconfig
USE_XZ= yes
USE_GMAKE= yes
USE_GCC= 4.6+
-USE_PKGCONFIG= build
USE_LDCONFIG= yes
ONLY_FOR_ARCHS= i386 amd64
diff --git a/emulators/open-vm-tools/Makefile b/emulators/open-vm-tools/Makefile
index de5c1d03f7dd..c03b2729569a 100644
--- a/emulators/open-vm-tools/Makefile
+++ b/emulators/open-vm-tools/Makefile
@@ -20,8 +20,8 @@ BUILD_VER= 425873
WRKSRC= ${WRKDIR}/open-vm-tools-${RELEASE_VER}-${BUILD_VER}
GNU_CONFIGURE= yes
+USES= pkgconfig
USE_LDCONFIG= yes
-USE_PKGCONFIG= build
CPPFLAGS+= -Wno-deprecated-declarations
CONFIGURE_ARGS+= --without-procps --sysconfdir=${LOCALBASE}/etc
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index e7cbf95688a6..dbc94d0aa26e 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -32,7 +32,7 @@ MAKE_JOBS_SAFE= yes
OPTIONS_DEFINE= SAMBA SDL OPENGL GNUTLS SASL JPEG PNG CDROM_DMA PCAP \
USBREDIR GNS3 ADD_AUDIO CLANG_HACK X86_TARGETS BSD_USER \
- STATIC_LINK
+ STATIC_LINK DOCS
SAMBA_DESC= samba dependency (for -smb)
GNUTLS_DESC= gnutls dependency (vnc encryption)
SASL_DESC= cyrus-sasl dependency (vnc encryption)
@@ -246,7 +246,7 @@ post-configure:
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@(cd ${WRKSRC} && ${COPYTREE_SHARE} docs ${DOCSDIR}/)
.endif
@${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifup.sample ${PREFIX}/etc
diff --git a/emulators/qemu-devel/pkg-plist b/emulators/qemu-devel/pkg-plist
index 65188aa3fe43..c13f699e5aed 100644
--- a/emulators/qemu-devel/pkg-plist
+++ b/emulators/qemu-devel/pkg-plist
@@ -114,3 +114,4 @@ etc/qemu/target-x86_64.conf.sample
%%DATADIR%%/keymaps/tr
@dirrm %%DATADIR%%/keymaps
@dirrmtry %%DATADIR%%
+@dirrmtry %%DOCSDIR%%
diff --git a/emulators/tme/Makefile b/emulators/tme/Makefile
index d748cc22107e..1bbd88a1d754 100644
--- a/emulators/tme/Makefile
+++ b/emulators/tme/Makefile
@@ -22,6 +22,7 @@ LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
xcb:${PORTSDIR}/x11/libxcb
+USES= pkgconfig
USE_GNOME= gdkpixbuf2 gtk20
USE_PERL5= yes
USE_GMAKE= yes
@@ -30,7 +31,6 @@ USE_GETTEXT= yes
USE_AUTOTOOLS= libtool libltdl
CONFIGURE_ENV= ac_cv_have_isinff=no
CONFIGURE_ARGS= --datadir=${WRKDIR}/tmproot --disable-warnings
-USE_PKGCONFIG= build
USE_XORG= pixman x11 xau xcomposite xcursor xdamage xdmcp xext xfixes \
xi xinerama xrandr xrender
USE_LDCONFIG= yes
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index d8bc26156552..7166666892db 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -25,10 +25,10 @@ LIB_DEPENDS+= Xaw3d:${PORTSDIR}/x11-toolkits/Xaw3d
RESTRICTED= ROMs are copyrighted by Commodore Business Machines
LICENSE= GPLv2
+USES= pkgconfig
USE_XORG= xpm ice sm xext xv xt x11 xmu
USE_XORG+= xrender xinerama xi xrandr xcursor xcomposite xdamage xfixes
USE_GMAKE= yes
-USE_PKGCONFIG= yes
GNU_CONFIGURE= yes
MAKE_ENV+= MAKEINFOFLAGS="--no-split"