aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--emulators/qemu-utils/Makefile4
-rw-r--r--emulators/qemu-utils/files/patch-Makefile6
-rw-r--r--emulators/qemu-utils/files/patch-configure2
3 files changed, 6 insertions, 6 deletions
diff --git a/emulators/qemu-utils/Makefile b/emulators/qemu-utils/Makefile
index e6dee95386ae..066ab25e0eeb 100644
--- a/emulators/qemu-utils/Makefile
+++ b/emulators/qemu-utils/Makefile
@@ -22,10 +22,9 @@ DESCR= ${.CURDIR}/pkg-descr
EXTRA_PATCHES= ${.CURDIR}/files/patch-configure
PKGMESSAGE=
-PORTDOCS= qemu-doc.html qemu-doc.txt
+PORTDOCS= interop/* specs/*
CONFIGURE_ARGS?=--localstatedir=/var --extra-ldflags=-L\"${LOCALBASE}/lib\" \
- --disable-libssh2 \
--mandir=${MANPREFIX}/man \
--prefix=${PREFIX} --cc=${CC} --disable-kvm \
--disable-linux-user --disable-linux-aio --disable-xen \
@@ -86,5 +85,6 @@ pre-configure:
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/qemu-*
@${RMDIR} ${STAGEDIR}${DATADIR}
+ @${RM} -rf ${STAGEDIR}${PREFIX}/share
.include "${MASTERDIR}/Makefile"
diff --git a/emulators/qemu-utils/files/patch-Makefile b/emulators/qemu-utils/files/patch-Makefile
index ca87881dba28..95a3110abd24 100644
--- a/emulators/qemu-utils/files/patch-Makefile
+++ b/emulators/qemu-utils/files/patch-Makefile
@@ -41,6 +41,6 @@
- $(INSTALL_DATA) $(SRC_PATH)/pc-bios/keymaps/$$x "$(DESTDIR)$(qemu_datadir)/keymaps"; \
- done
- $(INSTALL_DATA) $(BUILD_DIR)/trace-events-all "$(DESTDIR)$(qemu_datadir)/trace-events-all"
- for d in $(TARGET_DIRS); do \
- $(MAKE) $(SUBDIR_MAKEFLAGS) TARGET_DIR=$$d/ -C $$d $@ || exit 1 ; \
- done
+
+ .PHONY: ctags
+ ctags:
diff --git a/emulators/qemu-utils/files/patch-configure b/emulators/qemu-utils/files/patch-configure
index 3d69293d3e2b..a4ffd8f03a38 100644
--- a/emulators/qemu-utils/files/patch-configure
+++ b/emulators/qemu-utils/files/patch-configure
@@ -4,7 +4,7 @@
##########################################
# pixman support probe
--if test "$want_tools" = "no" -a "$softmmu" = "no"; then
+-if test "$want_tools" = "no" && test "$softmmu" = "no"; then
+if test "$softmmu" = "no"; then
pixman_cflags=
pixman_libs=