aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/clanlib-devel/Makefile4
-rw-r--r--devel/erlslang/Makefile8
-rw-r--r--devel/esdl/Makefile8
-rw-r--r--games/amphetamine/Makefile8
-rw-r--r--textproc/galax/Makefile8
5 files changed, 32 insertions, 4 deletions
diff --git a/devel/clanlib-devel/Makefile b/devel/clanlib-devel/Makefile
index d84c2f903f17..6b73db22b4a6 100644
--- a/devel/clanlib-devel/Makefile
+++ b/devel/clanlib-devel/Makefile
@@ -41,6 +41,10 @@ LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
.if ${OSVERSION} < 500032
BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
diff --git a/devel/erlslang/Makefile b/devel/erlslang/Makefile
index 0e58bdcd51e5..88ecb2f43849 100644
--- a/devel/erlslang/Makefile
+++ b/devel/erlslang/Makefile
@@ -30,6 +30,12 @@ USE_AUTOCONF= yes
GNU_CONFIGURE= yes
CONFIGURE_WRKSRC=${WRKSRC}/config
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
post-build:
@${RM} -r ${WRKSRC}/*/CVS
@${RM} -r ${WRKSRC}/*/.cvsignore
@@ -46,4 +52,4 @@ do-install:
@${CP} -r ${WRKSRC}/src ${PREFIX}/lib/erlang/lib/${DISTNAME}/src
@${LN} -sf ${DISTNAME} ${PREFIX}/lib/erlang/lib/slang
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/esdl/Makefile b/devel/esdl/Makefile
index 44d31159c5b5..e1089cb562bc 100644
--- a/devel/esdl/Makefile
+++ b/devel/esdl/Makefile
@@ -28,7 +28,13 @@ USE_SIZE= yes
ALL_TARGET= target
PLIST_SUB= VERSION="${PORTVERSION}"
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
post-install:
@${LN} -sf ${PORTNAME}-${PORTVERSION} ${PREFIX}/lib/erlang/lib/${PORTNAME}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/amphetamine/Makefile b/games/amphetamine/Makefile
index 76411bf975cd..55ded5f59115 100644
--- a/games/amphetamine/Makefile
+++ b/games/amphetamine/Makefile
@@ -24,8 +24,14 @@ USE_GMAKE= yes
DATAVERSION= 0.8.6
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
post-install:
@cd ${WRKDIR}/amph && ${FIND} . | \
${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/share/amph
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/galax/Makefile b/textproc/galax/Makefile
index 334182909a4c..441179d181c4 100644
--- a/textproc/galax/Makefile
+++ b/textproc/galax/Makefile
@@ -28,10 +28,16 @@ MAKE_ARGS= JAVAHOME=${JAVA_HOME} OCAMLHOME=${LOCALBASE}/lib/ocaml OCAMLBIN=${LOC
PLIST_SUB= GALAX=Galax-${PORTVERSION}
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
pre-patch:
${CP} ${WRKSRC}/config/Makefile.unix ${WRKSRC}/config/Makefile
post-install:
@${SED} 's,PREFIX,${PREFIX},; s,GALAX,Galax-${PORTVERSION},' ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>