aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--irc/bitlbee/Makefile1
-rw-r--r--irc/irssi-otr/Makefile1
-rw-r--r--net-im/climm/Makefile3
-rw-r--r--net-im/mcabber/Makefile1
-rw-r--r--net/kdenetwork4/Makefile4
-rw-r--r--security/kopete-otr/Makefile1
-rw-r--r--security/py-otr/Makefile1
7 files changed, 11 insertions, 1 deletions
diff --git a/irc/bitlbee/Makefile b/irc/bitlbee/Makefile
index e68707440722..26aa32d6c938 100644
--- a/irc/bitlbee/Makefile
+++ b/irc/bitlbee/Makefile
@@ -26,6 +26,7 @@ PORTEXAMPLES= bitlbee.conf motd.txt
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= glib20
+USE_PKGCONFIG= build
USE_RC_SUBR= bitlbee
PKGMESSAGE= ${WRKDIR}/pkg-message
diff --git a/irc/irssi-otr/Makefile b/irc/irssi-otr/Makefile
index bdb92e3150e4..12ca0a8bca47 100644
--- a/irc/irssi-otr/Makefile
+++ b/irc/irssi-otr/Makefile
@@ -27,6 +27,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USE_CMAKE= yes
USE_LDCONFIG= yes
USE_GNOME= glib20
+USE_PKGCONFIG= build
PLIST_FILES= lib/irssi/modules/libotr.so \
%%DOCSDIR%%/LICENSE %%DOCSDIR%%/README
diff --git a/net-im/climm/Makefile b/net-im/climm/Makefile
index a4f11c6e6cf8..2c564d90c30b 100644
--- a/net-im/climm/Makefile
+++ b/net-im/climm/Makefile
@@ -17,6 +17,7 @@ MAINTAINER= johans@FreeBSD.org
COMMENT= CLI-based Multi-Messenger
USE_GMAKE= yes
+USE_PKGCONFIG= build
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
@@ -70,7 +71,7 @@ CONFIGURE_ARGS+= --disable-remote
CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS+= --enable-xmpp --enable-ssl=gnutls \
--with-libgcrypt-prefix=${LOCALBASE}
-CONFIGURE_ENV+= LIBGNUTLS_CONFIG="${LOCALBASE}/bin/pkg-config gnutls"
+CONFIGURE_ENV+= LIBGNUTLS_CONFIG="${LOCALBASE}/bin/pkgconf gnutls"
USE_PKGCONFIG= yes
LIB_DEPENDS+= iksemel:${PORTSDIR}/textproc/iksemel \
gnutls:${PORTSDIR}/security/gnutls \
diff --git a/net-im/mcabber/Makefile b/net-im/mcabber/Makefile
index 3c62060c1734..0eadba58c47f 100644
--- a/net-im/mcabber/Makefile
+++ b/net-im/mcabber/Makefile
@@ -27,6 +27,7 @@ USE_ICONV= yes
USE_GETTEXT= yes
USE_LDCONFIG= yes
USE_NCURSES= yes
+USE_PKGCONFIG= build
USE_GNOME= glib20
MAN1= mcabber.1
diff --git a/net/kdenetwork4/Makefile b/net/kdenetwork4/Makefile
index 3880ae02c332..4cb063dd7653 100644
--- a/net/kdenetwork4/Makefile
+++ b/net/kdenetwork4/Makefile
@@ -45,6 +45,10 @@ USE_KDE4= kdehier kdelibs kdeprefix libkonq pimlibs workspace \
automoc4 ontologies qimageblitz soprano strigi
KDE4_BUILDENV= yes
USE_OPENSSL= yes
+
+# Should probably be build-only, but JIC
+USE_PKGCONFIG= both
+
USE_QT4= dbus gui network qt3support sql xml \
moc_build qmake_build rcc_build uic_build uic3_build
USE_SQLITE= yes
diff --git a/security/kopete-otr/Makefile b/security/kopete-otr/Makefile
index c9e1aef090af..b68e0fe773de 100644
--- a/security/kopete-otr/Makefile
+++ b/security/kopete-otr/Makefile
@@ -29,5 +29,6 @@ USE_AUTOTOOLS= libtool
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+USE_PKGCONFIG= build
.include <bsd.port.mk>
diff --git a/security/py-otr/Makefile b/security/py-otr/Makefile
index fd44bf83d0d6..4f88fea0a6cc 100644
--- a/security/py-otr/Makefile
+++ b/security/py-otr/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= otr:${PORTSDIR}/security/libotr
USE_PYTHON= yes
USE_PYDISTUTILS=yes
+USE_PKGCONFIG= build
PYDISTUTILS_PKGNAME= python-otr
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib