aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/libpreludedb/Makefile15
-rw-r--r--security/libpreludedb/distinfo6
-rw-r--r--security/libpreludedb/files/patch-bindings_perl_PreludeDB.c13
3 files changed, 15 insertions, 19 deletions
diff --git a/security/libpreludedb/Makefile b/security/libpreludedb/Makefile
index 437d9fc0d668..914a20aae82c 100644
--- a/security/libpreludedb/Makefile
+++ b/security/libpreludedb/Makefile
@@ -4,7 +4,7 @@
# $FreeBSD$
PORTNAME= libpreludedb
-PORTVERSION= 0.9.8
+PORTVERSION= 0.9.8.1
CATEGORIES= security
MASTER_SITES= http://www.prelude-ids.org/download/releases/ \
http://www.prelude-ids.org/download/releases/old/
@@ -23,6 +23,14 @@ LDCONFIG_DIRS= %%PREFIX%%/lib \
%%PREFIX%%/lib/libpreludedb/plugins/formats
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+OPTIONS= PERL "Include Perl bindings" off \
+ PYTHON "Include Python bindings" off \
+ MYSQL "Use MySQL backend" on \
+ PGSQL "Use PostgreSQL backend" off \
+ SQLITE "Use SQLite backend" off
+
+.include <bsd.port.pre.mk>
+
.if defined(WITH_PERL)
USE_PERL5= yes
CONFIGURE_ARGS+= --with-perl
@@ -34,6 +42,7 @@ PLIST_SUB+= WITH_PERL="@comment "
.if defined(WITH_PYTHON)
USE_PYTHON= yes
+.include "${PORTSDIR}/Mk/bsd.python.mk"
CONFIGURE_ARGS+= --with-python
PLIST_SUB+= WITH_PYTHON=""
.else
@@ -41,7 +50,7 @@ CONFIGURE_ARGS+= --without-python
PLIST_SUB+= WITH_PYTHON="@comment "
.endif
-.if defined(WITH_MYSQL)
+.if !defined(WITHOUT_MYSQL)
USE_MYSQL= yes
CONFIGURE_ARGS+= --with-mysql
PLIST_SUB+= WITH_MYSQL=""
@@ -80,4 +89,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/docs/api/html/* ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/libpreludedb/distinfo b/security/libpreludedb/distinfo
index 1e9e5d9e61ea..2d944fe1405b 100644
--- a/security/libpreludedb/distinfo
+++ b/security/libpreludedb/distinfo
@@ -1,3 +1,3 @@
-MD5 (libpreludedb-0.9.8.tar.gz) = a9bd45d4d578d1fe8b8865ba066781db
-SHA256 (libpreludedb-0.9.8.tar.gz) = 8481939745a9a89403bd728934cd29300c39c93c58d8f6af6e2f9c1453ddeeb1
-SIZE (libpreludedb-0.9.8.tar.gz) = 719497
+MD5 (libpreludedb-0.9.8.1.tar.gz) = ff433fc4d0e6400a11f4cccf8e03f874
+SHA256 (libpreludedb-0.9.8.1.tar.gz) = 1be094246e579392d47db3c15f5c864c681052528441c8311e92bc7f2693dce9
+SIZE (libpreludedb-0.9.8.1.tar.gz) = 732070
diff --git a/security/libpreludedb/files/patch-bindings_perl_PreludeDB.c b/security/libpreludedb/files/patch-bindings_perl_PreludeDB.c
deleted file mode 100644
index 21b3a2cfd4ab..000000000000
--- a/security/libpreludedb/files/patch-bindings_perl_PreludeDB.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- bindings/perl/PreludeDB.c.orig Tue Jun 6 10:46:03 2006
-+++ bindings/perl/PreludeDB.c Tue Jun 6 10:46:46 2006
-@@ -14,6 +14,10 @@
- * declarations/attributes, and other compiler dependent labels.
- *
- ************************************************************************/
-+/* workaround to build with perl-5.005 */
-+#ifndef INT2PTR
-+# define INT2PTR(type, pointer) (type)(pointer)
-+#endif
-
- /* template workaround for compilers that cannot correctly implement the C++ standard */
- #ifndef SWIGTEMPLATEDISAMBIGUATOR