aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--math/freemat/Makefile5
-rw-r--r--math/scalapack/Makefile6
2 files changed, 2 insertions, 9 deletions
diff --git a/math/freemat/Makefile b/math/freemat/Makefile
index 6739fec2d86b..3a929aaa5b16 100644
--- a/math/freemat/Makefile
+++ b/math/freemat/Makefile
@@ -26,10 +26,7 @@ BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
IGNORE= no MPI support at the moment
.endif
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
FFLAGS+= -O2
USE_GL= yes
diff --git a/math/scalapack/Makefile b/math/scalapack/Makefile
index 14049e6b444e..af64db4fef9b 100644
--- a/math/scalapack/Makefile
+++ b/math/scalapack/Makefile
@@ -30,11 +30,7 @@ LIB_DEPENDS= blacs.1:${PORTSDIR}/math/blacs
CONFLICTS= elmer-mathlibs-1*
USE_LDCONFIG= yes
-
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
ARCH2FIX= PBLAS/SRC PBLAS/SRC/PBBLAS PBLAS/SRC/PTOOLS PBLAS/SRC/PTZBLAS \
REDIST/SRC SRC TOOLS TOOLS/LAPACK