aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--archivers/p5-Compress-LZO/Makefile8
-rw-r--r--archivers/p5-Compress-LZW/Makefile9
-rw-r--r--benchmarks/autobench/Makefile9
-rw-r--r--converters/p5-Convert-Recode/Makefile10
-rw-r--r--converters/p5-WAP-wbxml/Makefile2
-rw-r--r--devel/p5-Class-MakeMethods/Makefile8
-rw-r--r--devel/p5-Class-Tangram/Makefile8
-rw-r--r--devel/p5-ExtUtils-PkgConfig/Makefile2
-rw-r--r--devel/p5-File-Flat/Makefile11
-rw-r--r--devel/p5-Make/Makefile15
-rw-r--r--devel/p5-MooseX-Log-Log4perl/Makefile3
-rw-r--r--devel/p5-MooseX-Types-Path-Class/Makefile3
12 files changed, 26 insertions, 62 deletions
diff --git a/archivers/p5-Compress-LZO/Makefile b/archivers/p5-Compress-LZO/Makefile
index 3ca636cdb6c1..43e82ec32c2f 100644
--- a/archivers/p5-Compress-LZO/Makefile
+++ b/archivers/p5-Compress-LZO/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Compress-LZO
-# Date created: 2006-09-10
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Compress-LZO
PORTVERSION= 1.08
@@ -21,7 +17,7 @@ CFLAGS+= -I${LOCALBASE}/include/lzo
PERL_CONFIGURE= yes
post-patch:
- ${PERL} -pi -e 's,%%LOCALBASE%%,${LOCALBASE},g' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -i '' -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/Makefile.PL
MAN3= Compress::LZO.3
diff --git a/archivers/p5-Compress-LZW/Makefile b/archivers/p5-Compress-LZW/Makefile
index 9ba4be056427..69dc2684b915 100644
--- a/archivers/p5-Compress-LZW/Makefile
+++ b/archivers/p5-Compress-LZW/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Compress-LZW
-# Date created: 2006-07-28
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Compress-LZW
PORTVERSION= 0.01
@@ -20,6 +16,7 @@ PERL_CONFIGURE= yes
MAN3= Compress::LZW.3
post-patch:
- ${PERL} -pi -e 's/\@hattmoward/\\\@hattmoward/' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -i '' -e 's|\@hattmoward|\\@hattmoward|' \
+ ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/benchmarks/autobench/Makefile b/benchmarks/autobench/Makefile
index c6280637e77d..b8f0d5617418 100644
--- a/benchmarks/autobench/Makefile
+++ b/benchmarks/autobench/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: autobench
-# Date created: Oct 20, 2003
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= autobench
PORTVERSION= 2.1.2
@@ -32,7 +27,7 @@ MAN1= autobench.1 autobench_admin.1 autobenchd.1 bench2graph.1 \
post-patch:
.for file in autobench autobench_admin
- @${PERL} -pi -e "s|/etc/|${PREFIX}/etc/|g" ${WRKSRC}/${file}
+ @${REINPLACE_CMD} -i '' -e 's|/etc/|${PREFIX}/etc/|' ${WRKSRC}/${file}
.endfor
.include <bsd.port.mk>
diff --git a/converters/p5-Convert-Recode/Makefile b/converters/p5-Convert-Recode/Makefile
index 5a8dbcf2e04a..3c53cb1497f6 100644
--- a/converters/p5-Convert-Recode/Makefile
+++ b/converters/p5-Convert-Recode/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Convert-Recode
-# Date created: 17 January 2000
-# Whom: Dmitry Sivachenko <dima@Chg.RU>
-#
+# Created by: Dmitry Sivachenko <dima@Chg.RU>
# $FreeBSD$
-#
PORTNAME= Convert-Recode
PORTVERSION= 1.04
@@ -23,7 +19,7 @@ PERL_CONFIGURE= YES
MAN3= Convert::Recode.3
post-patch:
- ${PERL} -pi -e 's#recode -\$$#${LOCALBASE}/bin/recode -\$$#' \
- ${WRKSRC}/Recode.pm
+ @${REINPLACE_CMD} -i '' -e 's|recode -\$$|${LOCALBASE}/bin/recode -\$$|' \
+ ${WRKSRC}/Recode.pm
.include <bsd.port.mk>
diff --git a/converters/p5-WAP-wbxml/Makefile b/converters/p5-WAP-wbxml/Makefile
index bc2731152c14..ffd5706dad57 100644
--- a/converters/p5-WAP-wbxml/Makefile
+++ b/converters/p5-WAP-wbxml/Makefile
@@ -23,7 +23,7 @@ MAN3= WAP::wbxml.3 WAP::wbxml::WbRules.3
post-patch:
.for file in syncml.wbrules.xml wap.wbrules.xml wv.wbrules.xml
- @${PERL} -pi -e 's#\r$$##g' ${WRKSRC}/lib/WAP/wbxml/${file}
+ @${REINPLACE_CMD} -i '' -e 's/^M$$//' ${WRKSRC}/lib/WAP/wbxml/${file}
.endfor
.include <bsd.port.mk>
diff --git a/devel/p5-Class-MakeMethods/Makefile b/devel/p5-Class-MakeMethods/Makefile
index 0e999fdd815e..880fa8a76b8d 100644
--- a/devel/p5-Class-MakeMethods/Makefile
+++ b/devel/p5-Class-MakeMethods/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Class::MakeMethods
-# Date created: 24 Jan 2002
-# Whom: Seamus Venasse <svenasse@polaris.ca>
-#
+# Created by: Seamus Venasse <svenasse@polaris.ca>
# $FreeBSD$
-#
PORTNAME= Class-MakeMethods
PORTVERSION= 1.010
@@ -79,6 +75,6 @@ MAN3= Class::MakeMethods.3 \
post-extract:
@${RM} ${WRKSRC}/benchmark.pl
- @${PERL} -pi -e '$$_="" if m|benchmark.pl|' ${WRKSRC}/MANIFEST
+ @${REINPLACE_CMD} -i '' '/benchmark.pl/d' ${WRKSRC}/MANIFEST
.include <bsd.port.mk>
diff --git a/devel/p5-Class-Tangram/Makefile b/devel/p5-Class-Tangram/Makefile
index f96b7a072c41..7bf4cce91753 100644
--- a/devel/p5-Class-Tangram/Makefile
+++ b/devel/p5-Class-Tangram/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Class-Tangram
-# Date created: 08 April 2002
-# Whom: Sergey Skvortsov <skv@FreeBSD.org>
-#
+# Created by: Sergey Skvortsov <skv@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Class-Tangram
PORTVERSION= 1.57
@@ -25,6 +21,6 @@ MAN3= Class::Tangram.3 Class::Tangram::Containers.3 \
Class::Tangram::Generator.3
post-patch:
- @${PERL} -pi -e 's/\@/\\@/' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -i '' -e 's|\@|\\@|' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/devel/p5-ExtUtils-PkgConfig/Makefile b/devel/p5-ExtUtils-PkgConfig/Makefile
index 7d88fa9b74ad..447784e034bc 100644
--- a/devel/p5-ExtUtils-PkgConfig/Makefile
+++ b/devel/p5-ExtUtils-PkgConfig/Makefile
@@ -18,6 +18,6 @@ PERL_CONFIGURE= yes
MAN3= ExtUtils::PkgConfig.3
post-patch:
- @${PERL} -pi -e '$$_="" if $$.==1' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -i '' -e '1d' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/devel/p5-File-Flat/Makefile b/devel/p5-File-Flat/Makefile
index 9015d7cacabd..a2569e3f2f85 100644
--- a/devel/p5-File-Flat/Makefile
+++ b/devel/p5-File-Flat/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: File-Flat
-# Date created: 11 December 2002
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= File-Flat
PORTVERSION= 1.04
@@ -12,7 +8,7 @@ CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= Implements a flat filesystem
RUN_DEPENDS= p5-Test-ClassAPI>=0:${PORTSDIR}/devel/p5-Test-ClassAPI \
@@ -32,7 +28,4 @@ PERL_CONFIGURE= yes
MAN3= File::Flat.3
-post-patch:
- @${PERL} -pi -e 's/^auto_install.*$$//' ${WRKSRC}/Makefile.PL
-
.include <bsd.port.mk>
diff --git a/devel/p5-Make/Makefile b/devel/p5-Make/Makefile
index f99305c71d7a..e3c4279d51ae 100644
--- a/devel/p5-Make/Makefile
+++ b/devel/p5-Make/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Make
-# Date created: Wed Jan 3 12:14:41 2001
-# Whom: will
-#
+# Created by: will
# $FreeBSD$
-#
PORTNAME= Make
PORTVERSION= 1.00
@@ -11,7 +7,7 @@ CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module implementing 'make' and script
PERL_CONFIGURE= yes
@@ -19,8 +15,9 @@ PERL_CONFIGURE= yes
MAN1= perlmake.1
MAN3= Make.3
-pre-configure:
- ${PERL} -pi -e "s:pmake:perlmake:g" ${WRKSRC}/Makefile.PL
- ${CP} ${WRKSRC}/pmake ${WRKSRC}/perlmake
+post-patch:
+ @${REINPLACE_CMD} -i '' -e 's|pmake|perlmake|' \
+ ${WRKSRC}/Makefile.PL
+ @${CP} ${WRKSRC}/pmake ${WRKSRC}/perlmake
.include <bsd.port.mk>
diff --git a/devel/p5-MooseX-Log-Log4perl/Makefile b/devel/p5-MooseX-Log-Log4perl/Makefile
index eeff34a0d4c0..88270e5ad797 100644
--- a/devel/p5-MooseX-Log-Log4perl/Makefile
+++ b/devel/p5-MooseX-Log-Log4perl/Makefile
@@ -22,7 +22,8 @@ MAN3= MooseX::Log::Log4perl.3 \
MooseX::Log::Log4perl::Easy.3
post-patch:
- @${PERL} -pi -e '$$_="" if m/auto_install/' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -i '' -e '/auto_install;/d' \
+ ${WRKSRC}/Makefile.PL
regression-test: build
cd ${WRKSRC}/ && ${MAKE} test
diff --git a/devel/p5-MooseX-Types-Path-Class/Makefile b/devel/p5-MooseX-Types-Path-Class/Makefile
index 3356e99ffd0b..0de93afa0856 100644
--- a/devel/p5-MooseX-Types-Path-Class/Makefile
+++ b/devel/p5-MooseX-Types-Path-Class/Makefile
@@ -19,7 +19,4 @@ PERL_CONFIGURE= yes
MAN3= MooseX::Types::Path::Class.3
-post-extract:
- @${PERL} -i -ne 'print unless m,build_requires,' ${WRKSRC}/Makefile.PL
-
.include <bsd.port.mk>