aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libdatrie/Makefile26
-rw-r--r--devel/libdatrie/distinfo2
-rw-r--r--devel/libdatrie/pkg-descr10
-rw-r--r--devel/libdatrie/pkg-plist11
5 files changed, 50 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1417d928c637..2505ea07aec0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -936,6 +936,7 @@
SUBDIR += libdaemon
SUBDIR += libdap
SUBDIR += libdasm
+ SUBDIR += libdatrie
SUBDIR += libdbusmenu-qt
SUBDIR += libdfui
SUBDIR += libdict
diff --git a/devel/libdatrie/Makefile b/devel/libdatrie/Makefile
new file mode 100644
index 000000000000..3f74e3ee5ec7
--- /dev/null
+++ b/devel/libdatrie/Makefile
@@ -0,0 +1,26 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libdatrie
+PORTVERSION= 0.2.6
+CATEGORIES= devel
+MASTER_SITES= http://linux.thai.net/pub/thailinux/software/libthai/
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Double-array trie implementation library
+
+LICENSE= LGPL21
+
+USE_XZ= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gnomehack
+USE_ICONV= yes
+USE_LDCONFIG= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+MAN1= trietool-0.2.1
+PORTDOCS= README.migration
+
+.include <bsd.port.mk>
diff --git a/devel/libdatrie/distinfo b/devel/libdatrie/distinfo
new file mode 100644
index 000000000000..ef0cb4fa342f
--- /dev/null
+++ b/devel/libdatrie/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libdatrie-0.2.6.tar.xz) = 8cbefcad704a293d950aeb2fa87b67ee82d2d53f9c57cd1eb0bb9ab8cf3e99ab
+SIZE (libdatrie-0.2.6.tar.xz) = 269288
diff --git a/devel/libdatrie/pkg-descr b/devel/libdatrie/pkg-descr
new file mode 100644
index 000000000000..a7747d9a0a98
--- /dev/null
+++ b/devel/libdatrie/pkg-descr
@@ -0,0 +1,10 @@
+This is an implementation of double-array structure for representing trie,
+as proposed by Junichi Aoe.
+
+Trie is a kind of digital search tree, an efficient indexing method with
+O(1) time complexity for searching. Comparably as efficient as hashing,
+trie also provides flexibility on incremental matching and key spelling
+manipulation. This makes it ideal for lexical analyzers, as well as
+spelling dictionaries.
+
+WWW: http://linux.thai.net/projects/datrie/
diff --git a/devel/libdatrie/pkg-plist b/devel/libdatrie/pkg-plist
new file mode 100644
index 000000000000..cdafd0215d64
--- /dev/null
+++ b/devel/libdatrie/pkg-plist
@@ -0,0 +1,11 @@
+bin/trietool-0.2
+include/datrie/alpha-map.h
+include/datrie/trie.h
+include/datrie/triedefs.h
+include/datrie/typedefs.h
+lib/libdatrie.a
+lib/libdatrie.la
+lib/libdatrie.so
+lib/libdatrie.so.3
+libdata/pkgconfig/datrie-0.2.pc
+@dirrm include/datrie