aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/gimp-gmic-plugin/Makefile15
-rw-r--r--graphics/gimp-gmic-plugin/distinfo4
-rw-r--r--graphics/gimp-gmic-plugin/files/patch-Makefile27
-rw-r--r--graphics/gimp-gmic-plugin/pkg-descr2
4 files changed, 29 insertions, 19 deletions
diff --git a/graphics/gimp-gmic-plugin/Makefile b/graphics/gimp-gmic-plugin/Makefile
index 421fb4b41619..36ac3104e3f2 100644
--- a/graphics/gimp-gmic-plugin/Makefile
+++ b/graphics/gimp-gmic-plugin/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= gmic
-PORTVERSION= 1.5.6.1
+PORTVERSION= 1.5.7.1
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME} \
SF/${PORTNAME}/old
@@ -12,12 +12,12 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= rm@FreeBSD.org
COMMENT= GREYC's Magic Image Converter
-LIB_DEPENDS= GraphicsMagick++.9:${PORTSDIR}/graphics/GraphicsMagick13 \
- IlmImf:${PORTSDIR}/graphics/OpenEXR \
- Magick++:${PORTSDIR}/graphics/ImageMagick \
- avcodec.1:${PORTSDIR}/multimedia/ffmpeg \
- fftw3:${PORTSDIR}/math/fftw3 \
- gimp-2.0:${PORTSDIR}/graphics/gimp-app
+LIB_DEPENDS= libGraphicsMagick++.so:${PORTSDIR}/graphics/GraphicsMagick13 \
+ libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
+ libMagick++.so:${PORTSDIR}/graphics/ImageMagick \
+ libavcodec.so:${PORTSDIR}/multimedia/ffmpeg \
+ libfftw3.so:${PORTSDIR}/math/fftw3 \
+ libgimp-2.0.so:${PORTSDIR}/graphics/gimp-app
OPTIONS_DEFINE= BASH
BASH_DESC= Install programmable completions for Bash
@@ -39,6 +39,7 @@ CXXFLAGS:= ${CXXFLAGS:N-O*:N-pipe}
MAN1= gmic.1
MANCOMPRESSED= yes
+NO_STAGE= yes
.include <bsd.port.options.mk>
diff --git a/graphics/gimp-gmic-plugin/distinfo b/graphics/gimp-gmic-plugin/distinfo
index 921ad39bed0d..6f02888caef8 100644
--- a/graphics/gimp-gmic-plugin/distinfo
+++ b/graphics/gimp-gmic-plugin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gmic_1.5.6.1.tar.gz) = 8399a97f4479a379d8e7fda6a0a73bde0ac120f781111b9ed8a2e28e5a3ed22f
-SIZE (gmic_1.5.6.1.tar.gz) = 2137616
+SHA256 (gmic_1.5.7.1.tar.gz) = bc55fe0309c08fd4b4d97c37704db77965316c818c169ac573b8b12a5a44d42f
+SIZE (gmic_1.5.7.1.tar.gz) = 2174947
diff --git a/graphics/gimp-gmic-plugin/files/patch-Makefile b/graphics/gimp-gmic-plugin/files/patch-Makefile
index 40d5a671958e..bae4f8685ab4 100644
--- a/graphics/gimp-gmic-plugin/files/patch-Makefile
+++ b/graphics/gimp-gmic-plugin/files/patch-Makefile
@@ -1,15 +1,24 @@
---- ./Makefile.orig 2012-12-03 20:57:53.000000000 +0400
-+++ ./Makefile 2012-12-31 13:25:31.000000000 +0400
-@@ -56,7 +56,7 @@
+--- ./Makefile.orig 2013-09-18 14:58:08.000000000 +0400
++++ ./Makefile 2013-09-20 17:26:01.000000000 +0400
+@@ -47,7 +47,7 @@
+ # Set correct variables and paths.
+ #----------------------------------
+ OS := $(shell uname)
+-CC = g++
++CC = c++
+ ifeq ($(OS),Linux)
+ OS = Unix
+ endif
+@@ -62,7 +62,7 @@
USR = /opt/local
else
PLUGINDIR = `gimptool-2.0 --gimpplugindir`/plug-ins
-USR = /usr
+USR = /usr/X11R6
endif
- ifeq ($(OS),MINGW32_NT-5.1)
+ ifeq ($(OSTYPE),msys)
EXE = .exe
-@@ -106,7 +106,7 @@
+@@ -117,7 +117,7 @@
# This requires the presence of the X11 extension include and library files.
# (package 'libx11-dev' on Debian).
XSHM_CFLAGS = -Dcimg_use_xshm
@@ -18,7 +27,7 @@
# Flags to enable image display, using GDI32.
# This requires the presence of the GDI32 include and library files.
-@@ -270,6 +270,13 @@
+@@ -282,6 +282,13 @@
$(MAKE) lib
$(MAKE) zart
else
@@ -31,8 +40,8 @@
+else
ifeq ($(OS),Darwin)
@echo "**"
- @echo "** MacOSX configuration"
-@@ -285,9 +292,10 @@
+ @echo "** MacOSX configuration."
+@@ -297,9 +304,10 @@
$(MAKE) gimp
endif
endif
@@ -44,7 +53,7 @@
lib:
$(MAKE) "CFLAGS=$(STD_LIB_CFLAGS) $(OPT_CFLAGS)" "LDFLAGS+=$(STD_LIB_LDFLAGS) $(OPT_LDFLAGS)" gmic_lib
-@@ -315,6 +323,9 @@
+@@ -324,6 +332,9 @@
linux:
$(MAKE) "CFLAGS=$(STD_UNIX_CFLAGS) $(OPT_CFLAGS)" "LDFLAGS=$(STD_UNIX_LDFLAGS)" "STRIP_EXE=1" gmic_gmic
diff --git a/graphics/gimp-gmic-plugin/pkg-descr b/graphics/gimp-gmic-plugin/pkg-descr
index a77449f99f08..263536b61c0b 100644
--- a/graphics/gimp-gmic-plugin/pkg-descr
+++ b/graphics/gimp-gmic-plugin/pkg-descr
@@ -9,4 +9,4 @@ G'MIC stands for GREYC's Magic Image Converter. This project aims to:
o The interactive plug-in gmic_gimp to bring G'MIC capabilities to the image
retouching software GIMP.
-WWW: http://gmic.sourceforge.net
+WWW: http://gmic.sourceforge.net/